summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-05-20 05:22:18 +0000
committerSven Wegener <swegener@gentoo.org>2005-05-20 05:22:18 +0000
commit47341b0df58926f934344ff39054477402fc90cf (patch)
treeedd31058c2fa5994439fba8742855b38cb02591c /net-nntp
parentManual Manifest commit. (diff)
downloadgentoo-2-47341b0df58926f934344ff39054477402fc90cf.tar.gz
gentoo-2-47341b0df58926f934344ff39054477402fc90cf.tar.bz2
gentoo-2-47341b0df58926f934344ff39054477402fc90cf.zip
Revision bump to pull in a patch from upstream developers that fixes bug #93265.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/klibido/ChangeLog10
-rw-r--r--net-nntp/klibido/files/0.2.3-availablegroups.patch24
-rw-r--r--net-nntp/klibido/files/digest-klibido-0.2.3-r1 (renamed from net-nntp/klibido/files/digest-klibido-0.2.3)0
-rw-r--r--net-nntp/klibido/klibido-0.2.3-r1.ebuild (renamed from net-nntp/klibido/klibido-0.2.3.ebuild)10
4 files changed, 41 insertions, 3 deletions
diff --git a/net-nntp/klibido/ChangeLog b/net-nntp/klibido/ChangeLog
index 779a5003605f..9d724bb3794b 100644
--- a/net-nntp/klibido/ChangeLog
+++ b/net-nntp/klibido/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nntp/klibido
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.10 2005/05/13 13:29:04 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/ChangeLog,v 1.11 2005/05/20 05:22:18 swegener Exp $
+
+*klibido-0.2.3-r1 (20 May 2005)
+
+ 20 May 2005; Sven Wegener <swegener@gentoo.org>
+ +files/0.2.3-availablegroups.patch, -klibido-0.2.3.ebuild,
+ +klibido-0.2.3-r1.ebuild:
+ Revision bump to pull in a patch from upstream developers that fixes bug
+ #93265.
*klibido-0.2.2.2 (19 Mar 2005)
diff --git a/net-nntp/klibido/files/0.2.3-availablegroups.patch b/net-nntp/klibido/files/0.2.3-availablegroups.patch
new file mode 100644
index 000000000000..877b7761e6cd
--- /dev/null
+++ b/net-nntp/klibido/files/0.2.3-availablegroups.patch
@@ -0,0 +1,24 @@
+--- src/availablegroups.cpp 2005-03-01 01:58:57.000000000 +0100
++++ src/availablegroups.cpp.fixed 2005-05-18 10:58:03.000000000 +0200
+@@ -30,8 +30,9 @@
+ int ret;
+ if ((ret=groupDb->open(NULL, dbName, NULL, DB_BTREE, DB_CREATE | DB_THREAD, 0644)) != 0)
+ qDebug("Error opening database: %s", dbEnv->strerror(ret));
++ else qDebug("AvailableGroups database opened");
+ updating=false;
+-
++ m_view=0;
+
+
+ }
+@@ -77,7 +78,9 @@
+ data=new Dbt;
+ Dbc *cursor;
+ Group *g;
+- groupDb->cursor(NULL, &cursor, 0);
++ if (groupDb->cursor(NULL, &cursor, 0))
++ kdDebug() << "Error opening cursor\n";
++ else kdDebug() << "Cursor openend\n";
+ int ret;
+ int count=0;
+ KListViewItem *item;
diff --git a/net-nntp/klibido/files/digest-klibido-0.2.3 b/net-nntp/klibido/files/digest-klibido-0.2.3-r1
index d1761e10eed2..d1761e10eed2 100644
--- a/net-nntp/klibido/files/digest-klibido-0.2.3
+++ b/net-nntp/klibido/files/digest-klibido-0.2.3-r1
diff --git a/net-nntp/klibido/klibido-0.2.3.ebuild b/net-nntp/klibido/klibido-0.2.3-r1.ebuild
index 14cd5c385586..b56b202f9a96 100644
--- a/net-nntp/klibido/klibido-0.2.3.ebuild
+++ b/net-nntp/klibido/klibido-0.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.3.ebuild,v 1.1 2005/05/13 13:29:04 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/klibido/klibido-0.2.3-r1.ebuild,v 1.1 2005/05/20 05:22:18 swegener Exp $
inherit kde versionator
@@ -18,13 +18,19 @@ DEPEND="dev-libs/uulib
need-kde 3
+src_unpack() {
+ kde_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-availablegroups.patch
+}
+
src_compile() {
local libdbver="$(best_version sys-libs/db)"
libdbver="${libdbver/sys-libs\/db-/}"
libdbver="$(get_version_component_range 1-2 ${libdbver})"
myconf="${myconf}
- --datadir=${D}/usr/share
+ --datadir='${D}'/usr/share
--with-extra-includes=/usr/include/db${libdbver}/
$(use_enable debug)
"