summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-26 11:09:44 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-26 11:09:44 +0000
commitaf40a9af82a5757d791c18329f0021a59caf1fcf (patch)
tree683354f305af2007e921c3668c31964e46bf3d75 /net-p2p
parentVersion bump (diff)
downloadgentoo-2-af40a9af82a5757d791c18329f0021a59caf1fcf.tar.gz
gentoo-2-af40a9af82a5757d791c18329f0021a59caf1fcf.tar.bz2
gentoo-2-af40a9af82a5757d791c18329f0021a59caf1fcf.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-0.5.8.7.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 79e90490f780..c172d53a60c5 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.60 2008/03/24 17:07:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.61 2008/03/26 11:09:44 armin76 Exp $
+
+*deluge-0.5.8.7 (26 Mar 2008)
+
+ 26 Mar 2008; Raúl Porcel <armin76@gentoo.org> +deluge-0.5.8.7.ebuild:
+ Version bump
24 Mar 2008; Raúl Porcel <armin76@gentoo.org> deluge-0.5.8.4.ebuild:
x86 stable
diff --git a/net-p2p/deluge/deluge-0.5.8.7.ebuild b/net-p2p/deluge/deluge-0.5.8.7.ebuild
new file mode 100644
index 000000000000..d66437ba9b02
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.5.8.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.8.7.ebuild,v 1.1 2008/03/26 11:09:44 armin76 Exp $
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+S="${WORKDIR}"/${PN}-torrent-${PV}
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+
+ filter-ldflags -Wl,--as-needed
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}