summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2006-12-14 21:46:39 +0000
committerWolfram Schlich <wschlich@gentoo.org>2006-12-14 21:46:39 +0000
commit9ee6360c712f533261bc667cede6f71cf63c4be8 (patch)
treec65844b0805d919cc8ff41d792dba174d3e8f374 /net-print
parentAdd ~x86-fbsd keyword (diff)
downloadgentoo-2-9ee6360c712f533261bc667cede6f71cf63c4be8.tar.gz
gentoo-2-9ee6360c712f533261bc667cede6f71cf63c4be8.tar.bz2
gentoo-2-9ee6360c712f533261bc667cede6f71cf63c4be8.zip
version bump
(Portage version: 2.1.1_pre4-r3)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog8
-rw-r--r--net-print/splix/files/digest-splix-1.0.1_beta23
-rw-r--r--net-print/splix/splix-1.0.1_beta2.ebuild38
3 files changed, 48 insertions, 1 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index 268fac743f35..e604317ae042 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/splix
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.1 2006/12/14 21:29:13 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.2 2006/12/14 21:46:39 wschlich Exp $
+
+*splix-1.0.1_beta2 (14 Dec 2006)
+
+ 14 Dec 2006; Wolfram Schlich <wschlich@gentoo.org>
+ +splix-1.0.1_beta2.ebuild:
+ version bump
*splix-0.0.2 (14 Dec 2006)
diff --git a/net-print/splix/files/digest-splix-1.0.1_beta2 b/net-print/splix/files/digest-splix-1.0.1_beta2
new file mode 100644
index 000000000000..5737284395a9
--- /dev/null
+++ b/net-print/splix/files/digest-splix-1.0.1_beta2
@@ -0,0 +1,3 @@
+MD5 20bdc23199c65249fefa9c198797fa47 splix-1.0.1-beta2.tar.bz2 33474
+RMD160 d9264250e3117eb2f2915734651156d581bc0f74 splix-1.0.1-beta2.tar.bz2 33474
+SHA256 9c762c1f94e80f79252a56ab92c95bc6e9a9aa8af5a88128e236853cc6109999 splix-1.0.1-beta2.tar.bz2 33474
diff --git a/net-print/splix/splix-1.0.1_beta2.ebuild b/net-print/splix/splix-1.0.1_beta2.ebuild
new file mode 100644
index 000000000000..1714e4d0c0af
--- /dev/null
+++ b/net-print/splix/splix-1.0.1_beta2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-1.0.1_beta2.ebuild,v 1.1 2006/12/14 21:46:39 wschlich Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fixMakefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ CUPSFILTERDIR="$(cups-config --serverbin)/filter"
+ CUPSPPDDIR="$(cups-config --datadir)/model"
+
+ dodir "${CUPSFILTERDIR}"
+ dodir "${CUPSPPDDIR}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+}