summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:55:03 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-07-16 14:55:03 +0000
commite72e6c226eb3c663fd5edf9d6c9484eb78a87aa4 (patch)
tree18f396501b6c3fb8d34ae4b1189a797df0f5eaa7 /net-print
parentinitial release (diff)
downloadgentoo-2-e72e6c226eb3c663fd5edf9d6c9484eb78a87aa4.tar.gz
gentoo-2-e72e6c226eb3c663fd5edf9d6c9484eb78a87aa4.tar.bz2
gentoo-2-e72e6c226eb3c663fd5edf9d6c9484eb78a87aa4.zip
initial release
Diffstat (limited to 'net-print')
-rw-r--r--net-print/omni/ChangeLog9
-rw-r--r--net-print/omni/Manifest3
-rw-r--r--net-print/omni/files/digest-omni-0.9.01
-rw-r--r--net-print/omni/omni-0.9.0.ebuild61
4 files changed, 73 insertions, 1 deletions
diff --git a/net-print/omni/ChangeLog b/net-print/omni/ChangeLog
new file mode 100644
index 000000000000..28ca04b31c5a
--- /dev/null
+++ b/net-print/omni/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-print/omni
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/ChangeLog,v 1.1 2003/07/16 14:54:54 lanius Exp $
+
+*omni-0.9.0 (16 Jul 2003)
+
+ 16 Jul 2003; Heinrich Wendel <lanius@gentoo.org> omni-0.9.0.ebuild:
+ initial release, thx to SpanKY <vapier@gentoo.org> (bug #6658)
+
diff --git a/net-print/omni/Manifest b/net-print/omni/Manifest
index 9d53d4dddff6..0b6967518494 100644
--- a/net-print/omni/Manifest
+++ b/net-print/omni/Manifest
@@ -1,2 +1,3 @@
-MD5 cad756d477b72e0288b840502aa5305a omni-0.9.0.ebuild 1322
+MD5 85f004f9212d4dfe10f6095264f82834 omni-0.9.0.ebuild 1546
+MD5 a47297e516d32ef652a340cfdc0ad996 ChangeLog 374
MD5 a0f001bbeec0ec15dff8fac7e9790527 files/digest-omni-0.9.0 63
diff --git a/net-print/omni/files/digest-omni-0.9.0 b/net-print/omni/files/digest-omni-0.9.0
new file mode 100644
index 000000000000..1218724fc372
--- /dev/null
+++ b/net-print/omni/files/digest-omni-0.9.0
@@ -0,0 +1 @@
+MD5 f161e4acc5e4db0669c58274af5d2b10 Omni-0.9.0.tar.gz 4104688
diff --git a/net-print/omni/omni-0.9.0.ebuild b/net-print/omni/omni-0.9.0.ebuild
new file mode 100644
index 000000000000..6c2beb11cd94
--- /dev/null
+++ b/net-print/omni/omni-0.9.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.0.ebuild,v 1.1 2003/07/16 14:54:54 lanius Exp $
+
+DESCRIPTION="Omni provides support for many printers with a pluggable framework (easy to add devices)"
+HOMEPAGE="http://sourceforge.net/projects/omniprint"
+MY_P=${P/o/O}
+SRC_URI="mirror://sourceforge/omniprint/${MY_P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=""
+RDEPEND=">=app-text/ghostscript-7.05.3-r2
+ >=dev-libs/libxml-1.8.6
+ dev-libs/glib
+ cups? ( >=net-print/cups-1.1.14 )
+ X? ( >=dev-cpp/gtkmm-1.2.5 )
+ >=dev-libs/libsigc++-1.01
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+S=${WORKDIR}/Omni
+
+IUSE="cups X ppds foomaticdb static"
+
+src_compile() {
+ use X \
+ && myconf="${myconf} --enable-jobdialog" \
+ || myconf="${myconf} --disable-jobdialog"
+ use cups \
+ && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ ./setupOmni ${myconf} || die
+
+ if [ `use ppds` -a `use cups` ]; then
+ cd CUPS
+ cp Makefile Makefile.1
+ sed -e "s/model\/foomatic/model\/omni/g" Makefile.1 > Makefile
+
+ make generateBuildPPDs || die
+ cd ..
+ fi
+ if [ `use foomaticdb` ]; then
+ cd Foomatic
+ make generateFoomaticData || die
+ cd ..
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ if [ `use foomaticdb` ]; then
+ cd Foomatic
+ make DESTDIR=${D} localInstall || die
+ cd ..
+ fi
+}