summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-10 09:49:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-10 09:49:26 +0000
commitcbb6c805cb3f3ccbf75a681f885910c18e56cae6 (patch)
treeb82f6edad239846a633aad77a7ebb1f837fb4a20 /sci-geosciences/osm2pgsql
parentNew snapshot of trunk. (diff)
downloadgentoo-2-cbb6c805cb3f3ccbf75a681f885910c18e56cae6.tar.gz
gentoo-2-cbb6c805cb3f3ccbf75a681f885910c18e56cae6.tar.bz2
gentoo-2-cbb6c805cb3f3ccbf75a681f885910c18e56cae6.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-geosciences/osm2pgsql')
-rw-r--r--sci-geosciences/osm2pgsql/ChangeLog8
-rw-r--r--sci-geosciences/osm2pgsql/osm2pgsql-0.86.0.ebuild32
2 files changed, 38 insertions, 2 deletions
diff --git a/sci-geosciences/osm2pgsql/ChangeLog b/sci-geosciences/osm2pgsql/ChangeLog
index b746ac589785..cbbd4b0417ab 100644
--- a/sci-geosciences/osm2pgsql/ChangeLog
+++ b/sci-geosciences/osm2pgsql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/osm2pgsql
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm2pgsql/ChangeLog,v 1.14 2014/11/03 13:56:03 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm2pgsql/ChangeLog,v 1.15 2014/11/10 09:49:26 patrick Exp $
+
+*osm2pgsql-0.86.0 (10 Nov 2014)
+
+ 10 Nov 2014; Patrick Lauer <patrick@gentoo.org> +osm2pgsql-0.86.0.ebuild:
+ Bump
03 Nov 2014; Aaron W. Swenson <titanofold@gentoo.org>
osm2pgsql-0.84.0.ebuild, osm2pgsql-99999999.ebuild:
@@ -68,4 +73,3 @@
08 Jul 2009; Tupone Alfredo <tupone@gentoo.org> +metadata.xml,
+osm2pgsql-20090707.ebuild:
New package. Bug #261822 by : renato gallo
-
diff --git a/sci-geosciences/osm2pgsql/osm2pgsql-0.86.0.ebuild b/sci-geosciences/osm2pgsql/osm2pgsql-0.86.0.ebuild
new file mode 100644
index 000000000000..920fc2393658
--- /dev/null
+++ b/sci-geosciences/osm2pgsql/osm2pgsql-0.86.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm2pgsql/osm2pgsql-0.86.0.ebuild,v 1.1 2014/11/10 09:49:26 patrick Exp $
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Converts OSM data to SQL and insert into PostgreSQL db"
+HOMEPAGE="http://wiki.openstreetmap.org/wiki/Osm2pgsql"
+SRC_URI="https://github.com/openstreetmap/${PN}/archive/${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+lua +pbf"
+
+DEPEND="
+ app-arch/bzip2
+ virtual/postgresql
+ dev-libs/libxml2:2
+ sci-libs/geos
+ sci-libs/proj
+ sys-libs/zlib
+ lua? ( dev-lang/lua )
+ pbf? ( dev-libs/protobuf-c )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}