summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:22:34 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:22:34 +0000
commit72be73a402832d7754fc6b82d151f0f6902dc90d (patch)
treec5ed4ee0052ffb7e108dd32a0f7e3ed2842ffd74 /sci-libs/cctbx
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-72be73a402832d7754fc6b82d151f0f6902dc90d.tar.gz
gentoo-2-72be73a402832d7754fc6b82d151f0f6902dc90d.tar.bz2
gentoo-2-72be73a402832d7754fc6b82d151f0f6902dc90d.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cctbx')
-rw-r--r--sci-libs/cctbx/ChangeLog6
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild5
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/sci-libs/cctbx/ChangeLog b/sci-libs/cctbx/ChangeLog
index fd6cfb73ef30..dade3fc0157d 100644
--- a/sci-libs/cctbx/ChangeLog
+++ b/sci-libs/cctbx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cctbx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.17 2011/04/10 14:51:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.18 2011/06/21 08:22:34 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> cctbx-2010.03.29.2334-r3.ebuild,
+ cctbx-2010.03.29.2334-r4.ebuild:
+ Added fortran-2.eclass support
*cctbx-2010.03.29.2334-r4 (10 Apr 2011)
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild
index 2a04eda54f1f..3a9b3d55f2f6 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild,v 1.6 2011/01/23 12:45:41 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r3.ebuild,v 1.7 2011/06/21 08:22:34 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit eutils prefix python toolchain-funcs
+inherit eutils fortran-2 prefix python toolchain-funcs
MY_PV="${PV//./_}"
@@ -34,6 +34,7 @@ MY_S="${WORKDIR}"/cctbx_sources
MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
+ fortran-2_pkg_setup
if use openmp && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild
index dd29d25bda0a..e05020b474d0 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild,v 1.1 2011/04/10 14:51:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r4.ebuild,v 1.2 2011/06/21 08:22:34 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit eutils prefix python toolchain-funcs
+inherit eutils fortran-2 prefix python toolchain-funcs
MY_PV="${PV//./_}"
@@ -34,6 +34,7 @@ MY_S="${WORKDIR}"/cctbx_sources
MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
+ fortran-2_pkg_setup
if use openmp && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"