summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-24 11:01:47 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-24 11:01:47 +0000
commit082b165dc44ff714caa05adfb10339c2f1e90ee1 (patch)
tree166b5475e1a026de8e1695b66d1ec3e23e87060a /sci-libs/punc
parentVersion bump (diff)
downloadgentoo-2-082b165dc44ff714caa05adfb10339c2f1e90ee1.tar.gz
gentoo-2-082b165dc44ff714caa05adfb10339c2f1e90ee1.tar.bz2
gentoo-2-082b165dc44ff714caa05adfb10339c2f1e90ee1.zip
Use cleanly pkg-config to detect blas
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/punc')
-rw-r--r--sci-libs/punc/ChangeLog6
-rw-r--r--sci-libs/punc/files/1.5-linking.patch46
-rw-r--r--sci-libs/punc/metadata.xml10
-rw-r--r--sci-libs/punc/punc-1.5.ebuild3
4 files changed, 45 insertions, 20 deletions
diff --git a/sci-libs/punc/ChangeLog b/sci-libs/punc/ChangeLog
index 9f1085335eb4..aff3ed598753 100644
--- a/sci-libs/punc/ChangeLog
+++ b/sci-libs/punc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/punc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.13 2011/06/21 14:46:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/ChangeLog,v 1.14 2011/11/24 11:01:47 jlec Exp $
+
+ 24 Nov 2011; Justin Lecher <jlec@gentoo.org> files/1.5-linking.patch,
+ punc-1.5.ebuild, metadata.xml:
+ Use cleanly pkg-config to detect blas
21 Jun 2011; Justin Lecher <jlec@gentoo.org> punc-0.2_p1.ebuild,
punc-1.4-r1.ebuild, punc-1.5.ebuild:
diff --git a/sci-libs/punc/files/1.5-linking.patch b/sci-libs/punc/files/1.5-linking.patch
index fb12a29e48e1..9e5d5a8ced69 100644
--- a/sci-libs/punc/files/1.5-linking.patch
+++ b/sci-libs/punc/files/1.5-linking.patch
@@ -1,10 +1,10 @@
- configure.ac | 29 ++++++++++++-----------------
+ configure.ac | 35 +++++++++++++++++------------------
src/aaa_lib/Makefile.am | 7 +++----
src/pmg/Makefile.am | 1 +
- 3 files changed, 16 insertions(+), 21 deletions(-)
+ 3 files changed, 21 insertions(+), 22 deletions(-)
diff --git a/configure.ac b/configure.ac
-index 1295a9f..e996eb0 100644
+index 1295a9f..f8fd97c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,8 @@ AC_LANG_C
@@ -16,16 +16,36 @@ index 1295a9f..e996eb0 100644
AM_PROG_LIBTOOL
dnl 3. checks for libraries
-@@ -358,7 +360,7 @@ else
+@@ -341,6 +343,10 @@ if test -n "${blas}"; then
+ else
+ AC_MSG_RESULT([no ...poking around])
+
++ PKG_CHECK_MODULES([BLAS],[blas],[
++ blas_lib=${BLAS_LIBS}
++ blas=""
++ ],[
+ dnl # BLAS library location ENV specification
+ AC_MSG_CHECKING([whether your environment defines FETK_BLAS_LIBRARY])
+ if test -n "${FETK_BLAS_LIBRARY}"; then
+@@ -358,7 +364,7 @@ else
AC_CHECK_LIB(blas,dscal_,
[blas_use="yes";blas_lib="${blas_lib_path}-lblas"],
[blas_use="";blas_lib=""],
- [${blas_lib_path}-lblas -lvf2c])
-+ [${blas_lib_path}-lblas])
++ [${blas_lib_path} $(BLAS_LIBS)])
if test -z "${blas_use}"; then
AC_MSG_RESULT([** BLAS library missing ...will BUILD **])
blas="blas";
-@@ -414,7 +416,7 @@ dnl lapack_use="";
+@@ -368,7 +374,7 @@ else
+ fi
+
+ dnl # Return LDFLAGS to normal
+- LDFLAGS=${LDFLAGS_SAVE};
++ LDFLAGS=${LDFLAGS_SAVE};])
+ fi
+
+ dnl # Final decisions on BLAS
+@@ -414,7 +420,7 @@ dnl lapack_use="";
dnl AC_CHECK_LIB(lapack,dsysv_,
dnl [lapack_use="yes";lapack_lib="${lapack_lib_path}-llapack"],
dnl [lapack_use="";lapack_lib=""],
@@ -34,7 +54,7 @@ index 1295a9f..e996eb0 100644
dnl if test -z "${lapack_use}"; then
dnl AC_MSG_RESULT([** LAPACK library missing ...will BUILD **])
dnl lapack="lapack";
-@@ -466,10 +468,10 @@ else
+@@ -466,10 +472,10 @@ else
LDFLAGS_SAVE=${LDFLAGS};
LDFLAGS=${amd_lib_path};
amd_use="";
@@ -47,7 +67,7 @@ index 1295a9f..e996eb0 100644
if test -z "${amd_use}"; then
AC_MSG_RESULT([** AMD library missing ...will BUILD **])
amd="amd";
-@@ -521,10 +523,10 @@ else
+@@ -521,10 +527,10 @@ else
LDFLAGS_SAVE=${LDFLAGS};
LDFLAGS=${umfpack_lib_path};
umfpack_use="";
@@ -60,7 +80,7 @@ index 1295a9f..e996eb0 100644
if test -z "${umfpack_use}"; then
AC_MSG_RESULT([** UMFPACK library missing ...will BUILD **])
umfpack="umfpack";
-@@ -579,7 +581,7 @@ else
+@@ -579,7 +585,7 @@ else
AC_CHECK_LIB(superlu,Destroy_SuperMatrix_Store,
[superlu_use="yes";superlu_lib="${superlu_lib_path}-lsuperlu"],
[superlu_use="";superlu_lib=""],
@@ -69,7 +89,7 @@ index 1295a9f..e996eb0 100644
if test -z "${superlu_use}"; then
AC_MSG_RESULT([** SUPERLU library missing ...will BUILD **])
superlu="superlu";
-@@ -635,7 +637,7 @@ dnl arpack_use="";
+@@ -635,7 +641,7 @@ dnl arpack_use="";
dnl AC_CHECK_LIB(arpack,dsgets_,
dnl [arpack_use="yes";arpack_lib="${arpack_lib_path}-larpack"],
dnl [arpack_use="";arpack_lib=""],
@@ -78,7 +98,7 @@ index 1295a9f..e996eb0 100644
dnl if test -z "${arpack_use}"; then
dnl AC_MSG_RESULT([** ARPACK library missing ...will BUILD **])
dnl arpack="arpack";
-@@ -691,7 +693,7 @@ dnl cgcode_use="";
+@@ -691,7 +697,7 @@ dnl cgcode_use="";
dnl AC_CHECK_LIB(cgcode,scgdrv_,
dnl [cgcode_use="yes";cgcode_lib="${cgcode_lib_path}-lcgcode"],
dnl [cgcode_use="";cgcode_lib=""],
@@ -87,7 +107,7 @@ index 1295a9f..e996eb0 100644
dnl if test -z "${cgcode_use}"; then
dnl AC_MSG_RESULT([** CGCODE library missing ...will BUILD **])
dnl cgcode="cgcode";
-@@ -747,7 +749,7 @@ dnl pmg_use="";
+@@ -747,7 +753,7 @@ dnl pmg_use="";
dnl AC_CHECK_LIB(pmg,buildg_,
dnl [pmg_use="yes";pmg_lib="${pmg_lib_path}-lpmg"],
dnl [pmg_use="";pmg_lib=""],
@@ -96,7 +116,7 @@ index 1295a9f..e996eb0 100644
dnl if test -z "${pmg_use}"; then
dnl AC_MSG_RESULT([** PMG library missing ...will BUILD **])
dnl pmg="pmg";
-@@ -986,13 +988,6 @@ AC_OUTPUT([
+@@ -986,13 +992,6 @@ AC_OUTPUT([
src/base/Makefile
src/vf2c/Makefile
diff --git a/sci-libs/punc/metadata.xml b/sci-libs/punc/metadata.xml
index cc35dc3a4a07..6a2ed5438995 100644
--- a/sci-libs/punc/metadata.xml
+++ b/sci-libs/punc/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
PUNC (Portable Understructure for Numerical Computing) is a small standard
collection of software libraries for numerical computing. The PUNC
collection includes reference implementations of the standard (dense matrix)
diff --git a/sci-libs/punc/punc-1.5.ebuild b/sci-libs/punc/punc-1.5.ebuild
index 9b3a8f4d41bb..61eb3aea945c 100644
--- a/sci-libs/punc/punc-1.5.ebuild
+++ b/sci-libs/punc/punc-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.4 2011/06/21 14:46:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/punc/punc-1.5.ebuild,v 1.5 2011/11/24 11:01:47 jlec Exp $
EAPI="3"
@@ -73,6 +73,7 @@ src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable debug vdebug) \
+ --enable-vf2cforce \
--enable-shared \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
--disable-triplet \