summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-01-11 03:55:11 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-01-11 03:55:11 +0000
commit589a07eaf5d22a3c425e6118b5e49fdca76d2672 (patch)
tree3be250625425b93c1c614377e3bd63a4dabbcecc /sci-libs/votca-tools
parentversion bump (diff)
downloadgentoo-2-589a07eaf5d22a3c425e6118b5e49fdca76d2672.tar.gz
gentoo-2-589a07eaf5d22a3c425e6118b5e49fdca76d2672.tar.bz2
gentoo-2-589a07eaf5d22a3c425e6118b5e49fdca76d2672.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux i686)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog10
-rw-r--r--sci-libs/votca-tools/votca-tools-1.2.2.ebuild71
2 files changed, 79 insertions, 2 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index c771d5750398..fda137a17bbe 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/votca-tools
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.10 2011/12/14 17:02:21 ago Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.11 2012/01/11 03:55:11 ottxor Exp $
+
+*votca-tools-1.2.2 (11 Jan 2012)
+
+ 11 Jan 2012; Christoph Junghans <ottxor@gentoo.org>
+ +votca-tools-1.2.2.ebuild:
+ version bump
14 Dec 2011; Agostino Sarubbo <ago@gentoo.org> votca-tools-1.2.1.ebuild:
Stable for AMD64, wrt bug #389681
diff --git a/sci-libs/votca-tools/votca-tools-1.2.2.ebuild b/sci-libs/votca-tools/votca-tools-1.2.2.ebuild
new file mode 100644
index 000000000000..c4d00f4155a0
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.2.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.2.ebuild,v 1.1 2012/01/11 03:55:11 ottxor Exp $
+
+EAPI="3"
+
+inherit cmake-utils eutils multilib
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="system-boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
+ !system-boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ EHG_REVISION="default"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+IUSE="doc +fftw +gsl sqlite +system-boost"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ system-boost? ( dev-libs/boost )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+ >=app-text/txt2tags-2.5
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ if use system-boost; then
+ rm -rf src/libboost
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with fftw FFTW)
+ $(cmake-utils_use_with sqlite SQLITE3)
+ -DWITH_RC_FILES=OFF
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure || die
+}
+
+src_install() {
+ DOCS=(${CMAKE_BUILD_DIR}/CHANGELOG NOTICE)
+ cmake-utils_src_install || die
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}" || die
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/* || die
+ fi
+}