summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2012-09-11 18:17:52 +0000
committerAngelo Arrifano <miknix@gentoo.org>2012-09-11 18:17:52 +0000
commit9473d1ae3f272985fa15aa0f24403d75a5219ad6 (patch)
tree761a22daaf6f5cf86d8c0eb5ff44c55c87c65f74 /sci-misc
parentStable for amd64, wrt bug #433603 (diff)
downloadgentoo-2-9473d1ae3f272985fa15aa0f24403d75a5219ad6.tar.gz
gentoo-2-9473d1ae3f272985fa15aa0f24403d75a5219ad6.tar.bz2
gentoo-2-9473d1ae3f272985fa15aa0f24403d75a5219ad6.zip
Fix 'use' function invocation on global ebuild scope. #434634
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/mendeleydesktop/ChangeLog5
-rw-r--r--sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild24
2 files changed, 18 insertions, 11 deletions
diff --git a/sci-misc/mendeleydesktop/ChangeLog b/sci-misc/mendeleydesktop/ChangeLog
index 63e818a3c8a9..4a12881e090c 100644
--- a/sci-misc/mendeleydesktop/ChangeLog
+++ b/sci-misc/mendeleydesktop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-misc/mendeleydesktop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/mendeleydesktop/ChangeLog,v 1.6 2012/09/10 13:42:02 miknix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/mendeleydesktop/ChangeLog,v 1.7 2012/09/11 18:17:52 miknix Exp $
+
+ 11 Sep 2012; Angelo Arrifano <miknix@gentoo.org> mendeleydesktop-1.6.ebuild:
+ Fix 'use' function invocation on global ebuild scope. #434634
*mendeleydesktop-1.6 (10 Sep 2012)
diff --git a/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild b/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild
index 695821fa60ab..fc8645c37e02 100644
--- a/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild
+++ b/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild,v 1.1 2012/09/10 13:42:02 miknix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/mendeleydesktop/mendeleydesktop-1.6.ebuild,v 1.2 2012/09/11 18:17:52 miknix Exp $
EAPI="4"
@@ -9,12 +9,6 @@ inherit eutils multilib
MY_P_AMD64="${P}-linux-x86_64"
MY_P_X86="${P}-linux-i486"
-if use amd64 || use amd64-linux ; then
- MY_P="${MY_P_AMD64}"
-elif use x86 || use x86-linux ; then
- MY_P="${MY_P_X86}"
-fi
-
DESCRIPTION="A free research management tool for desktop and web"
HOMEPAGE="http://www.mendeley.com/"
SRC_URI="amd64? ( ${MY_P_AMD64}.tar.bz2 )
@@ -36,18 +30,28 @@ RDEPEND=">=x11-libs/qt-core-4.6:4
>=x11-libs/qt-webkit-4.6:4
>=x11-libs/qt-xmlpatterns-4.6:4"
-S="${WORKDIR}/${MY_P}"
-
QA_PRESTRIPPED="
/opt/mendeleydesktop/$(get_libdir)/mendeleydesktop/libexec/.*
/opt/mendeleydesktop/$(get_libdir)/lib.*so.*"
pkg_nofetch() {
- elog "Please download ${MY_P} from:"
+ elog "Please download ${A} from:"
elog "http://www.mendeley.com/download-mendeley-desktop/"
elog "and move it to ${DISTDIR}"
}
+src_unpack() {
+ unpack ${A}
+
+ cd "${WORKDIR}"
+
+ if use amd64 || use amd64-linux ; then
+ mv -f "${MY_P_AMD64}" "${P}"
+ else
+ mv -f "${MY_P_X86}" "${P}"
+ fi
+}
+
src_prepare() {
# remove bundled Qt libraries
rm -rf lib/mendeleydesktop/plugins \