summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-11 07:16:13 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-11 07:16:13 +0000
commit8eb950c2c0b1d41873d4d639d05acf39812a0730 (patch)
tree87a2e43a417efdafbe0a6889b029523cb0a0287c /sys-apps/cpint
parentForgot --virtual (diff)
downloadgentoo-2-8eb950c2c0b1d41873d4d639d05acf39812a0730.tar.gz
gentoo-2-8eb950c2c0b1d41873d4d639d05acf39812a0730.tar.bz2
gentoo-2-8eb950c2c0b1d41873d4d639d05acf39812a0730.zip
Clean/fix up build.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sys-apps/cpint')
-rw-r--r--sys-apps/cpint/ChangeLog9
-rw-r--r--sys-apps/cpint/cpint-2.5.3.ebuild20
-rw-r--r--sys-apps/cpint/files/cpint-2.5.3-build.patch73
-rw-r--r--sys-apps/cpint/files/cpint-2.5.3-kernel.patch43
-rw-r--r--sys-apps/cpint/files/cpint-2.5.3-prototypes.patch43
5 files changed, 179 insertions, 9 deletions
diff --git a/sys-apps/cpint/ChangeLog b/sys-apps/cpint/ChangeLog
index 2276491ebb66..60dd62ba070c 100644
--- a/sys-apps/cpint/ChangeLog
+++ b/sys-apps/cpint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/cpint
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpint/ChangeLog,v 1.6 2007/04/07 15:05:39 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpint/ChangeLog,v 1.7 2008/01/11 07:16:12 vapier Exp $
+
+ 11 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/cpint-2.5.3-build.patch, +files/cpint-2.5.3-kernel.patch,
+ +files/cpint-2.5.3-prototypes.patch, cpint-2.5.3.ebuild:
+ Clean/fix up build.
*cpint-2.5.3 (07 Apr 2007)
diff --git a/sys-apps/cpint/cpint-2.5.3.ebuild b/sys-apps/cpint/cpint-2.5.3.ebuild
index 0390cc813d02..46780b022f6e 100644
--- a/sys-apps/cpint/cpint-2.5.3.ebuild
+++ b/sys-apps/cpint/cpint-2.5.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpint/cpint-2.5.3.ebuild,v 1.1 2007/04/07 15:05:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cpint/cpint-2.5.3.ebuild,v 1.2 2008/01/11 07:16:12 vapier Exp $
-inherit linux-info
+inherit linux-info eutils
MY_PV=${PV//./}
@@ -17,12 +17,18 @@ IUSE=""
DEPEND=""
-src_compile() {
- emake INCLUDEDIR=-I/usr/src/linux/include || die "emake failed"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+ epatch "${FILESDIR}"/${P}-kernel.patch
+
+ # the makefile uses this variable
+ export KERNEL_DIR
}
src_install() {
- einstall prefix="${D}" || die
- rm -rf "${D}"/lib/modules/misc
+ emake install prefix="${D}" || die
dodoc ChangeLog HOW-TO
}
diff --git a/sys-apps/cpint/files/cpint-2.5.3-build.patch b/sys-apps/cpint/files/cpint-2.5.3-build.patch
new file mode 100644
index 000000000000..9dacbdb6c7ad
--- /dev/null
+++ b/sys-apps/cpint/files/cpint-2.5.3-build.patch
@@ -0,0 +1,73 @@
+--- cpint-2.5.3/Makefile
++++ cpint-2.5.3/Makefile
+@@ -5,59 +5,29 @@
+ prefix =
+ bindir = /usr/sbin
+ etcdir = /etc
++krndir = /lib/modules/`uname -r`/misc
+
+-COMMAND = hcp mongen monstat actgen diag0
+-
+-tools: $(COMMAND)
++CFLAGS += -Wall
++CPPFLAGS += -I$(KERNEL_DIR)/include
+
+-hcp : hcp.o
+- $(CC) -o $@ $^
++COMMAND = hcp mongen monstat actgen diag0
+
+-hcptest : hcptest.o
+- $(CC) -o $@ $^
++all: $(COMMAND) cpint_mod.ko
+
+-mongen : mongen.o
+- $(CC) -o $@ $^
++cpint_mod.ko:
++ $(MAKE) -C $(KERNEL_DIR) modules SUBDIRS=$(PWD)
+
+-actgen : actgen.o
+- $(CC) -o $@ $^
++tools: $(COMMAND)
+
+ monstat : monstat.o sysinfo.o
+- $(CC) -o $@ $^
+-
+-diag0 : diag0.o
+- $(CC) -o $@ $^
+-
+-hcp.o : hcp.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c hcp.c
+-
+-hcptest.o : hcptest.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c hcptest.c
+-
+-mongen.o : mongen.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c mongen.c
+-
+-monstat.o : monstat.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c monstat.c
+-
+-sysinfo.o : sysinfo.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c sysinfo.c
+-
+-actgen.o : actgen.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c actgen.c
+-
+-diag0.o : diag0.c
+- $(CC) -o $@ $(INCLUDEDIR) -I. -O2 -c diag0.c
+
+ install: $(TARGET)
++ install -d -m 755 ${prefix}${bindir}
+ install -c -m 750 mongen ${prefix}${bindir}
+ install -c -m 750 monstat ${prefix}${bindir}
+ install -c -m 750 hcp ${prefix}${bindir}
+- cp cpint_mod.ko /lib/modules/`uname -r`/kernel/drivers/s390/char/
+- rm -rf /dev/cpcmd /dev/cpmod /dev/cpappl /dev/cpid \
+- /dev/cpint0 /dev/cpint8 /dev/cpint76 /dev/cpint222
+- modprobe -qr cpint_mod
+- depmod -a
++ install -d -m 755 ${prefix}${krndir}
++ install -c -m 644 cpint_mod.ko ${prefix}${krndir}
+
+ clean:
+ rm -rf *.o *~ core mongen monstat actgen hcp diag0 *.ko *.cmd \
diff --git a/sys-apps/cpint/files/cpint-2.5.3-kernel.patch b/sys-apps/cpint/files/cpint-2.5.3-kernel.patch
new file mode 100644
index 000000000000..b4bb7640eb2c
--- /dev/null
+++ b/sys-apps/cpint/files/cpint-2.5.3-kernel.patch
@@ -0,0 +1,43 @@
+--- cpint-2.5.3/cpint.c
++++ cpint-2.5.3/cpint.c
+@@ -131,7 +131,7 @@
+
+ CPInt_Dev *cpint_devices;
+
+-static struct class_simple *cpint_class;
++static struct class *cpint_class;
+
+ /*----------------------------------------------------------*/
+ /* The different file operations */
+@@ -309,7 +309,7 @@
+ /*------------------------------------------------------*/
+ /* Register this device class */
+ /*------------------------------------------------------*/
+- cpint_class = class_simple_create(THIS_MODULE, "cpint");
++ cpint_class = class_create(THIS_MODULE, "cpint");
+ if (IS_ERR(cpint_class)) {
+ printk(KERN_ERR "Error creating cpint class.\n");
+ kfree(cpint_devices);
+@@ -325,7 +325,7 @@
+
+ fopIdx = fopMap[i_dev];
+ if (fopIdx > -1 && !(cpint_devs_map & (1 << fopIdx))) {
+- class_simple_device_add(cpint_class,
++ class_device_create(cpint_class, NULL,
+ MKDEV(cpint_major, i_dev), NULL,
+ cpNames[fopIdx]);
+ cpint_devs_map |= 1 << fopIdx;
+@@ -386,11 +386,11 @@
+
+ fopIdx = fopMap[i_dev];
+ if (fopIdx > -1 && (cpint_devs_map & (1 << fopIdx))) {
+- class_simple_device_remove(MKDEV(cpint_major, i_dev));
++ class_device_destroy(cpint_class, MKDEV(cpint_major, i_dev));
+ }
+ }
+ cpint_devs_map = 0;
+- class_simple_destroy(cpint_class);
++ class_destroy(cpint_class);
+
+ unregister_chrdev(cpint_major, "cpint");
+ for (i_dev = 0; i_dev < CPINT_NR_DEVS; i_dev++) {
diff --git a/sys-apps/cpint/files/cpint-2.5.3-prototypes.patch b/sys-apps/cpint/files/cpint-2.5.3-prototypes.patch
new file mode 100644
index 000000000000..376ee8c4fc87
--- /dev/null
+++ b/sys-apps/cpint/files/cpint-2.5.3-prototypes.patch
@@ -0,0 +1,43 @@
+--- cpint-2.5.3/actgen.c
++++ cpint-2.5.3/actgen.c
+@@ -45,6 +45,7 @@
+ /************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
+--- cpint-2.5.3/diag0.c
++++ cpint-2.5.3/diag0.c
+@@ -46,6 +46,8 @@
+ /************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <sys/ioctl.h>
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
+--- cpint-2.5.3/hcp.c
++++ cpint-2.5.3/hcp.c
+@@ -48,6 +48,8 @@
+ /************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <sys/ioctl.h>
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>
+--- cpint-2.5.3/mongen.c
++++ cpint-2.5.3/mongen.c
+@@ -59,6 +59,8 @@
+ /************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <sys/ioctl.h>
+ #include <unistd.h>
+ #include <errno.h>
+ #include <fcntl.h>