summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-01 22:35:51 +0000
commit6958fd94660a6f75a8de8b52b4f994965b22573c (patch)
tree1fc05a3b3717559d2787ef0c8284e2eb26a87775 /sys-apps/grub
parentlots of cleanup. jpeg,zlib,libpng should now extract in the correct dirs (diff)
downloadgentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.gz
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.tar.bz2
gentoo-2-6958fd94660a6f75a8de8b52b4f994965b22573c.zip
header, tab fixes
Diffstat (limited to 'sys-apps/grub')
-rw-r--r--sys-apps/grub/grub-0.90-r4.ebuild37
1 files changed, 19 insertions, 18 deletions
diff --git a/sys-apps/grub/grub-0.90-r4.ebuild b/sys-apps/grub/grub-0.90-r4.ebuild
index 4d0274934c96..d385e7171931 100644
--- a/sys-apps/grub/grub-0.90-r4.ebuild
+++ b/sys-apps/grub/grub-0.90-r4.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Mikael Hallendal <hallski@gentoo.org>
-# /home/cvsroot/gentoo-x86/sys-apps/grub/grub-0.5.96.1-r2.ebuild,v 1.2 2001/02/07 20:05:43 achim Exp
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.90-r4.ebuild,v 1.1 2001/12/29 02:17:55 gbevin Exp $
+# Maintainer: Mikael Hallendal <hallski@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grub/grub-0.90-r4.ebuild,v 1.2 2002/01/01 22:35:51 azarah Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="GNU GRUB boot loader"
-SRC_URI="ftp://alpha.gnu.org/gnu/grub/${A}"
+SRC_URI="ftp://alpha.gnu.org/gnu/grub/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grub"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r2"
src_unpack() {
+
unpack ${A}
cd ${S}
patch -p1 < ${FILESDIR}/${P}/grub-0.5.97-vga16.patch || die
@@ -32,34 +31,36 @@ src_unpack() {
src_compile() {
- ./configure --prefix=/usr --sbindir=/sbin \
- --mandir=/usr/share/man --infodir=/usr/share/info \
- --host=${CHOST}
- assert "Configuration of package failed."
+ ./configure --prefix=/usr \
+ --sbindir=/sbin \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} || die "Configuration of package failed."
# Have to do this since the configure-script seems a little brooken
echo "#define VGA16 1" >> config.h
emake -e CPPFLAGS="-Wall -Wmissing-prototypes -Wunused \
-Wshadow -malign-jumps=1 -malign-loops=1 \
- -malign-functions=1 -Wundef"
- assert "Building failed."
+ -malign-functions=1 -Wundef" || die "Building failed."
}
src_install() {
- make prefix=${D}/usr sbindir=${D}/sbin mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install
- assert "Installation failed."
+ make prefix=${D}/usr \
+ sbindir=${D}/sbin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation failed."
if [ -z "`use bootcd`" ]
then
- dodir /boot/grub
+ dodir /boot/grub
cd ${D}/usr/share/grub/i386-pc
cp stage1 stage2 *stage1_5 ${D}/boot/grub
- cp ${FILESDIR}/${P}/splash.xpm.gz ${D}/boot/grub
+ cp ${FILESDIR}/${P}/splash.xpm.gz ${D}/boot/grub
- cd ${S}
+ cd ${S}
dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
else
rm -rf ${D}/usr/share/{man,info,doc}