summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-09 23:26:55 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-09 23:26:55 +0000
commit1f7e3a098a5755368084578cdb8758b3869b4e76 (patch)
tree66c730a2a2a7529d25db5da2bda987e50345bb6d /sys-apps/slocate/slocate-2.6.ebuild
parentupdated URL, removed old version, and added SLOT in the meantime (diff)
downloadgentoo-2-1f7e3a098a5755368084578cdb8758b3869b4e76.tar.gz
gentoo-2-1f7e3a098a5755368084578cdb8758b3869b4e76.tar.bz2
gentoo-2-1f7e3a098a5755368084578cdb8758b3869b4e76.zip
slocate 2.6: a secure drop-in replacement for locate and updatedb
Diffstat (limited to 'sys-apps/slocate/slocate-2.6.ebuild')
-rw-r--r--sys-apps/slocate/slocate-2.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/slocate/slocate-2.6.ebuild b/sys-apps/slocate/slocate-2.6.ebuild
new file mode 100644
index 000000000000..2a7bef81be3c
--- /dev/null
+++ b/sys-apps/slocate/slocate-2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/slocate/slocate-2.6.ebuild,v 1.1 2002/02/09 23:26:55 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure locate provides a secure way to index and quickly search for files on your system (drop-in replacement for 'locate')"
+SRC_URI="ftp://ftp.geekreview.org/slocate/src/slocate-${PV}.tar.gz"
+HOMEPAGE="http://www.geekreview.org/slocate/"
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+
+src_install() {
+
+ # make install for this package is blocked by sandbox
+ dobin slocate
+ dosym /usr/bin/slocate /usr/bin/locate
+ dosym /usr/bin/slocate /usr/bin/updatedb
+
+ dodir /var/lib/slocate ; touch ${D}/var/lib/slocate/.keep
+
+ insinto /etc/cron.daily
+ chmod +x slocate.cron
+ doins slocate.cron
+
+ # man pages are already compressed for us
+ insinto /usr/share/man/man1
+ mv doc/slocate.1.linux.gz doc/slocate.1.gz
+ doins doc/slocate.1.gz doc/updatedb.1.gz
+ dosym /usr/share/man/man1/slocate.1.gz /usr/share/man/man1/locate.1.gz
+
+ dodoc LICENSE COPYING AUTHORS NEWS README ChangeLog
+}
+
+pkg_postinst() {
+ # /var/lib/slocate is owned by group slocate and so is the executable
+ groupadd slocate
+
+ chown root.slocate /usr/bin/slocate
+ chmod 2755 /usr/bin/slocate
+
+ chown root.slocate /var/lib/slocate
+ chmod 0750 /var/lib/slocate
+}