summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2012-10-29 11:07:24 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2012-10-29 11:07:24 +0000
commit927c9fa722e1ea7e413b09fd9b255b4b47abab23 (patch)
treee27959b1d999d0fb180226842f61d7fc78c0d60c /sys-cluster/libqb
parentwww-servers/tomcat: version bump (diff)
downloadgentoo-2-927c9fa722e1ea7e413b09fd9b255b4b47abab23.tar.gz
gentoo-2-927c9fa722e1ea7e413b09fd9b255b4b47abab23.tar.bz2
gentoo-2-927c9fa722e1ea7e413b09fd9b255b4b47abab23.zip
Version bump
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'sys-cluster/libqb')
-rw-r--r--sys-cluster/libqb/ChangeLog7
-rw-r--r--sys-cluster/libqb/libqb-0.14.3.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-cluster/libqb/ChangeLog b/sys-cluster/libqb/ChangeLog
index c9664d91e650..232012ed13f3 100644
--- a/sys-cluster/libqb/ChangeLog
+++ b/sys-cluster/libqb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/libqb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.1 2012/05/16 10:29:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/ChangeLog,v 1.2 2012/10/29 11:07:24 ultrabug Exp $
+
+*libqb-0.14.3 (29 Oct 2012)
+
+ 29 Oct 2012; Ultrabug <ultrabug@gentoo.org> +libqb-0.14.3.ebuild:
+ Version bump
*libqb-0.13.0 (16 May 2012)
diff --git a/sys-cluster/libqb/libqb-0.14.3.ebuild b/sys-cluster/libqb/libqb-0.14.3.ebuild
new file mode 100644
index 000000000000..425006340d72
--- /dev/null
+++ b/sys-cluster/libqb/libqb-0.14.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/libqb/libqb-0.14.3.ebuild,v 1.1 2012/10/29 11:07:24 ultrabug Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/asalkeld/libqb"
+SRC_URI="http://fedorahosted.org/releases/q/u/quarterback/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples static-libs test"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=(README.markdown ChangeLog)
+
+src_prepare() {
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile doxygen
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ fi
+}