summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-05-31 15:20:52 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-05-31 15:20:52 +0000
commit1f619296aeed83d8ff825f2ea24804bf902a10de (patch)
tree9b801ba014c1e9d73d8d9c27f6a91887a01d2e6a /sys-cluster/vzctl
parentAdd USE dependency default in preparation for the removal of the semantic-des... (diff)
downloadgentoo-2-1f619296aeed83d8ff825f2ea24804bf902a10de.tar.gz
gentoo-2-1f619296aeed83d8ff825f2ea24804bf902a10de.tar.bz2
gentoo-2-1f619296aeed83d8ff825f2ea24804bf902a10de.zip
Bump to 4.3 and update 9999, adding vanilla kernel support. Thanks to slepnoga.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog9
-rw-r--r--sys-cluster/vzctl/metadata.xml2
-rw-r--r--sys-cluster/vzctl/vzctl-4.3.ebuild83
-rw-r--r--sys-cluster/vzctl/vzctl-9999.ebuild61
4 files changed, 131 insertions, 24 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index ac5f535830f1..40c4744e82d0 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.111 2013/05/25 08:51:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.112 2013/05/31 15:20:52 maksbotan Exp $
+
+*vzctl-4.3 (31 May 2013)
+
+ 31 May 2013; Maxim Koltsov <maksbotan@gentoo.org> +vzctl-4.3.ebuild,
+ metadata.xml, vzctl-9999.ebuild:
+ Bump to 4.3 and update 9999, adding vanilla kernel support. Thanks to
+ slepnoga.
25 May 2013; Agostino Sarubbo <ago@gentoo.org> vzctl-4.2.ebuild:
Add ~ppc64, wrt bug #414531
diff --git a/sys-cluster/vzctl/metadata.xml b/sys-cluster/vzctl/metadata.xml
index 209c43d2ed34..965a8321e087 100644
--- a/sys-cluster/vzctl/metadata.xml
+++ b/sys-cluster/vzctl/metadata.xml
@@ -11,6 +11,8 @@
<use>
<flag name='ploop'>Add support for ploop devices via <pkg>sys-cluster/ploop</pkg></flag>
<flag name='cgroup'>Add support to Linux kernel cgroup subsytem</flag>
+ <flag name='vz-kernel'>Support OpenVZ patched kernel (<pkg>sys-kernel/openvz-sources</pkg>)</flag>
+ <flag name='vanilla-kernel'>Support unpatched upstream Linux kernel</flag>
</use>
<upstream>
<maintainer status="active">
diff --git a/sys-cluster/vzctl/vzctl-4.3.ebuild b/sys-cluster/vzctl/vzctl-4.3.ebuild
new file mode 100644
index 000000000000..e55a9a7466fc
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-4.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.3.ebuild,v 1.1 2013/05/31 15:20:52 maksbotan Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1 eutils toolchain-funcs udev
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc64"
+IUSE="ploop vanilla-kernel vz-kernel"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ vz-kernel? ( sys-fs/vzquota )
+ ploop? ( >=sys-cluster/ploop-1.5 )
+ vanilla-kernel? ( >=dev-libs/libcgroup-0.37 )
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+REQUIRED_USE="^^ ( vz-kernel vanilla-kernel )"
+
+src_prepare() {
+
+ # Set default OSTEMPLATE on gentoo
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+}
+
+src_configure() {
+
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate \
+ --with-vz \
+ $(use_with ploop) \
+ $(use_with vanilla-kernel cgroup)
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" udevdir="$(udev_get_udevdir)"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+
+ if use vanilla-kernel; then
+ einfo "You have selected vanilla' kernel support."
+ einfo "If you need checkpoint suspend/restore feature"
+ einfo "please install 'sys-process/criu' "
+ einfo "This is experimental and not stable (in gentoo) now"
+ fi
+}
diff --git a/sys-cluster/vzctl/vzctl-9999.ebuild b/sys-cluster/vzctl/vzctl-9999.ebuild
index 5684f68c5b61..939aff7364f7 100644
--- a/sys-cluster/vzctl/vzctl-9999.ebuild
+++ b/sys-cluster/vzctl/vzctl-9999.ebuild
@@ -1,10 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.14 2013/02/22 14:24:39 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-9999.ebuild,v 1.15 2013/05/31 15:20:52 maksbotan Exp $
EAPI="5"
-inherit bash-completion-r1 autotools git-2 toolchain-funcs udev
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit bash-completion-r1 autotools-utils git-2 toolchain-funcs udev
DESCRIPTION="OpenVZ ConTainers control utility"
HOMEPAGE="http://openvz.org/"
@@ -14,39 +17,49 @@ EGIT_REPO_URI="git://git.openvz.org/pub/${PN}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="cgroup +ploop"
+IUSE="ploop vanilla-kernel vz-kernel"
-RDEPEND="
- net-firewall/iptables
- sys-apps/ed
- >=sys-apps/iproute2-3.3.0
- sys-fs/vzquota
- ploop? ( >=sys-cluster/ploop-1.5 )
- cgroup? ( >=dev-libs/libcgroup-0.37 )
-"
+RDEPEND="net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ vz-kernel? ( sys-fs/vzquota )
+ ploop? ( >=sys-cluster/ploop-1.6 )
+ vanilla-kernel? ( >=dev-libs/libcgroup-0.37 )
+ "
DEPEND="${RDEPEND}
virtual/pkgconfig"
+REQUIRED_USE="^^ ( vz-kernel vanilla-kernel )"
+
src_prepare() {
+
# Set default OSTEMPLATE on gentoo
sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
# Set proper udev directory
sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
- eautoreconf
+
+ #provide user_epatch
+ autotools-utils_src_prepare
}
src_configure() {
- econf \
- --localstatedir=/var \
- --enable-udev \
- --enable-bashcomp \
- --enable-logrotate \
- $(use_with ploop) \
- $(use_with cgroup)
+
+ local myeconfargs=(
+ --localstatedir=/var
+ --enable-udev
+ --enable-bashcomp
+ --enable-logrotate
+ --with-vz
+ $(use_with ploop)
+ $(use_with vanilla-kernel cgroup)
+ )
+
+ autotools-utils_src_configure
}
src_install() {
+
emake DESTDIR="${D}" udevdir="$(udev_get_udevdir)"/rules.d install install-gentoo
# install the bash-completion script into the right location
@@ -59,6 +72,7 @@ src_install() {
}
pkg_postinst() {
+
ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
ewarn "following code to /etc/conf.d/net:"
ewarn " postup() {"
@@ -70,9 +84,10 @@ pkg_postinst() {
ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
ewarn "/etc/init.d/vzeventd."
- if use cgroup; then
- ewarn "You have chose to use experimental CGROUP feature"
- ewarn "please do NOT file bugs to Gentoo bugzilla,"
- ewarn "use upstream bug tracker instead"
+ if use vanilla-kernel; then
+ einfo "You have selected vanilla' kernel support."
+ einfo "If you need checkpoint suspend/restore feature"
+ einfo "please install 'sys-process/criu' "
+ einfo "This is experimental and not stable (in gentoo) now"
fi
}