summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-06-04 01:31:06 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-06-04 01:31:06 +0000
commitcdfab6cc5681aa36ebace7a30dea91f34fc3bcc4 (patch)
treea6d418836295bd5d3f9d098eb3b9aaeda8eec03e /sys-devel
parentold (diff)
downloadgentoo-2-cdfab6cc5681aa36ebace7a30dea91f34fc3bcc4.tar.gz
gentoo-2-cdfab6cc5681aa36ebace7a30dea91f34fc3bcc4.tar.bz2
gentoo-2-cdfab6cc5681aa36ebace7a30dea91f34fc3bcc4.zip
Bump weekly 4.2 snapshot
(Portage version: 2.1_rc3-r5)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200606033
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060603.ebuild66
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 859aa483647e..ffdb55eba32c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.550 2006/05/31 13:14:55 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.551 2006/06/04 01:31:05 halcy0n Exp $
+
+*gcc-4.2.0_alpha20060603 (04 Jun 2006)
+
+ 04 Jun 2006; Mark Loeser <halcy0n@gentoo.org>
+ -gcc-4.2.0_alpha20060527.ebuild, +gcc-4.2.0_alpha20060603.ebuild:
+ Bump weekly 4.2 snapshot
31 May 2006; Joseph Jezak <josejx@gentoo.org> gcc-3.4.6-r1.ebuild:
Marked ppc stable.
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060603 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060603
new file mode 100644
index 000000000000..523681905bc5
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20060603
@@ -0,0 +1,3 @@
+MD5 085cc98e7484aa069f1fe0ca2f8f4789 gcc-4.2-20060603.tar.bz2 38957593
+RMD160 8af578b75449be5a2fb5b0efcd222d9bea05e39b gcc-4.2-20060603.tar.bz2 38957593
+SHA256 cc6156cf4aa6339bf02dc4f77f7683827a747365f4f13b264fe5a01a09b08dff gcc-4.2-20060603.tar.bz2 38957593
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060603.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060603.ebuild
new file mode 100644
index 000000000000..22e718f2e185
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060603.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060603.ebuild,v 1.1 2006/06/04 01:31:05 halcy0n Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ virtual/libiconv
+ fortran? (
+ dev-libs/gmp
+ dev-libs/mpfr
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? (
+ hppa? ( >=sys-libs/glibc-2.3.4 ) !hppa? ( >=sys-libs/glibc-2.3.6 )
+ )"
+fi
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+
+PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+ x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}