summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-18 23:40:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-18 23:40:20 +0000
commitfdd841a1f6aee404bbbfa7fa96bae6a72e8a02ab (patch)
tree1e7eb1345003a29377ca2449d0500134f1ecc3d3 /sys-freebsd/freebsd-libexec
parentremove old (diff)
downloadgentoo-2-fdd841a1f6aee404bbbfa7fa96bae6a72e8a02ab.tar.gz
gentoo-2-fdd841a1f6aee404bbbfa7fa96bae6a72e8a02ab.tar.bz2
gentoo-2-fdd841a1f6aee404bbbfa7fa96bae6a72e8a02ab.zip
remove old
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-libexec')
-rw-r--r--sys-freebsd/freebsd-libexec/ChangeLog10
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.0-libfallback.patch137
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtld7.patch24
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtldnoload.patch75
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch12
-rw-r--r--sys-freebsd/freebsd-libexec/files/freebsd-libexec-setXid.patch10
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-7.2-r2.ebuild78
-rw-r--r--sys-freebsd/freebsd-libexec/freebsd-libexec-8.0.ebuild65
8 files changed, 9 insertions, 402 deletions
diff --git a/sys-freebsd/freebsd-libexec/ChangeLog b/sys-freebsd/freebsd-libexec/ChangeLog
index 9fa657b749bb..dac9a6af410d 100644
--- a/sys-freebsd/freebsd-libexec/ChangeLog
+++ b/sys-freebsd/freebsd-libexec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-freebsd/freebsd-libexec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.54 2013/06/18 17:06:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/ChangeLog,v 1.55 2013/06/18 23:40:20 aballier Exp $
+
+ 18 Jun 2013; Alexis Ballier <aballier@gentoo.org>
+ -freebsd-libexec-7.2-r2.ebuild, -freebsd-libexec-8.0.ebuild,
+ -files/freebsd-libexec-7.0-libfallback.patch,
+ -files/freebsd-libexec-7.2-rtld7.patch,
+ -files/freebsd-libexec-7.2-rtldnoload.patch,
+ -files/freebsd-libexec-nossp.patch, -files/freebsd-libexec-setXid.patch:
+ remove old
*freebsd-libexec-9.1-r1 (18 Jun 2013)
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.0-libfallback.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.0-libfallback.patch
deleted file mode 100644
index 6269ac4dd239..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.0-libfallback.patch
+++ /dev/null
@@ -1,137 +0,0 @@
---- rtld-elf/rtld.c.orig 2007-04-07 23:17:00 +0000
-+++ rtld-elf/rtld.c 2007-04-23 09:42:32 +0000
-@@ -988,6 +988,103 @@
- return NULL;
- }
-
-+#define MAX_LIBRARIES_HITS 255
-+
-+struct fill_library_paths_args {
-+ const char *name;
-+ size_t namelen;
-+ char **libraries;
-+ size_t *count;
-+};
-+
-+static void *
-+fill_library_paths(const char *dir, size_t dirlen, void *param)
-+{
-+ struct fill_library_paths_args *arg;
-+
-+ arg = param;
-+ if (*(arg->count) > MAX_LIBRARIES_HITS)
-+ return (NULL);
-+
-+ if (*dir == '/' || trust) {
-+ arg->libraries[*(arg->count)] = malloc(sizeof(char)*(dirlen + 1 + arg->namelen + 1));
-+ strncpy(arg->libraries[*(arg->count)], dir, dirlen);
-+ arg->libraries[*(arg->count)][dirlen] = '/';
-+ strncpy(arg->libraries[*(arg->count)] + dirlen + 1, arg->name, arg->namelen+1);
-+
-+ dbg(" Trying \"%s\"\n", arg->libraries[*(arg->count)]);
-+ if (access(arg->libraries[*(arg->count)], F_OK) == 0) {
-+ *(arg->count) += 1;
-+ }
-+ }
-+ return (NULL);
-+}
-+
-+/**
-+ * Find all libraries matching xname for the object refobj (if not null), like
-+ * find_library but find all the matching libraries in the paths.
-+ *
-+ * The returned pointer has to be free()'d (as well as the contained strings)
-+ * if it's non-NULL.
-+ * The end of the array is found when the pointer gets NULL.
-+ */
-+static char **find_libraries(const char *xname, const Obj_Entry *refobj)
-+{
-+ char **libraries;
-+ size_t libraries_count;
-+ struct fill_library_paths_args arg;
-+ char *name;
-+
-+ if (strchr(xname, '/') != NULL) { /* Hard coded pathname */
-+ if (xname[0] != '/' && !trust) {
-+ _rtld_error("Absolute pathname required for shared object \"%s\"",
-+ xname);
-+ return NULL;
-+ }
-+ libraries = malloc(sizeof(char*)*2);
-+ libraries[0] = xstrdup(xname);
-+ libraries[1] = NULL;
-+ return libraries;
-+ }
-+
-+ if (libmap_disable || (refobj == NULL) ||
-+ (name = lm_find(refobj->path, xname)) == NULL)
-+ name = (char *)xname;
-+
-+ dbg(" Searching for \"%s\"", name);
-+
-+ /* look up at maximum 255 libraries, would be crazy going over that */
-+ libraries = malloc(sizeof(char*)*(MAX_LIBRARIES_HITS+1));
-+ libraries_count = 0;
-+
-+ arg.name = name;
-+ arg.namelen = strlen(name);
-+ arg.libraries = libraries;
-+ arg.count = &libraries_count;
-+
-+ path_enumerate(ld_library_path, fill_library_paths, &arg);
-+ if(refobj != NULL)
-+ path_enumerate(refobj->rpath, fill_library_paths, &arg);
-+ path_enumerate(gethints(), fill_library_paths, &arg);
-+ path_enumerate(STANDARD_LIBRARY_PATH, fill_library_paths, &arg);
-+
-+ libraries[libraries_count] = NULL;
-+
-+ if(libraries_count == 0) {
-+ if(refobj != NULL && refobj->path != NULL) {
-+ _rtld_error("Shared object \"%s\" not found, required by \"%s\"",
-+ name, basename(refobj->path));
-+ } else {
-+ _rtld_error("Shared object \"%s\" not found", name);
-+ }
-+
-+ free(libraries);
-+ return NULL;
-+ }
-+
-+ return libraries;
-+}
-+
- /*
- * Given a symbol number in a referencing object, find the corresponding
- * definition of the symbol. Returns a pointer to the symbol, or NULL if
-@@ -1260,7 +1357,29 @@
- Needed_Entry *needed;
-
- for (needed = obj->needed; needed != NULL; needed = needed->next) {
-- needed->obj = load_object(obj->strtab + needed->name, obj);
-+ const char *name = obj->strtab + needed->name;
-+ char **paths = find_libraries(name, obj);
-+ char **curpath = paths;
-+
-+ needed->obj = NULL;
-+ if (paths == NULL) {
-+ if (ld_tracing)
-+ continue;
-+ else
-+ return -1;
-+ }
-+
-+ while(*curpath) {
-+ if (needed->obj == NULL) {
-+ needed->obj = load_object(*curpath, NULL);
-+ curpath++;
-+ continue;
-+ }
-+ /* Continue, so that we can free the whole lot */
-+ free(*curpath);
-+ curpath++;
-+ }
-+ free(paths);
- if (needed->obj == NULL && !ld_tracing)
- return -1;
- }
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtld7.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtld7.patch
deleted file mode 100644
index 6c6f0adf5fa8..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtld7.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-http://security.freebsd.org/advisories/FreeBSD-SA-09:16.rtld.asc
-
-Index: libexec/rtld-elf/rtld.c
-===================================================================
---- libexec/rtld-elf/rtld.c
-+++ libexec/rtld-elf/rtld.c
-@@ -358,11 +358,12 @@
- * future processes to honor the potentially un-safe variables.
- */
- if (!trust) {
-- unsetenv(LD_ "PRELOAD");
-- unsetenv(LD_ "LIBMAP");
-- unsetenv(LD_ "LIBRARY_PATH");
-- unsetenv(LD_ "LIBMAP_DISABLE");
-- unsetenv(LD_ "DEBUG");
-+ if (unsetenv(LD_ "PRELOAD") || unsetenv(LD_ "LIBMAP") ||
-+ unsetenv(LD_ "LIBRARY_PATH") || unsetenv(LD_ "LIBMAP_DISABLE") ||
-+ unsetenv(LD_ "DEBUG")) {
-+ _rtld_error("environment corrupt; aborting");
-+ die();
-+ }
- }
- ld_debug = getenv(LD_ "DEBUG");
- libmap_disable = getenv(LD_ "LIBMAP_DISABLE") != NULL;
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtldnoload.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtldnoload.patch
deleted file mode 100644
index 2e45736e3883..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-7.2-rtldnoload.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Backported from 8.0.
-Even if RTLD_NOLOAD is not standard, dev-libs/nss expects it.
-Since it has made it to 8.0 we can afford backporting it.
-
---- libexec/rtld-elf/rtld.c.old 2010-01-10 18:19:50 +0100
-+++ libexec/rtld-elf/rtld.c 2010-01-10 18:30:03 +0100
-@@ -104,7 +104,7 @@
- static void linkmap_delete(Obj_Entry *);
- static int load_needed_objects(Obj_Entry *);
- static int load_preload_objects(void);
--static Obj_Entry *load_object(const char *, const Obj_Entry *);
-+static Obj_Entry *load_object(const char *, const Obj_Entry *, int);
- static Obj_Entry *obj_from_addr(const void *);
- static void objlist_call_fini(Objlist *, int *lockstate);
- static void objlist_call_init(Objlist *, int *lockstate);
-@@ -1384,7 +1384,7 @@
-
- while(*curpath) {
- if (needed->obj == NULL) {
-- needed->obj = load_object(*curpath, NULL);
-+ needed->obj = load_object(*curpath, NULL, false);
- curpath++;
- continue;
- }
-@@ -1417,7 +1417,7 @@
-
- savech = p[len];
- p[len] = '\0';
-- if (load_object(p, NULL) == NULL)
-+ if (load_object(p, NULL, false) == NULL)
- return -1; /* XXX - cleanup */
- p[len] = savech;
- p += len;
-@@ -1434,7 +1434,7 @@
- * on failure.
- */
- static Obj_Entry *
--load_object(const char *name, const Obj_Entry *refobj)
-+load_object(const char *name, const Obj_Entry *refobj, int noload)
- {
- Obj_Entry *obj;
- int fd = -1;
-@@ -1480,6 +1480,8 @@
- close(fd);
- return obj;
- }
-+ if (noload)
-+ return (NULL);
-
- /* First use of this object, so we must map it in */
- obj = do_load_object(fd, name, path, &sb);
-@@ -1940,12 +1942,13 @@
- Obj_Entry **old_obj_tail;
- Obj_Entry *obj;
- Objlist initlist;
-- int result, lockstate;
-+ int result, lockstate, noload;
-
- LD_UTRACE(UTRACE_DLOPEN_START, NULL, NULL, 0, mode, name);
- ld_tracing = (mode & RTLD_TRACE) == 0 ? NULL : "1";
- if (ld_tracing != NULL)
- environ = (char **)*get_program_var_addr("environ");
-+ noload = mode & RTLD_NOLOAD;
-
- objlist_init(&initlist);
-
-@@ -1958,7 +1961,7 @@
- obj = obj_main;
- obj->refcount++;
- } else {
-- obj = load_object(name, obj_main);
-+ obj = load_object(name, obj_main, noload);
- }
-
- if (obj) {
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch
deleted file mode 100644
index 541254680964..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-nossp.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: fbsd-6.1/libexec/rtld-elf/Makefile
-===================================================================
---- fbsd-6.1.orig/libexec/rtld-elf/Makefile
-+++ fbsd-6.1/libexec/rtld-elf/Makefile
-@@ -7,6 +7,7 @@ SRCS= rtld_start.S \
- MAN= rtld.1
- CSTD?= gnu99
- CFLAGS+= -Wall -DFREEBSD_ELF -DIN_RTLD
-+CFLAGS+= ${NOSSP_FLAGS}
- CFLAGS+= -I${.CURDIR}/${MACHINE_ARCH} -I${.CURDIR}
- LDFLAGS+= -nostdlib -e .rtld_start
- INSTALLFLAGS= -C -b
diff --git a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-setXid.patch b/sys-freebsd/freebsd-libexec/files/freebsd-libexec-setXid.patch
deleted file mode 100644
index 4a53dd1c222d..000000000000
--- a/sys-freebsd/freebsd-libexec/files/freebsd-libexec-setXid.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -ur libexec.orig/pt_chown/Makefile libexec/pt_chown/Makefile
---- libexec.orig/pt_chown/Makefile Thu Apr 7 20:09:33 2005
-+++ libexec/pt_chown/Makefile Thu Apr 7 20:16:36 2005
-@@ -6,4 +6,6 @@
- BINMODE=4555
- NOMAN=
-
-+LDFLAGS += -Wl,-z,now
-+
- .include <bsd.prog.mk>
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-7.2-r2.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-7.2-r2.ebuild
deleted file mode 100644
index aa95adaba208..000000000000
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-7.2-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-7.2-r2.ebuild,v 1.1 2010/01/10 23:04:53 aballier Exp $
-
-EAPI=2
-
-inherit bsdmk freebsd pam
-
-DESCRIPTION="FreeBSD libexec things"
-SLOT="0"
-KEYWORDS="~sparc-fbsd ~x86-fbsd"
-
-SRC_URI="mirror://gentoo/${LIBEXEC}.tar.bz2
- mirror://gentoo/${UBIN}.tar.bz2
- mirror://gentoo/${BIN}.tar.bz2
- mirror://gentoo/${CONTRIB}.tar.bz2
- mirror://gentoo/${LIB}.tar.bz2
- mirror://gentoo/${ETC}.tar.bz2
- mirror://gentoo/${USBIN}.tar.bz2"
-
-RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
- >=sys-freebsd/freebsd-lib-7.2-r1
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- =sys-freebsd/freebsd-mk-defs-${RV}*
- =sys-freebsd/freebsd-sources-${RV}*"
-RDEPEND="${RDEPEND}
- xinetd? ( sys-apps/xinetd )"
-
-S="${WORKDIR}/libexec"
-
-PATCHES=( "${FILESDIR}/${PN}-setXid.patch"
- "${FILESDIR}/${PN}-nossp.patch"
- "${FILESDIR}/${PN}-7.0-libfallback.patch"
- "${FILESDIR}/${P}-rtld7.patch"
- "${FILESDIR}/${P}-pic.patch"
- "${FILESDIR}/${P}-rtldnoload.patch" )
-
-# Remove sendmail, tcp_wrapper and other useless stuff
-REMOVE_SUBDIRS="smrsh mail.local tcpd telnetd rshd rlogind lukemftpd ftpd"
-
-IUSE="pam ssl kerberos ipv6 nis xinetd"
-
-pkg_setup() {
- use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6= WITHOUT_INET6_SUPPORT= "
- use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= "
- use nis || mymakeopts="${mymakeopts} WITHOUT_NIS= "
- use pam || mymakeopts="${mymakeopts} WITHOUT_PAM_SUPPORT= "
- use ssl || mymakeopts="${mymakeopts} WITHOUT_OPENSSL= "
-
- mymakeopts="${mymakeopts} WITHOUT_SENDMAIL= WITHOUT_PF= WITHOUT_RCMDS= "
-}
-
-src_prepare() {
- ln -s /usr/include "${WORKDIR}/include"
-}
-
-src_compile() {
- NOSSP_FLAGS="$(test-flags -fno-stack-protector -fno-stack-protector-all)"
- export NOSSP_FLAGS
- freebsd_src_compile
-}
-
-src_install() {
- freebsd_src_install
-
- insinto /etc
- doins "${WORKDIR}/etc/gettytab"
- newinitd "${FILESDIR}/bootpd.initd" bootpd
- newconfd "${FILESDIR}/bootpd.confd" bootpd
-
- if use xinetd; then
- for rpcd in rstatd rusersd walld rquotad sprayd; do
- insinto /etc/xinetd.d
- newins "${FILESDIR}/${rpcd}.xinetd" ${rpcd}
- done
- fi
-}
diff --git a/sys-freebsd/freebsd-libexec/freebsd-libexec-8.0.ebuild b/sys-freebsd/freebsd-libexec/freebsd-libexec-8.0.ebuild
deleted file mode 100644
index 867fad402393..000000000000
--- a/sys-freebsd/freebsd-libexec/freebsd-libexec-8.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-libexec/freebsd-libexec-8.0.ebuild,v 1.2 2010/05/01 11:07:45 aballier Exp $
-
-EAPI=2
-
-inherit bsdmk freebsd pam
-
-DESCRIPTION="FreeBSD libexec things"
-SLOT="0"
-KEYWORDS="~sparc-fbsd ~x86-fbsd"
-
-SRC_URI="mirror://gentoo/${LIBEXEC}.tar.bz2
- mirror://gentoo/${UBIN}.tar.bz2
- mirror://gentoo/${BIN}.tar.bz2
- mirror://gentoo/${CONTRIB}.tar.bz2
- mirror://gentoo/${LIB}.tar.bz2
- mirror://gentoo/${ETC}.tar.bz2
- mirror://gentoo/${USBIN}.tar.bz2"
-
-RDEPEND="=sys-freebsd/freebsd-lib-${RV}*
- pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- =sys-freebsd/freebsd-mk-defs-${RV}*
- =sys-freebsd/freebsd-sources-${RV}*"
-RDEPEND="${RDEPEND}
- xinetd? ( sys-apps/xinetd )"
-
-S="${WORKDIR}/libexec"
-
-PATCHES=( "${FILESDIR}/${PN}-7.2-pic.patch" )
-# Remove sendmail, tcp_wrapper and other useless stuff
-REMOVE_SUBDIRS="smrsh mail.local tcpd telnetd rshd rlogind lukemftpd ftpd"
-
-IUSE="pam ssl kerberos ipv6 nis xinetd"
-
-pkg_setup() {
- use ipv6 || mymakeopts="${mymakeopts} WITHOUT_INET6= WITHOUT_INET6_SUPPORT= "
- use kerberos || mymakeopts="${mymakeopts} WITHOUT_KERBEROS_SUPPORT= "
- use nis || mymakeopts="${mymakeopts} WITHOUT_NIS= "
- use pam || mymakeopts="${mymakeopts} WITHOUT_PAM_SUPPORT= "
- use ssl || mymakeopts="${mymakeopts} WITHOUT_OPENSSL= "
-
- mymakeopts="${mymakeopts} WITHOUT_SENDMAIL= WITHOUT_PF= WITHOUT_RCMDS= "
-}
-
-src_prepare() {
- ln -s /usr/include "${WORKDIR}/include"
-}
-
-src_install() {
- freebsd_src_install
-
- insinto /etc
- doins "${WORKDIR}/etc/gettytab"
- newinitd "${FILESDIR}/bootpd.initd" bootpd
- newconfd "${FILESDIR}/bootpd.confd" bootpd
-
- if use xinetd; then
- for rpcd in rstatd rusersd walld rquotad sprayd; do
- insinto /etc/xinetd.d
- newins "${FILESDIR}/${rpcd}.xinetd" ${rpcd}
- done
- fi
-}