summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2010-11-21 00:41:23 +0000
committerMike Pagano <mpagano@gentoo.org>2010-11-21 00:41:23 +0000
commitd46a93db492781c3dee11416eb76f4e1600378a5 (patch)
treeba3fa32dd63c78186d15608d2b93bb3ed2e30611 /sys-kernel/linux-docs
parentMask gentoo-sources-2.6.36-r2 for testing of the TTY-based group scheduling p... (diff)
downloadgentoo-2-d46a93db492781c3dee11416eb76f4e1600378a5.tar.gz
gentoo-2-d46a93db492781c3dee11416eb76f4e1600378a5.tar.bz2
gentoo-2-d46a93db492781c3dee11416eb76f4e1600378a5.zip
Add docs for additional kernel versions
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/linux-docs')
-rw-r--r--sys-kernel/linux-docs/ChangeLog10
-rw-r--r--sys-kernel/linux-docs/linux-docs-2.6.35.2.ebuild62
-rw-r--r--sys-kernel/linux-docs/linux-docs-2.6.36.ebuild (renamed from sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild)6
3 files changed, 74 insertions, 4 deletions
diff --git a/sys-kernel/linux-docs/ChangeLog b/sys-kernel/linux-docs/ChangeLog
index d30337668133..e6b9fea25f2b 100644
--- a/sys-kernel/linux-docs/ChangeLog
+++ b/sys-kernel/linux-docs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/linux-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.25 2010/10/04 19:18:50 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/ChangeLog,v 1.26 2010/11/21 00:41:23 mpagano Exp $
+
+*linux-docs-2.6.36 (21 Nov 2010)
+*linux-docs-2.6.35.2 (21 Nov 2010)
+
+ 21 Nov 2010; Michael Pagano <mpagano@gentoo.org>
+ -linux-docs-2.6.25.2.ebuild, +linux-docs-2.6.35.2.ebuild,
+ +linux-docs-2.6.36.ebuild:
+ Add docs for 2.6.36
*linux-docs-2.6.35.7 (04 Oct 2010)
*linux-docs-2.6.32.23 (04 Oct 2010)
diff --git a/sys-kernel/linux-docs/linux-docs-2.6.35.2.ebuild b/sys-kernel/linux-docs/linux-docs-2.6.35.2.ebuild
new file mode 100644
index 000000000000..cf3755f029dd
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-2.6.35.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.35.2.ebuild,v 1.1 2010/11/21 00:41:23 mpagano Exp $
+
+inherit toolchain-funcs
+
+MY_P=linux-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="http://www.kernel.org/"
+SRC_URI="mirror://kernel/linux/kernel/v2.6/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+IUSE="html"
+DEPEND="app-text/docbook-sgml-utils
+ app-text/xmlto
+ sys-apps/sed
+ ~app-text/docbook-xml-dtd-4.1.2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e "s:db2:docbook2:g" \
+ -e "s:/usr/local/man:${D}/usr/share/man:g" \
+ "${S}"/Documentation/DocBook/Makefile
+
+ # fix for parallel build as per bug #248337
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+}
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ emake mandocs || die "make mandocs failed"
+
+ if use html; then
+ emake htmldocs || die "make htmldocs failed"
+ fi
+}
+
+src_install() {
+ local file
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+
+ make installmandocs || die "make installmandocs failed"
+
+ if use html; then
+ for file in Documentation/DocBook/*.html; do
+ dohtml -r ${file/\.html/}
+ done
+ fi
+}
diff --git a/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild b/sys-kernel/linux-docs/linux-docs-2.6.36.ebuild
index 49428a89a483..197129709ff6 100644
--- a/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild
+++ b/sys-kernel/linux-docs/linux-docs-2.6.36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild,v 1.2 2008/11/26 23:06:25 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.36.ebuild,v 1.1 2010/11/21 00:41:23 mpagano Exp $
inherit toolchain-funcs
@@ -30,10 +30,10 @@ src_unpack() {
-e "s:/usr/local/man:${D}/usr/share/man:g" \
"${S}"/Documentation/DocBook/Makefile
+ # fix for parallel build as per bug #248337
sed -i \
-e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
"${S}"/Makefile
-
}
src_compile() {