summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-11 08:59:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-11 08:59:20 +0000
commit2f7196e2f9afc2e0638c05a9c5a01b277343ddf3 (patch)
tree1f6dfb7d94582513ea945c24066b640f78b8ac22 /sys-process
parentDrop fox-1.2 support in fxscintilla-1.71 (fox-1.2 will be removed soon) (diff)
downloadgentoo-2-2f7196e2f9afc2e0638c05a9c5a01b277343ddf3.tar.gz
gentoo-2-2f7196e2f9afc2e0638c05a9c5a01b277343ddf3.tar.bz2
gentoo-2-2f7196e2f9afc2e0638c05a9c5a01b277343ddf3.zip
Version bump, with fix from bug #174402 for parallel-safety in makefiles.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/numactl/ChangeLog8
-rw-r--r--sys-process/numactl/files/digest-numactl-0.9.113
-rw-r--r--sys-process/numactl/files/numactl-0.9.11-make-jobs.patch19
-rw-r--r--sys-process/numactl/numactl-0.9.11.ebuild60
4 files changed, 89 insertions, 1 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index f7f3ce93cc47..c61210560bde 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/numactl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.3 2007/05/01 07:10:23 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.4 2007/05/11 08:59:20 robbat2 Exp $
+
+*numactl-0.9.11 (11 May 2007)
+
+ 11 May 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/numactl-0.9.11-make-jobs.patch, +numactl-0.9.11.ebuild:
+ Version bump, with fix from bug #174402 for parallel-safety in makefiles.
*numactl-0.9.10 (01 May 2007)
diff --git a/sys-process/numactl/files/digest-numactl-0.9.11 b/sys-process/numactl/files/digest-numactl-0.9.11
new file mode 100644
index 000000000000..37c193d0884c
--- /dev/null
+++ b/sys-process/numactl/files/digest-numactl-0.9.11
@@ -0,0 +1,3 @@
+MD5 84de1782dedac3a61f8f1babe5c4f12b numactl-0.9.11.tar.gz 49649
+RMD160 e214333d09f7290b290d0a466674269e09d73c39 numactl-0.9.11.tar.gz 49649
+SHA256 9fe8e8c29afc1e065dc3597b29c554685d6ca43573b129334ec910b554faecf0 numactl-0.9.11.tar.gz 49649
diff --git a/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch b/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch
new file mode 100644
index 000000000000..4db298f570f2
--- /dev/null
+++ b/sys-process/numactl/files/numactl-0.9.11-make-jobs.patch
@@ -0,0 +1,19 @@
+--- numactl-0.9.11/Makefile.orig 2007-04-03 13:44:54.000000000 +0200
++++ numactl-0.9.11/Makefile 2007-04-03 13:46:21.000000000 +0200
+@@ -140,12 +140,13 @@
+
+ html: ${HTML}
+
+-html/numactl.html: numactl.8
++htmldir:
+ if [ ! -d html ] ; then mkdir html ; fi
++
++html/numactl.html: numactl.8 htmldir
+ groff -Thtml -man numactl.8 > html/numactl.html
+
+-html/numa.html: numa.3
+- if [ ! -d html ] ; then mkdir html ; fi
++html/numa.html: numa.3 htmldir
+ groff -Thtml -man numa.3 > html/numa.html
+
+ depend: .depend
diff --git a/sys-process/numactl/numactl-0.9.11.ebuild b/sys-process/numactl/numactl-0.9.11.ebuild
new file mode 100644
index 000000000000..4389b8d8a0ce
--- /dev/null
+++ b/sys-process/numactl/numactl-0.9.11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-0.9.11.ebuild,v 1.1 2007/05/11 08:59:20 robbat2 Exp $
+
+inherit base eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems."
+HOMEPAGE="ftp://ftp.suse.com/pub/people/ak/numa/"
+SRC_URI="ftp://ftp.suse.com/pub/people/ak/numa/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+RDEPEND="virtual/libc
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-0.9.11-make-jobs.patch
+}
+
+src_compile() {
+ emake all html \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ # do this manually, as the Makefile doesn't do a good job
+ dobin numactl migratepages numastat
+ dolib.so libnuma.so.1
+ insinto /usr/include
+ doins numa.h numaif.h
+ doman migratepages.8 numa.3 numa_maps.5 numactl.8 numastat.8
+ dodoc README TODO CHANGES DESIGN
+ dodoc numademo.c memhog.c
+ dohtml html/*html
+ cd ${D}/usr/share/man/man3
+ # this list stolen from the Makefile
+ local MANLINKS="all_nodes alloc alloc_interleaved alloc_interleaved_subset
+ alloc_local alloc_onnode available bind error exit_on_error free
+ get_interleave_mask get_interleave_node get_membind get_run_node_mask
+ interleave_memory max_node no_nodes node_size node_to_cpus police_memory
+ preferred run_on_node run_on_node_mask set_bind_policy set_interleave_mask
+ set_localalloc set_membind set_preferred set_strict setlocal_memory
+ tonode_memory tonodemask_memory distance"
+ for i in ${MANLINKS}; do
+ ln -sf numa.3 numa_${i}.3
+ done
+}
+
+src_test() {
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd ${S}/test
+ ./regress2 || die "regress2 failed!"
+}