summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-02-04 04:00:18 +0000
committerTim Harder <radhermit@gentoo.org>2014-02-04 04:00:18 +0000
commitbab86fa7bb67abeb10361f240108778e49cd49dd (patch)
treecd3c0e3d49bf09673beafd237c5a99c870b0c24f /www-misc
parentreconsidered bug 365359, issues caused by binary drivers which need revdep-pa... (diff)
downloadgentoo-2-bab86fa7bb67abeb10361f240108778e49cd49dd.tar.gz
gentoo-2-bab86fa7bb67abeb10361f240108778e49cd49dd.tar.bz2
gentoo-2-bab86fa7bb67abeb10361f240108778e49cd49dd.zip
Version bump, migrate to distutils-r1.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/urlwatch/ChangeLog9
-rw-r--r--www-misc/urlwatch/urlwatch-1.16.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/www-misc/urlwatch/ChangeLog b/www-misc/urlwatch/ChangeLog
index 8dd3dd022427..fe0d6f4371c6 100644
--- a/www-misc/urlwatch/ChangeLog
+++ b/www-misc/urlwatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-misc/urlwatch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.4 2013/09/13 21:34:33 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/ChangeLog,v 1.5 2014/02/04 04:00:18 radhermit Exp $
+
+*urlwatch-1.16 (04 Feb 2014)
+
+ 04 Feb 2014; Tim Harder <radhermit@gentoo.org> +urlwatch-1.16.ebuild:
+ Version bump, migrate to distutils-r1.
13 Sep 2013; Michał Górny <mgorny@gentoo.org> urlwatch-1.14.ebuild,
urlwatch-1.15.ebuild:
diff --git a/www-misc/urlwatch/urlwatch-1.16.ebuild b/www-misc/urlwatch/urlwatch-1.16.ebuild
new file mode 100644
index 000000000000..aeb2753e3472
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-1.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/urlwatch/urlwatch-1.16.ebuild,v 1.1 2014/02/04 04:00:18 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="http://thp.io/2008/urlwatch/ http://pypi.python.org/pypi/urlwatch"
+SRC_URI="http://thp.io/2008/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures"
+RDEPEND="${DEPEND}
+ || ( www-client/lynx app-text/html2text )"
+
+python_prepare() {
+ if [[ ${EPYTHON} == python3.* ]]; then
+ 2to3 -nw --no-diffs urlwatch lib/urlwatch/*.py \
+ share/urlwatch/examples/hooks.py.example setup.py || die
+ fi
+}