summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-10 15:53:42 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-10 15:53:42 +0000
commit5bcff5259485587bb927d80238722bf4ba473f15 (patch)
tree45cc0d31cd01e8f912b8334448d6d7502af9c46c /x11-libs/gtkmathview
parentOops. (diff)
downloadgentoo-2-5bcff5259485587bb927d80238722bf4ba473f15.tar.gz
gentoo-2-5bcff5259485587bb927d80238722bf4ba473f15.tar.bz2
gentoo-2-5bcff5259485587bb927d80238722bf4ba473f15.zip
Fix compile with GCC 4.4 wrt #267472, thanks to John Keeping.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtkmathview')
-rw-r--r--x11-libs/gtkmathview/ChangeLog8
-rw-r--r--x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc44.patch10
-rw-r--r--x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild9
3 files changed, 21 insertions, 6 deletions
diff --git a/x11-libs/gtkmathview/ChangeLog b/x11-libs/gtkmathview/ChangeLog
index b5422a0daec7..6429950d0ac9 100644
--- a/x11-libs/gtkmathview/ChangeLog
+++ b/x11-libs/gtkmathview/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/gtkmathview
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.33 2008/11/22 16:54:44 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/ChangeLog,v 1.34 2009/05/10 15:53:42 ssuominen Exp $
+
+ 10 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+ gtkmathview-0.8.0.ebuild, +files/gtkmathview-0.8.0-gcc44.patch:
+ Fix compile with GCC 4.4 wrt #267472, thanks to John Keeping.
22 Nov 2008; Jeroen Roovers <jer@gentoo.org> gtkmathview-0.8.0.ebuild:
Stable for HPPA (bug #245303).
diff --git a/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc44.patch b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc44.patch
new file mode 100644
index 000000000000..f85a828e1f23
--- /dev/null
+++ b/x11-libs/gtkmathview/files/gtkmathview-0.8.0-gcc44.patch
@@ -0,0 +1,10 @@
+--- src/common/AbstractLogger.cc.orig 2009-04-25 20:39:35.815053524 +0100
++++ src/common/AbstractLogger.cc 2009-04-25 20:40:01.240595176 +0100
+@@ -19,6 +19,7 @@
+ #include <config.h>
+
+ #include <stdarg.h>
++#include <stdio.h>
+
+ #include "AbstractLogger.hh"
+
diff --git a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
index ad1b6532e48e..a244e8105933 100644
--- a/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
+++ b/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.9 2008/11/22 16:54:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkmathview/gtkmathview-0.8.0.ebuild,v 1.10 2009/05/10 15:53:42 ssuominen Exp $
inherit eutils
@@ -31,8 +31,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gcc43.patch"
- epatch "${FILESDIR}/${P}-cond-t1.patch"
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-cond-t1.patch
}
src_compile() {