summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-07 23:41:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-07 23:41:49 +0000
commitc198b667ba03518d6f9e176edc209731e828891e (patch)
treee2713bcf9948a4ae60f5006c8e414664611fb704 /x11-libs/libqxt
parentversion bump (diff)
downloadgentoo-2-c198b667ba03518d6f9e176edc209731e828891e.tar.gz
gentoo-2-c198b667ba03518d6f9e176edc209731e828891e.tar.bz2
gentoo-2-c198b667ba03518d6f9e176edc209731e828891e.zip
Revbump to fix documenation installation. New elog message wrt qt-assistant. Fixes bug #327129
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libqxt')
-rw-r--r--x11-libs/libqxt/ChangeLog9
-rw-r--r--x11-libs/libqxt/libqxt-0.6.0-r1.ebuild63
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-libs/libqxt/ChangeLog b/x11-libs/libqxt/ChangeLog
index cdc6692591eb..69de4896b085 100644
--- a/x11-libs/libqxt/ChangeLog
+++ b/x11-libs/libqxt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libqxt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.13 2010/04/30 17:32:19 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/ChangeLog,v 1.14 2010/07/07 23:41:49 hwoarang Exp $
+
+*libqxt-0.6.0-r1 (07 Jul 2010)
+
+ 07 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
+ +libqxt-0.6.0-r1.ebuild:
+ Revbump to fix documenation installation. New elog message wrt
+ qt-assistant. Fixes bug #327129
*libqxt-0.6.0 (30 Apr 2010)
diff --git a/x11-libs/libqxt/libqxt-0.6.0-r1.ebuild b/x11-libs/libqxt/libqxt-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..7bcddb4cecce
--- /dev/null
+++ b/x11-libs/libqxt/libqxt-0.6.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libqxt/libqxt-0.6.0-r1.ebuild,v 1.1 2010/07/07 23:41:49 hwoarang Exp $
+
+EAPI=2
+inherit eutils qt4-r2
+
+DESCRIPTION="The Qt eXTension library provides cross-platform utility classes for the Qt toolkit"
+HOMEPAGE="http://libqxt.org/"
+SRC_URI="http://bitbucket.org/${PN}/${PN}/get/v${PV}.tar.gz ->
+${P}.tar.gz"
+
+LICENSE="|| ( CPL-1.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb crypt debug doc sql web"
+
+RDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-script:4
+ berkdb? ( x11-libs/qt-sql:4 sys-libs/db )
+ sql? ( x11-libs/qt-sql:4 )
+ crypt? ( >=dev-libs/openssl-0.9.8 x11-libs/qt-core:4[ssl] )
+ web? ( >=dev-libs/fcgi-2.4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS README LICENSE cpl1.0.txt"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ eqmake4 ${PN}.pro \
+ QXT_INSTALL_DOCS="/usr/share/doc/${PF}" \
+ QXT_INSTALL_FEATURES="/usr/share/qt4/mkspecs/features"
+ local myconf
+ myconf="-prefix /usr \
+ -libdir /usr/$(get_libdir) \
+ -docdir /usr/share/doc/${PF} \
+ -qmake-bin /usr/bin/qmake \
+ $(use debug && echo -debug) \
+ $(use !berkdb && echo -no-db -nomake berkeley) \
+ $(use !crypt && echo -nomake crypto -no-openssl) \
+ $(use !sql && echo -nomake sql) \
+ $(use !web && echo -nomake web)"
+ ./configure ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ use doc && emake docs
+}
+
+pkg_postinst() {
+ if use doc; then
+ elog
+ elog "In case you want to browse the libqxt documentation using"
+ elog "qt-assistant do the following steps:"
+ elog "1. Open qt-assistant"
+ elog "2. Edit->Preferences->Documentation->Add"
+ elog "3. Add this path: /usr/share/doc/${PF}/qxt.qch"
+ elog
+ fi
+}