summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-02 11:15:12 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-02 11:15:12 +0000
commit7ebdc036bf1df8c76a98d4452b4ef7b53d5b281e (patch)
treeb7fd3596e4c609c65c7dbb042453fdd2226d5f48 /x11-themes
parentRevision bump so everyone gets the fix. (diff)
downloadgentoo-2-7ebdc036bf1df8c76a98d4452b4ef7b53d5b281e.tar.gz
gentoo-2-7ebdc036bf1df8c76a98d4452b4ef7b53d5b281e.tar.bz2
gentoo-2-7ebdc036bf1df8c76a98d4452b4ef7b53d5b281e.zip
Version bump.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-icon-theme/ChangeLog7
-rw-r--r--x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.6.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-themes/gnome-icon-theme/ChangeLog b/x11-themes/gnome-icon-theme/ChangeLog
index 3c9a3e14e595..612e7dd5d59e 100644
--- a/x11-themes/gnome-icon-theme/ChangeLog
+++ b/x11-themes/gnome-icon-theme/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/gnome-icon-theme
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.187 2011/01/08 11:05:37 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.188 2011/02/02 11:15:12 pacho Exp $
+
+*gnome-icon-theme-2.91.6 (02 Feb 2011)
+
+ 02 Feb 2011; Pacho Ramos <pacho@gentoo.org> +gnome-icon-theme-2.91.6.ebuild:
+ Version bump.
08 Jan 2011; Pacho Ramos <pacho@gentoo.org> gnome-icon-theme-2.91.0.ebuild:
Don't enable branding per default as won't work for people using
diff --git a/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.6.ebuild b/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.6.ebuild
new file mode 100644
index 000000000000..14b8f7759e7b
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.6.ebuild,v 1.1 2011/02/02 11:15:12 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME 2 default icon themes"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="LGPL-3
+ branding? ( CCPL-Sampling-Plus-1.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="branding"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.40
+ sys-devel/gettext"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# FIXME: double check potential LINGUAS problem
+pkg_setup() {
+ DOCS="AUTHORS NEWS TODO"
+ G2CONF="${G2CONF} --enable-icon-mapping"
+}
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/gnome//${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+ # FIXME: 2.91.0 tries to install icon-theme.cache, recheck if still needed
+ # in future versions
+ rm -f "${ED}/usr/share/icons/gnome/icon-theme.cache" || die
+}