summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-09 10:41:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-09 10:41:20 +0000
commitb952bf8ad84289e77cc927653c9aefeba04b5257 (patch)
treef4b5605986c6b097963e3e50d01744bac33c9aad /xfce-base
parentfix comment (diff)
downloadgentoo-2-b952bf8ad84289e77cc927653c9aefeba04b5257.tar.gz
gentoo-2-b952bf8ad84289e77cc927653c9aefeba04b5257.tar.bz2
gentoo-2-b952bf8ad84289e77cc927653c9aefeba04b5257.zip
Fix building with libpng14.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/ChangeLog6
-rw-r--r--xfce-base/thunar/files/thunar-1.0.1-libpng14.patch13
-rw-r--r--xfce-base/thunar/thunar-1.0.1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 23343f1c17b6..98b85e622d93 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/thunar
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.86 2010/02/09 10:23:09 mduft Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.87 2010/03/09 10:41:19 ssuominen Exp $
+
+ 09 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> thunar-1.0.1.ebuild,
+ +files/thunar-1.0.1-libpng14.patch:
+ Fix building with libpng14.
09 Feb 2010; Markus Duft <mduft@gentoo.org> thunar-1.1.0.ebuild:
fix build for all prefix platforms, EPREFIX was missing
diff --git a/xfce-base/thunar/files/thunar-1.0.1-libpng14.patch b/xfce-base/thunar/files/thunar-1.0.1-libpng14.patch
new file mode 100644
index 000000000000..cc43d12a3344
--- /dev/null
+++ b/xfce-base/thunar/files/thunar-1.0.1-libpng14.patch
@@ -0,0 +1,13 @@
+http://repos.archlinux.org/wsvn/packages/thunar/trunk/libpng-1.4.patch
+
+--- thunar-vfs/thunar-vfs-thumb.c
++++ thunar-vfs/thunar-vfs-thumb.c
+@@ -1169,7 +1169,7 @@
+ goto done0;
+
+ /* verify the png signature */
+- if (G_LIKELY (png_check_sig ((png_bytep) signature, sizeof (signature))))
++ if (G_LIKELY (!png_sig_cmp ((png_bytep) signature, 0, sizeof (signature))))
+ rewind (fp);
+ else
+ goto done0;
diff --git a/xfce-base/thunar/thunar-1.0.1.ebuild b/xfce-base/thunar/thunar-1.0.1.ebuild
index 211a218f738b..1e290b34581b 100644
--- a/xfce-base/thunar/thunar-1.0.1.ebuild
+++ b/xfce-base/thunar/thunar-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-1.0.1.ebuild,v 1.16 2010/01/22 16:48:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-1.0.1.ebuild,v 1.17 2010/03/09 10:41:19 ssuominen Exp $
EAPI=2
MY_P=${P/t/T}
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
doc? ( dev-libs/libxslt )"
pkg_setup() {
+ PATCHES=( "${FILESDIR}/${P}-libpng14.patch" )
XFCONF="--disable-dependency-tracking
$(use_enable dbus)
$(use_enable gnome gnome-thumbnailers)