summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/homebank/ChangeLog7
-rw-r--r--app-office/homebank/homebank-4.0.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-office/homebank/ChangeLog b/app-office/homebank/ChangeLog
index 4753586fae62..d2c381ce435e 100644
--- a/app-office/homebank/ChangeLog
+++ b/app-office/homebank/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/homebank
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.4 2008/04/23 08:22:37 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.5 2008/12/27 19:11:17 calchan Exp $
+
+*homebank-4.0.1 (27 Dec 2008)
+
+ 27 Dec 2008; Denis Dupeyron <calchan@gentoo.org> +homebank-4.0.1.ebuild:
+ Version bump, thanks to Viaken (bug #250304).
*homebank-3.8 (23 Apr 2008)
diff --git a/app-office/homebank/homebank-4.0.1.ebuild b/app-office/homebank/homebank-4.0.1.ebuild
new file mode 100644
index 000000000000..d6964fae8dbd
--- /dev/null
+++ b/app-office/homebank/homebank-4.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-4.0.1.ebuild,v 1.1 2008/12/27 19:11:17 calchan Exp $
+
+inherit autotools fdo-mime
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ofx"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.12
+ sys-libs/zlib
+ ofx? ( >=dev-libs/libofx-0.7 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${RDEPEND}
+ gnome-base/librsvg"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's/-Werror//' configure.ac \
+ -e 's/LDFLAGS="${LDFLAGS} -lofx"/LIBS="${LIBS} -lofx"/' \
+ configure.ac || die "sed failed"
+
+ eautoconf
+}
+
+src_compile() {
+ econf $(use_with ofx) || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}