summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/dcron/ChangeLog27
-rw-r--r--sys-apps/dcron/dcron-2.7-r9.ebuild67
-rw-r--r--sys-apps/dcron/files/crontab22
-rw-r--r--sys-apps/dcron/files/dcron.rc63
-rw-r--r--sys-apps/dcron/files/digest-dcron-2.7-r91
-rw-r--r--sys-apps/fcron/ChangeLog20
-rw-r--r--sys-apps/fcron/fcron-2.0.0-r1.ebuild83
-rw-r--r--sys-apps/fcron/files/crontab23
-rw-r--r--sys-apps/fcron/files/digest-fcron-2.0.0-r11
-rw-r--r--sys-apps/fcron/files/fcron-2.0.0-gentoo.diff22
-rw-r--r--sys-apps/fcron/files/fcron.conf24
-rw-r--r--sys-apps/fcron/files/fcron.rc630
-rw-r--r--sys-apps/vcron/ChangeLog28
-rw-r--r--sys-apps/vcron/files/crontab15
-rw-r--r--sys-apps/vcron/files/digest-vcron-3.0.1-r11
-rw-r--r--sys-apps/vcron/files/vcron.rc63
-rw-r--r--sys-apps/vcron/vcron-3.0.1-r1.ebuild60
17 files changed, 407 insertions, 23 deletions
diff --git a/sys-apps/dcron/ChangeLog b/sys-apps/dcron/ChangeLog
index b38212662df1..87e954dbc5d0 100644
--- a/sys-apps/dcron/ChangeLog
+++ b/sys-apps/dcron/ChangeLog
@@ -1,11 +1,26 @@
# ChangeLog for sys-apps/dcron
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.3 2002/04/20 12:08:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/ChangeLog,v 1.4 2002/04/20 22:03:25 bangert Exp $
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/crontab
+
+ fixed /var/spool/cron/lastrun
+ added support for cron.hourly
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> dcron-2.7-r8.ebuild
+
+ add PROVIDE="virtual/cron" and RDEPEND="!virtual/cron sys-apps/cronbase"
+ added config section to activate /etc/cron.{hourly..etc}
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/cron.rc6
+
+ add "provide cron" to use
20 April 2002; Martin Schlemmer <azarah@gentoo.org> files/dcron.rc6 :
Update to NEED "logger"
+
*dcron-2.7-r8 (21 Mar 2002)
21 Mar 2002; Donny Davies <woodchip@gentoo.org> dcron-2.7-r8.ebuild,
@@ -13,13 +28,3 @@
Added patch from Matt Dillon to fix crontabs that begin with whitespace.
Thanks to everybody who helped analyze this problem.
-
-*dcron-2.7-r7 (1 Feb 2002)
-
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/sys-apps/dcron/dcron-2.7-r9.ebuild b/sys-apps/dcron/dcron-2.7-r9.ebuild
new file mode 100644
index 000000000000..8f46fde5d63d
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7-r9.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7-r9.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+# to use this, you must be part of the "cron" group
+
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/dcron27.tgz"
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+PROVIDE="virtual/cron"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff || die
+ # fix 'crontab -e' to look at $EDITOR and not $VISUAL
+ cp ${S}/crontab.c ${S}/crontab.c.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.c.orig > ${S}/crontab.c
+ cp ${S}/crontab.1 ${S}/crontab.1.orig
+ sed -e 's:VISUAL:EDITOR:g' ${S}/crontab.1.orig > ${S}/crontab.1
+ # fix for lines starting with whitespace
+ patch -p0 < ${FILESDIR}/${P}-whitespace.diff || die
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+
+ diropts -m 0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+ dodir /usr/{sbin,bin}
+ install -o root -g wheel -m 0700 crond ${D}/usr/sbin
+ install -o root -g cron -m 4750 crontab ${D}/usr/bin
+
+ dodoc CHANGELOG README
+ doman crontab.1 crond.8
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/dcron.rc6 dcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+}
diff --git a/sys-apps/dcron/files/crontab b/sys-apps/dcron/files/crontab
index 6bde0882d647..e4f4cc295666 100644
--- a/sys-apps/dcron/files/crontab
+++ b/sys-apps/dcron/files/crontab
@@ -1,9 +1,23 @@
+
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $ Header: $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
-#
+
*/15 * * * * test -x /usr/sbin/run-crons && /usr/sbin/run-crons
-0 0 * * * rm -f /var/cron/lastrun/cron.daily
-0 0 * * 6 rm -f /var/cron/lastrun/cron.weekly
-0 0 1 * * rm -f /var/cron/lastrun/cron.monthly
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
diff --git a/sys-apps/dcron/files/dcron.rc6 b/sys-apps/dcron/files/dcron.rc6
index 48dc3afb3957..809d8b3d446a 100644
--- a/sys-apps/dcron/files/dcron.rc6
+++ b/sys-apps/dcron/files/dcron.rc6
@@ -1,10 +1,11 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.4 2002/04/20 12:08:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/files/dcron.rc6,v 1.5 2002/04/20 22:03:25 bangert Exp $
depend() {
need clock hostname logger
+ provide cron
}
start() {
diff --git a/sys-apps/dcron/files/digest-dcron-2.7-r9 b/sys-apps/dcron/files/digest-dcron-2.7-r9
new file mode 100644
index 000000000000..0bbc16c10bc6
--- /dev/null
+++ b/sys-apps/dcron/files/digest-dcron-2.7-r9
@@ -0,0 +1 @@
+MD5 8984a6bb120cd674d4fb7f1cc52630a2 dcron27.tgz 15868
diff --git a/sys-apps/fcron/ChangeLog b/sys-apps/fcron/ChangeLog
new file mode 100644
index 000000000000..8d3bc3de1dd4
--- /dev/null
+++ b/sys-apps/fcron/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for app-admin/fcron
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/ChangeLog,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/fcron.rc6 :
+
+ added "logger hostname" to need - "backport" from app-admin/fcron/files/fcron.rc6
+
+ 19 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/fcron.rc6 :
+
+ added "provide cron"
+
+ 19 Apr 2002; Thilo Bangert <bangert@gentoo.org> frcon-2.0.0-r1.ebuild :
+
+ added RDEPEND="!virtual/cron sys-apps/cronbase" and PROVIDE="virtual/cron"
+ changed spooldir to /var/spool/cron
+ added symlink for crontab
+ fixed html docs
+ installed default config with crontabs located in /var/spool/cron/crontabs \ No newline at end of file
diff --git a/sys-apps/fcron/fcron-2.0.0-r1.ebuild b/sys-apps/fcron/fcron-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..cece355dce48
--- /dev/null
+++ b/sys-apps/fcron/fcron-2.0.0-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry A! <jerry@gentoo.org>, Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/fcron-2.0.0-r1.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://fcron.free.fr/${P}.src.tar.gz"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+
+PROVIDE="virtual/cron"
+
+src_unpack() {
+
+ unpack ${A} ; cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die "bad patchfile"
+ autoconf || die "autoconf problem"
+}
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --with-username=cron \
+ --with-groupname=cron \
+ --with-piddir=/var/run \
+ --with-etcdir=/etc/fcron \
+ --with-spooldir=/var/spool/cron \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-cflags="${CFLAGS}" --host=${CHOST} || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ diropts -m 770 -o cron -g cron
+ dodir /var/spool/cron/crontabs
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0110 ; doins fcron
+
+ insinto /usr/bin
+ insopts -o cron -g cron -m 6110 ; doins fcrontab
+ insopts -o root -g cron -m 6110 ; doins fcronsighup
+
+ dosym fcrontab /usr/bin/crontab
+
+ doman doc/*.{1,3,5,8}
+
+ dodoc MANIFEST VERSION doc/{CHANGES,README,LICENSE,FAQ,INSTALL,THANKS}
+ newdoc ${FILESDIR}/fcron.conf fcron.conf.sample
+ docinto html ; dohtml doc/*.html
+
+ insinto /etc/fcron
+ insopts -m 640 -o root -g cron
+ doins ${FILESDIR}/{fcron.allow,fcron.deny,fcron.conf}
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/fcron.rc6 fcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "To activate /etc/cron.{hourly|daily|weekly|montly} please run: "
+ einfo "crontab /etc/crontab"
+ echo
+ einfo "!!! That will replace root's current crontab !!!"
+ echo
+
+} \ No newline at end of file
diff --git a/sys-apps/fcron/files/crontab b/sys-apps/fcron/files/crontab
new file mode 100644
index 000000000000..bbeed56239ff
--- /dev/null
+++ b/sys-apps/fcron/files/crontab
@@ -0,0 +1,23 @@
+
+# /etc/crontab
+# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
+# $ Header: $
+
+# fcron || dcron:
+# This is NOT the system crontab! fcron and dcron do not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# crontab /etc/crontab
+# as root.
+# NOTE: This will REPLACE root's current crontab!!
+
+
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+
+*/15 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+
+
+
diff --git a/sys-apps/fcron/files/digest-fcron-2.0.0-r1 b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
new file mode 100644
index 000000000000..45d732101fce
--- /dev/null
+++ b/sys-apps/fcron/files/digest-fcron-2.0.0-r1
@@ -0,0 +1 @@
+MD5 b20c6bc5d9435a790e5500ecb7990df8 fcron-2.0.0.src.tar.gz 144069
diff --git a/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
new file mode 100644
index 000000000000..aa6c0362f6e1
--- /dev/null
+++ b/sys-apps/fcron/files/fcron-2.0.0-gentoo.diff
@@ -0,0 +1,22 @@
+--- configure.in.orig Sun Jul 8 07:32:17 2001
++++ configure.in Sat Aug 25 14:36:05 2001
+@@ -201,13 +201,13 @@
+ fi
+ ;;
+ *)
+- if test -d "$withval"; then
++# if test -d "$withval"; then
+ etcdir="$withval"
+- AC_MSG_RESULT($withval)
+- else
+- AC_MSG_ERROR([
+-Directory $withval does not exist])
+- fi
++# AC_MSG_RESULT($withval)
++# else
++# AC_MSG_ERROR([
++#Directory $withval does not exist])
++# fi
+ ;;
+ esac ],
+ if test -d "/etc"; then
diff --git a/sys-apps/fcron/files/fcron.conf b/sys-apps/fcron/files/fcron.conf
new file mode 100644
index 000000000000..eb7e47af9d07
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.conf
@@ -0,0 +1,24 @@
+# fcron.conf - Configuration file for fcron(8) and fcrontab(1).
+# See fcron.conf(5) for syntax and explanations.
+#
+# WARNING : this file must be owned by root:cron and 640.
+#
+# $ Header: $
+#
+
+# The spool directory where fcron stores its files
+fcrontabs = /var/spool/cron/crontabs
+
+# The location of the pidfile
+pidfile = /var/run/fcron.pid
+
+# allow/deny files to determine which users are allowed to use fcrontab
+fcronallow = /etc/fcron/fcron.allow
+fcrondeny = /etc/fcron/fcron.deny
+
+# Location of the programs used by fcron
+shell = /bin/sh
+sendmail = /usr/sbin/sendmail
+
+# Location of the default editor for "fcrontab -e"
+editor = /usr/bin/nano
diff --git a/sys-apps/fcron/files/fcron.rc6 b/sys-apps/fcron/files/fcron.rc6
new file mode 100644
index 000000000000..26dc4d68e431
--- /dev/null
+++ b/sys-apps/fcron/files/fcron.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fcron/files/fcron.rc6,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+depend() {
+ need clock hostname logger
+ provide cron
+}
+
+checkconfig() {
+ if [ ! -e /etc/fcron/fcron.conf ] ; then
+ eerror "You will need an /etc/fcron/fcron.conf first"
+ eerror "There is a sample in /etc/fcron"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting fcron"
+ start-stop-daemon --start --quiet --exec /usr/sbin/fcron
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping fcron"
+ start-stop-daemon --stop --quiet --pidfile /var/run/fcron.pid
+ eend $?
+}
diff --git a/sys-apps/vcron/ChangeLog b/sys-apps/vcron/ChangeLog
index 549b7f9a5b3d..e53d65152873 100644
--- a/sys-apps/vcron/ChangeLog
+++ b/sys-apps/vcron/ChangeLog
@@ -1,17 +1,33 @@
# ChangeLog for sys-apps/vcron
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/ChangeLog,v 1.2 2002/04/20 12:07:13 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/ChangeLog,v 1.3 2002/04/20 22:03:25 bangert Exp $
+
+
+*vcron-3.0.1-r1 (20 Apr 2002)
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/crontab :
+
+ added own crontab
+ fixed path to suit /var/spool/cron/lastrun
+ added support for /etc/cron.hourly
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> vcron-3.0.1.ebuild :
+
+ added PROVIDE="virtual/cron" && RDEPEND="virtual/cron"
+ removed code duplication
+ install own version of /etc/crontab
+ rdepend on sys-apps/cronbase and virtual/mta
+
+ 20 Apr 2002; Thilo Bangert <bangert@gentoo.org> files/vcron.rc6 :
+
+ added "provide cron"
20 April 2002; Martin Schlemmer <azarah@gentoo.org> files/vcron.rc6 :
Update to NEED "logger"
+
*vcron-3.0.1 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/sys-apps/vcron/files/crontab b/sys-apps/vcron/files/crontab
new file mode 100644
index 000000000000..64619cb94cdb
--- /dev/null
+++ b/sys-apps/vcron/files/crontab
@@ -0,0 +1,15 @@
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+# for vixie cron
+# remember to give cron a sighup when updating this file
+#
+# $ Header: $
+#
+#
+*/15 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+0 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
+0 0 * * * root rm -f /var/spool/cron/lastrun/cron.daily
+0 0 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
+0 0 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
+
+
+
diff --git a/sys-apps/vcron/files/digest-vcron-3.0.1-r1 b/sys-apps/vcron/files/digest-vcron-3.0.1-r1
new file mode 100644
index 000000000000..730747648de8
--- /dev/null
+++ b/sys-apps/vcron/files/digest-vcron-3.0.1-r1
@@ -0,0 +1 @@
+MD5 369390355808fcf947cd2f9847f88859 vixie-cron-3.0.1.tar.bz2 50376
diff --git a/sys-apps/vcron/files/vcron.rc6 b/sys-apps/vcron/files/vcron.rc6
index 3f483c4807fe..e5641c94f8e1 100644
--- a/sys-apps/vcron/files/vcron.rc6
+++ b/sys-apps/vcron/files/vcron.rc6
@@ -1,10 +1,11 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/files/vcron.rc6,v 1.4 2002/04/20 12:07:13 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/files/vcron.rc6,v 1.5 2002/04/20 22:03:25 bangert Exp $
depend() {
need clock localmount logger
+ provide cron
}
start() {
diff --git a/sys-apps/vcron/vcron-3.0.1-r1.ebuild b/sys-apps/vcron/vcron-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..51366a7708f3
--- /dev/null
+++ b/sys-apps/vcron/vcron-3.0.1-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/vcron/vcron-3.0.1-r1.ebuild,v 1.1 2002/04/20 22:03:25 bangert Exp $
+
+MY_P=${P/vcron/vixie-cron}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The Vixie cron daemon"
+SRC_URI="ftp://ftp.vix.com/pub/vixie/${MY_P}.tar.bz2"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="!virtual/cron
+ sys-apps/cronbase
+ virtual/mta"
+PROVIDE="virtual/cron"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${MY_P}-gentoo.patch || die
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+}
+
+src_compile() {
+
+ emake || die
+}
+
+src_install() {
+
+ diropts -m0750 -o root -g cron
+ dodir /var/spool/cron/crontabs
+
+ doman crontab.1 crontab.5 cron.8
+
+ dodoc CHANGES CONVERSION FEATURES MAIL MANIFEST README THANKS
+
+ diropts -m0755 ; dodir /etc/cron.d
+ touch ${D}/etc/cron.d/.keep
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/vcron.rc6 vcron
+
+ insinto /etc
+ doins ${FILESDIR}/crontab
+
+ dodoc ${FILESDIR}/crontab
+
+ insinto /usr/sbin
+ insopts -o root -g root -m 0750 ; doins cron
+
+ insinto /usr/bin
+ insopts -o root -g cron -m 4750 ; doins crontab
+
+}