summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vov')
-rw-r--r--app-emulation/vov/ChangeLog9
-rw-r--r--app-emulation/vov/Manifest4
-rw-r--r--app-emulation/vov/metadata.xml15
-rw-r--r--app-emulation/vov/vov-2.0.0.ebuild52
4 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/vov/ChangeLog b/app-emulation/vov/ChangeLog
new file mode 100644
index 000000000000..baf21ce0dc04
--- /dev/null
+++ b/app-emulation/vov/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/vov
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vov/ChangeLog,v 1.1 2008/02/18 11:14:30 s4t4n Exp $
+
+*vov-2.0.0 (18 Feb 2007)
+
+ 18 Feb 2007; Michele Noberasco <s4t4n@gentoo.org> vov-2.0.0.ebuild:
+ Initial import.
+
diff --git a/app-emulation/vov/Manifest b/app-emulation/vov/Manifest
new file mode 100644
index 000000000000..510f20d5022a
--- /dev/null
+++ b/app-emulation/vov/Manifest
@@ -0,0 +1,4 @@
+DIST vov-2.0.0.tar.gz 510667 RMD160 ff86221d41d2a37962e8c290ee041773737c34a0 SHA1 86177c5bed6515bc412a8c5331541f6f38147975 SHA256 f615cec368999171d911faf539bb32db1ba58d572857b2402efa4be144463bed
+EBUILD vov-2.0.0.ebuild 1063 RMD160 2fd106d15502cc06725ec9a4634f3e908dacaac4 SHA1 032a271d4f2796d4601375b662b022057b829ab1 SHA256 2645c47a66869c3639bba2bbcc3250da5ac279b48b5784f173cf02fa753e9524
+MISC ChangeLog 233 RMD160 5e38cdefafcd3b49e6f2af998d1b50bca0a4323c SHA1 3397a96d721144663c3433a9d0acda325ac455db SHA256 a5b3522ebc251228f247b4b8a164f11aca5eb2cd5f3645ce9e4523db803585bd
+MISC metadata.xml 658 RMD160 0a63022181f059ab3b7a8b4a5de12460d92c5ee6 SHA1 5154d6a9fcf76d106ffb757d80c4a1503d34f527 SHA256 ca998d952222a33047c85809be92ec1ae77e32b45cf6cbf5899e205cfe77604d
diff --git a/app-emulation/vov/metadata.xml b/app-emulation/vov/metadata.xml
new file mode 100644
index 000000000000..a6a942849b9c
--- /dev/null
+++ b/app-emulation/vov/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>s4t4n@gentoo.org</email>
+ <name>Michele Noberasco</name>
+</maintainer>
+<longdescription>
+vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine.
+It is basically an interpreter, which reads files in the form of memory assignments and executes
+the encoded instructions. The vov's instructions make you able to perform simple arithmetic data
+manipulation. It is a very useful tool to see if your programs work and how.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emulation/vov/vov-2.0.0.ebuild b/app-emulation/vov/vov-2.0.0.ebuild
new file mode 100644
index 000000000000..f74e749183b5
--- /dev/null
+++ b/app-emulation/vov/vov-2.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vov/vov-2.0.0.ebuild,v 1.1 2008/02/18 11:14:30 s4t4n Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="vov (Vov's Obsessive Von-Neumann) is a tool that emulates the behavior of a Von-Neumann machine."
+HOMEPAGE="http://home.gna.org/vov/"
+SRC_URI="http://download.gna.org/vov/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug gprof"
+
+RDEPEND="virtual/libc"
+DEPEND=">=sys-devel/flex-2.5.33-r3
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+
+ # do no install redundant documentation
+ cd "${S}"
+ sed -i 's/src scripts docs/src scripts/' "${S}/Makefile.in"
+}
+
+src_compile()
+{
+ local fp_support=""
+
+ if use gprof; then
+ filter-flags "-fomit-frame-pointer"
+ fp_support="--enable-frame-pointer"
+ fi
+
+ econf \
+ `use_enable gprof` \
+ `use_enable debug` \
+ ${fp_support} \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README NEWS
+ doman docs/vov.1
+}