summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-handwrite/ChangeLog10
-rw-r--r--app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch13
-rw-r--r--app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild41
3 files changed, 62 insertions, 2 deletions
diff --git a/app-i18n/ibus-handwrite/ChangeLog b/app-i18n/ibus-handwrite/ChangeLog
index bc45210f653e..81a711d1219d 100644
--- a/app-i18n/ibus-handwrite/ChangeLog
+++ b/app-i18n/ibus-handwrite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/ibus-handwrite
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-handwrite/ChangeLog,v 1.3 2013/09/01 10:08:34 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-handwrite/ChangeLog,v 1.4 2014/02/21 16:10:46 dlan Exp $
+
+*ibus-handwrite-2.1.4-r1 (21 Feb 2014)
+
+ 21 Feb 2014; Yixun Lan <dlan@gentoo.org> +ibus-handwrite-2.1.4-r1.ebuild,
+ +files/ibus-handwrite-link.patch:
+ fix under link bug #501954
01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ibus-handwrite-2.1.4.ebuild:
Stable for x86, wrt bug #480822
diff --git a/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch b/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch
new file mode 100644
index 000000000000..bd73e4f41f46
--- /dev/null
+++ b/app-i18n/ibus-handwrite/files/ibus-handwrite-link.patch
@@ -0,0 +1,13 @@
+diff --git a/configure.ac b/configure.ac
+index 8625fe9..20fdd42 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -80,6 +80,8 @@ AS_IF([test "x${have_zinnia}" = "xyes" ],[
+ AM_CONDITIONAL(WITH_ZINNIA,[false])
+ ])
+
++AC_SEARCH_LIBS([atan2],[m])
++
+ # check ibus
+ PKG_CHECK_MODULES(IBUS, [
+ ibus-1.0 >= 1.3
diff --git a/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild
new file mode 100644
index 000000000000..a69db09d07ba
--- /dev/null
+++ b/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-handwrite/ibus-handwrite-2.1.4-r1.ebuild,v 1.1 2014/02/21 16:10:46 dlan Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit eutils python-single-r1 autotools-utils multilib
+
+DESCRIPTION="hand write recognition/input using ibus IM engine"
+HOMEPAGE="http://code.google.com/p/ibus-handwrite/"
+SRC_URI="http://ibus-handwrite.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls +zinnia"
+
+RDEPEND="zinnia? ( app-i18n/zinnia app-i18n/zinnia-tomoe )
+ >=app-i18n/ibus-1.3.0
+ >=x11-libs/gtk+-2.10
+ x11-libs/gtkglext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-link.patch #bug #501954
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ $(use_enable zinnia)
+ $(use_with zinnia zinnia-tomoe "${EPREFIX}"/usr/$(get_libdir)/zinnia/model/tomoe)
+ )
+ autotools-utils_src_configure
+}