summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild')
-rw-r--r--dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild b/dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild
new file mode 100644
index 000000000000..9d6d22dd9a84
--- /dev/null
+++ b/dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gecko-sharp/gecko-sharp-0.6.ebuild,v 1.16 2007/01/29 16:34:42 armin76 Exp $
+
+inherit mono multilib
+
+DESCRIPTION="A Gtk# Mozilla binding"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/archive/1.0.3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.0
+ =dev-dotnet/gtk-sharp-1.0*
+ www-client/mozilla"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ ${S}/*.pc.in || die
+ fi
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake -j1 || die "Make failed. You may need to unmerge gecko-sharp and re-emerge it if you are upgrading from an earlier version."
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}