summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild')
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild b/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild
deleted file mode 100644
index a374970c2489..000000000000
--- a/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.3-r1.ebuild,v 1.8 2004/07/31 11:51:12 axxo Exp $
-
-inherit java-pkg
-
-DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
-HOMEPAGE="http://jakarta.apache.org/commons/logging/"
-SRC_URI="mirror://apache/jakarta/commons/logging/source/${PN}-${PV}-src.tar.gz"
-DEPEND=">=dev-java/log4j-1.2.5
- dev-java/avalon-logkit-bin
- >=dev-java/ant-1.4
- jikes? ( dev-java/jikes )
- junit? ( >=dev-java/junit-3.7 >=virtual/jdk-1.4 )
- !junit? ( >=virtual/jdk-1.3 )"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc sparc amd64"
-IUSE="doc jikes junit"
-
-S="${WORKDIR}/${P}-src/"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- echo "log4j.jar=`java-config -p log4j`" > build.properties
- echo "logkit.jar=`java-config -p avalon-logkit-bin`" >> build.properties
- echo "junit.jar=`java-config -p junit`" >> build.properties
-}
-
-src_compile() {
- local antflags="compile"
- use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
- use doc && antflags="${antflags} javadoc"
- use junit && antflags="${antflags} test"
- ant ${antflags} || die "compile problem"
-}
-
-src_install() {
- java-pkg_dojar target/${PN}-api.jar target/${PN}.jar
-
- dodoc RELEASE-NOTES.txt
- dohtml PROPOSAL.html STATUS.html usersguide.html
- use doc && dohtml -r dist/docs/
-}