summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/ghc-7.4.2.ebuild6
-rw-r--r--dev-lang/ghc/ghc-7.6.3-r1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-7.8.3.ebuild6
-rw-r--r--dev-lang/ghc/ghc-7.8.4.ebuild6
5 files changed, 26 insertions, 5 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 3da6f247dfa7..3667e35a90cb 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.278 2015/01/19 09:02:02 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.279 2015/03/18 09:46:28 slyfox Exp $
+
+ 18 Mar 2015; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.4.2.ebuild,
+ ghc-7.6.3-r1.ebuild, ghc-7.8.3.ebuild, ghc-7.8.4.ebuild:
+ fix package cache regeneration on upgrade/reinstall (bug #543008 by Kobboi) by
+ restoring pkg_postrm()
19 Jan 2015; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.8.4.ebuild:
added ia64 binary
diff --git a/dev-lang/ghc/ghc-7.4.2.ebuild b/dev-lang/ghc/ghc-7.4.2.ebuild
index 20922cd1f5d6..c57819f55dc2 100644
--- a/dev-lang/ghc/ghc-7.4.2.ebuild
+++ b/dev-lang/ghc/ghc-7.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.2.ebuild,v 1.16 2015/01/18 11:50:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.2.ebuild,v 1.17 2015/03/18 09:46:28 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -633,3 +633,7 @@ pkg_prerm() {
cp -p "${PKGCACHE}"{.shipped,}
}
+
+pkg_postrm() {
+ ghc-package_pkg_postrm
+}
diff --git a/dev-lang/ghc/ghc-7.6.3-r1.ebuild b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
index 55ca0556c070..6b163d39d9e5 100644
--- a/dev-lang/ghc/ghc-7.6.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.16 2015/01/18 11:50:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.17 2015/03/18 09:46:28 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -822,3 +822,7 @@ pkg_prerm() {
cp -p "${PKGCACHE}"{.shipped,}
}
+
+pkg_postrm() {
+ ghc-package_pkg_postrm
+}
diff --git a/dev-lang/ghc/ghc-7.8.3.ebuild b/dev-lang/ghc/ghc-7.8.3.ebuild
index d9b9fe514c98..1178c2ac8b16 100644
--- a/dev-lang/ghc/ghc-7.8.3.ebuild
+++ b/dev-lang/ghc/ghc-7.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.12 2015/01/18 11:50:59 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.3.ebuild,v 1.13 2015/03/18 09:46:28 slyfox Exp $
EAPI=5
@@ -609,3 +609,7 @@ pkg_prerm() {
cp -p "${PKGCACHE}"{.shipped,}
}
+
+pkg_postrm() {
+ ghc-package_pkg_postrm
+}
diff --git a/dev-lang/ghc/ghc-7.8.4.ebuild b/dev-lang/ghc/ghc-7.8.4.ebuild
index d621f6fa5196..031fab5be4d2 100644
--- a/dev-lang/ghc/ghc-7.8.4.ebuild
+++ b/dev-lang/ghc/ghc-7.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.4.ebuild,v 1.9 2015/01/19 09:02:02 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.8.4.ebuild,v 1.10 2015/03/18 09:46:28 slyfox Exp $
EAPI=5
@@ -612,3 +612,7 @@ pkg_prerm() {
cp -p "${PKGCACHE}"{.shipped,}
}
+
+pkg_postrm() {
+ ghc-package_pkg_postrm
+}