summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/files/python-2.3-db4.2.patch19
-rw-r--r--dev-lang/python/python-2.3.3.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 2a7fc5dc9081..b62de5c75070 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.79 2004/02/09 23:25:00 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.80 2004/02/11 00:16:31 liquidx Exp $
10 Feb 2004; Bartosch Pixa <darkspecter@gentoo.org> python-2.3.3.ebuild:
set ppc in keywords
+ 10 Feb 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild,
+ files/python-2.3-db4.2.patch:
+ add fix to make python-2.3.3 db-4.2 (gentoo flavour) aware
+
06 Feb 2004; <gustavoz@gentoo.org> python-2.3.3.ebuild:
Stable on sparc
diff --git a/dev-lang/python/files/python-2.3-db4.2.patch b/dev-lang/python/files/python-2.3-db4.2.patch
new file mode 100644
index 000000000000..fccbd5987751
--- /dev/null
+++ b/dev-lang/python/files/python-2.3-db4.2.patch
@@ -0,0 +1,19 @@
+--- setup.py.old 2004-02-10 22:22:12.028012888 +0000
++++ setup.py 2004-02-10 22:24:17.751899952 +0000
+@@ -497,14 +497,8 @@
+ '/opt/sfw',
+ '/sw/lib',
+ ),
+- 'incdirs': ('/usr/local/BerkeleyDB.4.2/include',
+- '/usr/local/include/db42',
+- '/usr/local/BerkeleyDB.4.1/include',
+- '/usr/local/include/db41',
+- '/usr/local/BerkeleyDB.4.0/include',
+- '/usr/local/include/db4',
+- '/opt/sfw/include/db4',
+- '/sw/include/db4',
++ 'incdirs': ('/usr/include/db4.2',
++ '/usr/include/db4.1',
+ '/usr/include/db4',
+ )},
+ 'db3': {'libs': ('db-3.3', 'db-3.2', 'db-3.1', 'db3',),
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index fb80078c00f6..779d2147d57f 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.14 2004/02/09 23:25:00 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.15 2004/02/11 00:16:31 liquidx Exp $
inherit flag-o-matic python
@@ -65,6 +65,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.3-gentoo_py_dontcompile.patch
epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
+ epatch ${FILESDIR}/${PN}-2.3-db4.2.patch
}
src_configure() {