summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog9
-rw-r--r--dev-lang/perl/Manifest4
-rw-r--r--dev-lang/perl/files/digest-perl-5.8.0-r123
-rw-r--r--dev-lang/perl/files/perl-5.8.0-reorder-INC.patch88
-rw-r--r--dev-lang/perl/perl-5.8.0-r12.ebuild315
5 files changed, 416 insertions, 3 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index d9d7bcdaad14..4c94dd7706f9 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.20 2003/06/24 14:48:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.21 2003/06/25 07:42:06 rac Exp $
+
+*perl-5.8.0-r12 (25 Jun 2003)
+
+ 25 Jun 2003; <rac@gentoo.org> perl-5.8.0-r12.ebuild,
+ files/perl-5.8.0-reorder-INC.patch:
+ Reorder @INC so that site modules can override vendor modules, which can in
+ turn override core modules.
24 Jun 2003; Aron Griffis <agriffis@gentoo.org> perl-5.8.0-r10.ebuild:
Mark stable on alpha
diff --git a/dev-lang/perl/Manifest b/dev-lang/perl/Manifest
index be4b3e9e8877..757b4f03bb73 100644
--- a/dev-lang/perl/Manifest
+++ b/dev-lang/perl/Manifest
@@ -1,9 +1,9 @@
MD5 e17d94a31ec95ba063e25a5e7bb14cc5 perl-5.6.1-r12.ebuild 7227
MD5 c89f05e4fc2ad8d6e4accf8626768e9e perl-5.8.0-r10.ebuild 13851
MD5 3dc77560d588871c4db09b8a86737f6d perl-5.8.0-r9.ebuild 13569
-MD5 37253c25eb45af2084f3f6c801ec9ff9 perl-5.8.0-r12.ebuild 9970
+MD5 7967a1fb68106f5eea193f2729912b8b perl-5.8.0-r12.ebuild 9967
MD5 fdccad58d0969a57dc5a284b9e385889 perl-5.6.1-r11.ebuild 6276
-MD5 58d0e7527b065710f6ccf4ddf6a670bf ChangeLog 16362
+MD5 5c59d1dddf90ed307a9e14723a2e8686 ChangeLog 16357
MD5 9c4a542b94e1abb143e148a628f78a58 perl-5.8.0-r11.ebuild 9684
MD5 01b216e82ad890302a0becdc19244a10 perl-5.6.1-r10.ebuild 6819
MD5 060e9f10466fdc1268c75a7cf4dcbc7c files/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch 446
diff --git a/dev-lang/perl/files/digest-perl-5.8.0-r12 b/dev-lang/perl/files/digest-perl-5.8.0-r12
new file mode 100644
index 000000000000..8303b880706d
--- /dev/null
+++ b/dev-lang/perl/files/digest-perl-5.8.0-r12
@@ -0,0 +1,3 @@
+MD5 d9bdb180620306023fd35901a2878b62 perl-5.8.0.tar.gz 11023084
+MD5 306033319ec016cbec2ff4f3238f3566 DB_File-1.806.tar.gz 80078
+MD5 1dbc4728cea6c662d03ea4a0863859a5 Safe-2.09.tar.gz 11465
diff --git a/dev-lang/perl/files/perl-5.8.0-reorder-INC.patch b/dev-lang/perl/files/perl-5.8.0-reorder-INC.patch
new file mode 100644
index 000000000000..2480b6416811
--- /dev/null
+++ b/dev-lang/perl/files/perl-5.8.0-reorder-INC.patch
@@ -0,0 +1,88 @@
+This is largely lifted from Debian's patch 53. The notion is to
+change the @INC ordering so that vendor can trump core, and site can
+trump vendor.
+
+--- perl.c.stock 2003-06-24 23:16:10.000000000 -0700
++++ perl.c 2003-06-24 23:18:50.000000000 -0700
+@@ -3679,9 +3679,9 @@
+ incpush(APPLLIB_EXP, TRUE, TRUE);
+ #endif
+
+-#ifdef ARCHLIB_EXP
+- incpush(ARCHLIB_EXP, FALSE, FALSE);
+-#endif
++ /* for configuration where /usr is mounted ro (CPAN::Config, Net::Config) */
++ incpush("/etc/perl", FALSE, FALSE);
++
+ #ifdef MACOS_TRADITIONAL
+ {
+ Stat_t tmpstatbuf;
+@@ -3708,8 +3708,6 @@
+ #endif
+ #if defined(WIN32)
+ incpush(PRIVLIB_EXP, TRUE, FALSE);
+-#else
+- incpush(PRIVLIB_EXP, FALSE, FALSE);
+ #endif
+
+ #ifdef SITEARCH_EXP
+@@ -3752,6 +3750,59 @@
+ incpush(PERL_VENDORLIB_STEM, FALSE, TRUE);
+ #endif
+
++ incpush(ARCHLIB_EXP, FALSE, FALSE);
++ incpush(PRIVLIB_EXP, FALSE, FALSE);
++
++ /* Non-versioned site directory for local modules and for
++ compatability with the previous packages' site dirs */
++ incpush("/usr/local/lib/site_perl", TRUE, FALSE);
++
++#ifdef PERL_INC_VERSION_LIST
++ {
++ struct stat s;
++
++ /* add small buffer in case old versions are longer than the
++ current version */
++ char sitearch[sizeof(SITEARCH_EXP)+16] = SITEARCH_EXP;
++ char sitelib[sizeof(SITELIB_EXP)+16] = SITELIB_EXP;
++ char const *vers[] = { PERL_INC_VERSION_LIST };
++ char const **p;
++
++ char *arch_vers = strrchr(sitearch, '/');
++ char *lib_vers = strrchr(sitelib, '/');
++
++ if (arch_vers && isdigit(*++arch_vers))
++ *arch_vers = 0;
++ else
++ arch_vers = 0;
++
++ if (lib_vers && isdigit(*++lib_vers))
++ *lib_vers = 0;
++ else
++ lib_vers = 0;
++
++ /* there is some duplication here as incpush does something
++ similar internally, but required as sitearch is not a
++ subdirectory of sitelib */
++ for (p = vers; *p; p++)
++ {
++ if (arch_vers)
++ {
++ strcpy(arch_vers, *p);
++ if (PerlLIO_stat(sitearch, &s) >= 0 && S_ISDIR(s.st_mode))
++ incpush(sitearch, FALSE, FALSE);
++ }
++
++ if (lib_vers)
++ {
++ strcpy(lib_vers, *p);
++ if (PerlLIO_stat(sitelib, &s) >= 0 && S_ISDIR(s.st_mode))
++ incpush(sitelib, FALSE, FALSE);
++ }
++ }
++ }
++#endif
++
+ #ifdef PERL_OTHERLIBDIRS
+ incpush(PERL_OTHERLIBDIRS, TRUE, TRUE);
+ #endif
diff --git a/dev-lang/perl/perl-5.8.0-r12.ebuild b/dev-lang/perl/perl-5.8.0-r12.ebuild
new file mode 100644
index 000000000000..9f1db1ea2d7c
--- /dev/null
+++ b/dev-lang/perl/perl-5.8.0-r12.ebuild
@@ -0,0 +1,315 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.0-r12.ebuild,v 1.1 2003/06/25 07:42:06 rac Exp $
+
+inherit eutils flag-o-matic
+
+# Perl has problems compiling with -Os in your flags
+replace-flags "-Os" "-O2"
+# This flag makes compiling crash in interesting ways
+filter-flags -malign-double
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
+MY_P="${P/lib}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+DB_FILE_VERSION="1.806"
+SAFE_VERSION="2.09"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz
+ ftp://ftp.perl.org/pub/CPAN/modules/by-module/DB_File/DB_File-${DB_FILE_VERSION}.tar.gz
+ ftp://ftp.perl.org/pub/CPAN/modules/by-module/Safe/Safe-${SAFE_VERSION}.tar.gz"
+HOMEPAGE="http://www.perl.org/"
+SLOT="0"
+LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~alpha ~mips ~hppa"
+IUSE="berkdb doc gdbm threads"
+
+DEPEND="sys-apps/groff
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ >=sys-apps/portage-2.0.45-r5
+ =sys-devel/libperl-${PV}*"
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+pkg_setup() {
+ # I think this should rather be displayed if you *have* 'threads'
+ # in USE if it could break things ...
+ if [ -n "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ sleep 10
+ else
+ ewarn ""
+ ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
+ ewarn "threading enabled , you must restart this emerge"
+ ewarn "with USE=threads emerge...."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ fi
+
+ if [ ! -f /usr/lib/${LIBPERL} ]
+ then
+ # Make sure we have libperl installed ...
+ eerror "Cannot find /usr/lib/${LIBPERL}! Make sure that you"
+ eerror "have sys-libs/libperl installed properly ..."
+ die "Cannot find /usr/lib/${LIBPERL}!"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Fix the definition of 'int sockatmark(int);' in perl.h to have __THROW.
+ # This fixes bug #12605.
+ # <azarah@gentoo.org> (28 Dec 2002).
+ cd ${S}; epatch ${FILESDIR}/${P}-sockatmark-should-__THROW.patch
+
+ # Get -lpthread linked before -lc. This is needed
+ # when using glibc >= 2.3, or else runtime signal
+ # handling breaks. Fixes bug #14380.
+ # <rac@gentoo.org> (14 Feb 2003)
+ cd ${S}; epatch ${FILESDIR}/${P}-prelink-lpthread.patch
+
+ # Patch perldoc to not abort when it attempts to search
+ # nonexistent directories; fixes bug #16589.
+ # <rac@gentoo.org> (28 Feb 2003)
+ cd ${S}; epatch ${FILESDIR}/${P}-perldoc-emptydirs.patch
+
+ # to allow building with db4, must replace the DB_File in the core
+ # with a newer one from CPAN.
+
+ einfo "Replacing core DB_File with newer version ${DB_FILE_VERSION}"
+ rm -rf ${S}/ext/DB_File
+ cp -R ${WORKDIR}/DB_File-${DB_FILE_VERSION} ${S}/ext/DB_File
+
+ # there is a security problem in the Safe.pm version in the core.
+ einfo "Replacing core Safe.pm with newer version ${SAFE_VERSION}"
+ chmod +w ${S}/ext/Opcode/Safe.pm
+ cp ${WORKDIR}/Safe-${SAFE_VERSION}/Safe.pm ${S}/ext/Opcode/
+
+ # this lays the groundwork for solving the issue of what happens
+ # when people (or ebuilds) install different versiosn of modules
+ # that are in the core, by rearranging the @INC directory to look
+ # site -> vendor -> core.
+ cd ${S}; epatch ${FILESDIR}/${P}-reorder-INC.patch
+}
+
+src_compile() {
+
+ export LC_ALL="C"
+ local myconf=""
+
+ if [ "`use threads`" ]
+ then
+ einfo "using threads"
+ mythreading="-multi"
+ myconf="-Dusethreads ${myconf}"
+ myarch="${CHOST%%-*}-linux-thread"
+ else
+ myarch="${CHOST%%-*}-linux"
+ fi
+
+ if [ "`use gdbm`" ]
+ then
+ myconf="${myconf} -Di_gdbm"
+ fi
+ if [ "`use berkdb`" ]
+ then
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+ if [ "`use sparc`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+ if [ "`use sparc64`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+
+cat > config.over <<EOF
+installprefix=${D}/usr
+installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
+installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
+installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/share/share/!/share/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/share/share/!/share/!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/usr/man/!/usr/share/man/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/usr/man/!/usr/share/man/!"\`
+man1ext=1
+man3ext=3pm
+installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
+installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
+installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
+installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
+EOF
+ sleep 10
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcc="${CC:-gcc}" \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefix='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ -Dscriptdir=/usr/bin \
+ -Dman3ext='3pm' \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ ${myconf} || die "Unable to configure"
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
+
+ emake -i test CCDLFLAGS=
+}
+
+src_install() {
+
+ export LC_ALL="C"
+
+ # Need to do this, else apps do not link to dynamic version of
+ # the library ...
+ local coredir="/usr/lib/perl5/${PV}/${myarch}${mythreading}/CORE"
+ dodir ${coredir}
+ dosym ../../../../${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so.${PERLSLOT}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
+
+ make DESTDIR="${D}" \
+ INSTALLMAN1DIR="${D}/usr/share/man/man1" \
+ INSTALLMAN3DIR="${D}/usr/share/man/man3" \
+ install || die "Unable to make install"
+
+ cp -f utils/h2ph utils/h2ph_patched
+ epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
+
+ LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+ -a -d ${D}/usr/lib/perl5/${PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+ # This is to fix a missing c flag for backwards compat
+ for i in `find ${D}/usr/lib/perl5 -iname "Config.pm"`;do
+ sed -e "s:ccflags=':ccflags='-DPERL5 :" \
+ -e "s:cppflags=':cppflags='-DPERL5 :" \
+ ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+ ./perl installman \
+ --man1dir="${D}/usr/share/man/man1" --man1ext='1' \
+ --man3dir="${D}/usr/share/man/man3" --man3ext='3'
+
+ # This removes ${D} from Config.pm and .packlist
+ for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do
+ einfo "Removing ${D} from ${i}..."
+ sed -e "s:${D}::" ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+ if [ -n "`use doc`" ]
+ then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+}
+
+pkg_postinst() {
+
+ # Make sure we do not have stale/invalid libperl.so 's ...
+ if [ -f "${ROOT}usr/lib/libperl.so" -a ! -L "${ROOT}usr/lib/libperl.so" ]
+ then
+ mv -f ${ROOT}usr/lib/libperl.so ${ROOT}usr/lib/libperl.so.old
+ fi
+
+ local perllib="`readlink -f ${ROOT}usr/lib/libperl.so | sed -e 's:^.*/::'`"
+
+ # If we are installing perl, we need the /usr/lib/libperl.so symlink to
+ # point to the version of perl we are running, else builing something
+ # against libperl.so will break ...
+ if [ "${perllib}" != "${LIBPERL}" ]
+ then
+ # Delete stale symlinks
+ rm -f ${ROOT}usr/lib/libperl.so
+ rm -f ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Regenerate libperl.so.${PERLSLOT}
+ ln -snf ${LIBPERL} ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Create libperl.so (we use the *soname* versioned lib here ..)
+ ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include; h2ph *.h sys/*.h
+ fi
+
+ eerror ""
+ eerror "If this is an upgrade to a perl 5.6.1 system,"
+ eerror "~OR~ an upgrade to a previous Gentoo release"
+ eerror "of perl 5.8.0, prior to -r8 "
+ eerror "you may need to recompile applications that"
+ eerror "were emerged against the old libperl.so"
+ eerror ""
+ eerror "${FILESDIR}/libperl_rebuilder "
+ eerror "is provided to assist with this. "
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run the rebuilder and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+ eerror ""
+}
+
+