summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clozurecl/ChangeLog11
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.4.ebuild85
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.7.ebuild (renamed from dev-lisp/clozurecl/clozurecl-1.5.ebuild)8
-rw-r--r--dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch13
4 files changed, 12 insertions, 105 deletions
diff --git a/dev-lisp/clozurecl/ChangeLog b/dev-lisp/clozurecl/ChangeLog
index 2f40accea1eb..b362c986a189 100644
--- a/dev-lisp/clozurecl/ChangeLog
+++ b/dev-lisp/clozurecl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lisp/clozurecl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.4 2010/12/17 20:18:11 ulm Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.5 2011/08/04 09:35:20 grozin Exp $
+
+*clozurecl-1.7 (04 Aug 2011)
+
+ 04 Aug 2011; Andrey Grozin <grozin@gentoo.org> -clozurecl-1.4.ebuild,
+ -clozurecl-1.5.ebuild, +clozurecl-1.7.ebuild,
+ -files/fix_user-homedir-pathname.patch:
+ Version bump
17 Dec 2010; Ulrich Mueller <ulm@gentoo.org> clozurecl-1.4.ebuild,
clozurecl-1.5.ebuild, clozurecl-1.6.ebuild:
diff --git a/dev-lisp/clozurecl/clozurecl-1.4.ebuild b/dev-lisp/clozurecl/clozurecl-1.4.ebuild
deleted file mode 100644
index f0c8a0930cb4..000000000000
--- a/dev-lisp/clozurecl/clozurecl-1.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.4.ebuild,v 1.2 2010/12/17 20:18:11 ulm Exp $
-
-EAPI=2
-
-inherit common-lisp-common-3 eutils
-
-MY_PN=ccl
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's MCL product"
-HOMEPAGE="http://ccl.clozure.com/"
-SRC_URI="x86? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
- amd64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
- # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
- # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
-
-LICENSE="LLGPL-2.1"
-SLOT="0"
-# KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="!dev-lisp/openmcl"
-
-S="${WORKDIR}"/${MY_PN}
-
-ENVD="${T}"/50ccl
-
-src_prepare() {
- find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
- find "${S}" -type f -name .cvsignore -delete &>/dev/null
- epatch "${FILESDIR}"/fix_user-homedir-pathname.patch
-}
-
-src_configure() {
- if use x86; then
- CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers
- elif use amd64; then
- CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64
- elif use ppc; then
- CCL_RUNTIME=ppccl; CCL_HEADERS=headers
- elif use ppc64; then
- CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64
- fi
-}
-
-src_compile() {
- unset CCL_DEFAULT_DIRECTORY
- ./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
-
- # remove non-owner write permissions on the full-image
- chmod go-w ${CCL_RUNTIME}{,.image}
-}
-
-src_install() {
- local install_dir=/usr/$(get_libdir)/${PN}
-
- exeinto ${install_dir}
- # install executable
- doexe ${CCL_RUNTIME}
- # install core image
- cp ${CCL_RUNTIME}.image "${D}"/${install_dir} || die
- # install optional libraries
- dodir ${install_dir}/tools
- cp tools/*fsl "${D}"/${install_dir}/tools || die
-
- # until we figure out which source files are necessary for runtime
- # optional features and which aren't, we install all sources
- find . -type f -name '*fsl' -delete
- cp -a compiler level-0 level-1 lib library \
- lisp-kernel scripts tools xdump \
- "${D}"/${install_dir} || die
- cp -a ${CCL_HEADERS} "${D}"/${install_dir} || die
-
- make_wrapper ccl "${install_dir}/${CCL_RUNTIME}"
-
- echo "CCL_DEFAULT_DIRECTORY=${install_dir}" > "${ENVD}"
- doenvd "${ENVD}"
-
- dodoc doc/release-notes.txt
- dohtml doc/ccl-documentation.html
- use doc && dohtml -r examples
-}
diff --git a/dev-lisp/clozurecl/clozurecl-1.5.ebuild b/dev-lisp/clozurecl/clozurecl-1.7.ebuild
index fcd1ad9fee71..3a3fb2179577 100644
--- a/dev-lisp/clozurecl/clozurecl-1.5.ebuild
+++ b/dev-lisp/clozurecl/clozurecl-1.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.5.ebuild,v 1.2 2010/12/17 20:18:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.7.ebuild,v 1.1 2011/08/04 09:35:20 grozin Exp $
EAPI=3
inherit eutils
@@ -23,14 +23,12 @@ IUSE="doc"
DEPEND="!dev-lisp/openmcl"
-S="${WORKDIR}"/${MY_PN}
+S="${WORKDIR}"/${MY_P}
ENVD="${T}"/50ccl
src_prepare() {
find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
- find "${S}" -type f -name .cvsignore -delete &>/dev/null
- epatch "${FILESDIR}"/fix_user-homedir-pathname.patch
}
src_configure() {
diff --git a/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch b/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch
deleted file mode 100644
index d69a58f6b4e1..000000000000
--- a/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: level-1/l1-pathnames.lisp
-===================================================================
---- level-1/l1-pathnames.lisp (revision 11951)
-+++ level-1/l1-pathnames.lisp (working copy)
-@@ -624,7 +624,7 @@
- (let* ((native
- (ignore-errors
- (truename
-- (native-to-directory-pathname (or #+ccl-0711 (getenv "HOME")
-+ (native-to-directory-pathname (or (getenv "HOME")
- (get-user-home-dir (getuid))))))))
- (if (and native (eq :absolute (car (pathname-directory native))))
- native