summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog8
-rw-r--r--dev-python/dulwich/dulwich-0.6.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index d6d600fced55..0a9bf39de66f 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.14 2010/07/10 15:26:52 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.15 2010/07/23 19:05:57 arfrever Exp $
+
+*dulwich-0.6.1 (23 Jul 2010)
+
+ 23 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +dulwich-0.6.1.ebuild:
+ Version bump.
10 Jul 2010; Christian Faulhammer <fauli@gentoo.org> dulwich-0.6.0.ebuild:
stable x86, bug 327149
diff --git a/dev-python/dulwich/dulwich-0.6.1.ebuild b/dev-python/dulwich/dulwich-0.6.1.ebuild
new file mode 100644
index 000000000000..62845ed8bb99
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.6.1.ebuild,v 1.1 2010/07/23 19:05:57 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}