summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/ChangeLog5
-rw-r--r--dev-python/feedparser/feedparser-5.0.1.ebuild13
2 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/feedparser/ChangeLog b/dev-python/feedparser/ChangeLog
index df1de6363c50..6ccd0f73296d 100644
--- a/dev-python/feedparser/ChangeLog
+++ b/dev-python/feedparser/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/feedparser
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.30 2011/06/23 15:10:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/ChangeLog,v 1.31 2011/11/16 19:10:07 hwoarang Exp $
+
+ 16 Nov 2011; Markos Chandras <hwoarang@gentoo.org> feedparser-5.0.1.ebuild:
+ Restrict tests with Jython. Update HOMEPAGE and LICENSE. Patch by Arfrever.
23 Jun 2011; Markos Chandras <hwoarang@gentoo.org> -feedparser-4.1.ebuild,
-feedparser-4.2_pre316.ebuild, -feedparser-5.0.ebuild:
diff --git a/dev-python/feedparser/feedparser-5.0.1.ebuild b/dev-python/feedparser/feedparser-5.0.1.ebuild
index ed8b1d276b3d..1600881de7a3 100644
--- a/dev-python/feedparser/feedparser-5.0.1.ebuild
+++ b/dev-python/feedparser/feedparser-5.0.1.ebuild
@@ -1,17 +1,21 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.0.1.ebuild,v 1.8 2011/04/02 11:54:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/feedparser/feedparser-5.0.1.ebuild,v 1.9 2011/11/16 19:10:07 hwoarang Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
+# 877 errors with Python 3.
+PYTHON_TESTS_RESTRICTED_ABIS="3.* *-jython"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
inherit distutils eutils
DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="http://www.feedparser.org/ http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
+HOMEPAGE="http://code.google.com/p/feedparser/ http://pypi.python.org/pypi/feedparser"
SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-LICENSE="BSD-2 PSF-2.2"
+# sgmllib is licensed under PSF-2.
+LICENSE="BSD-2 PSF-2"
SLOT="0"
KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE=""
@@ -46,9 +50,6 @@ src_compile() {
src_test() {
testing() {
- # 877 errors with Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
cd feedparser || return 1
PYTHONPATH="." "$(PYTHON)" feedparsertest.py
}