summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog9
-rw-r--r--dev-ruby/oauth2/oauth2-0.9.3.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 19d808edc3f9..eff154748e79 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.18 2013/11/03 03:41:17 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.19 2014/01/22 06:59:40 graaff Exp $
+
+*oauth2-0.9.3 (22 Jan 2014)
+
+ 22 Jan 2014; Hans de Graaff <graaff@gentoo.org> +oauth2-0.9.3.ebuild:
+ Version bump.
03 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -oauth2-0.5.2.ebuild,
-oauth2-0.8.0.ebuild, -oauth2-0.9.1.ebuild:
diff --git a/dev-ruby/oauth2/oauth2-0.9.3.ebuild b/dev-ruby/oauth2/oauth2-0.9.3.ebuild
new file mode 100644
index 000000000000..43c940078fbd
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.9.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.9.3.ebuild,v 1.1 2014/01/22 06:59:40 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-0.1.8
+ >=dev-ruby/multi_json-1.0.3
+ >=dev-ruby/multi_xml-0.5
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}