summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/trollop/trollop-1.16.2-r1.ebuild')
-rw-r--r--dev-ruby/trollop/trollop-1.16.2-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/trollop/trollop-1.16.2-r1.ebuild b/dev-ruby/trollop/trollop-1.16.2-r1.ebuild
new file mode 100644
index 000000000000..cec09210761a
--- /dev/null
+++ b/dev-ruby/trollop/trollop-1.16.2-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/trollop/trollop-1.16.2-r1.ebuild,v 1.1 2010/09/12 09:09:30 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Trollop is a commandline option parser for Ruby."
+HOMEPAGE="http://trollop.rubyforge.org/"
+LICENSE="Ruby"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I lib test/test_trollop.rb || die "Tests failed."
+}