summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kdevelop')
-rw-r--r--dev-util/kdevelop/ChangeLog6
-rw-r--r--dev-util/kdevelop/files/kdevelop-3.3.0-makefiles.patch69
-rw-r--r--dev-util/kdevelop/kdevelop-3.3.0.ebuild6
3 files changed, 77 insertions, 4 deletions
diff --git a/dev-util/kdevelop/ChangeLog b/dev-util/kdevelop/ChangeLog
index 645b5aeabb42..d395190e0a11 100644
--- a/dev-util/kdevelop/ChangeLog
+++ b/dev-util/kdevelop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/kdevelop
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/ChangeLog,v 1.105 2005/11/23 11:31:36 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/ChangeLog,v 1.106 2005/11/25 09:01:56 greg_g Exp $
+
+ 25 Nov 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdevelop-3.3.0-makefiles.patch, kdevelop-3.3.0.ebuild:
+ Update patch for bug #86870.
*kdevelop-3.3.0 (23 Nov 2005)
diff --git a/dev-util/kdevelop/files/kdevelop-3.3.0-makefiles.patch b/dev-util/kdevelop/files/kdevelop-3.3.0-makefiles.patch
new file mode 100644
index 000000000000..9a28e5c3c183
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-3.3.0-makefiles.patch
@@ -0,0 +1,69 @@
+diff -Nur kdevelop-3.3.0.orig/buildtools/custommakefiles/customprojectpart.cpp kdevelop-3.3.0/buildtools/custommakefiles/customprojectpart.cpp
+--- kdevelop-3.3.0.orig/buildtools/custommakefiles/customprojectpart.cpp 2005-09-10 10:21:46.000000000 +0200
++++ kdevelop-3.3.0/buildtools/custommakefiles/customprojectpart.cpp 2005-11-24 21:26:16.000000000 +0100
+@@ -187,17 +187,17 @@
+ m_contextRemoveFiles.clear();
+
+ if( fcontext->urls().size() == 1 )
+- {
+- QString contextFileName = URLUtil::canonicalPath(fcontext->urls().first().fileName());
+- bool inProject = project()->isProjectFile(contextFileName);
+- QString popupstr = QFileInfo(contextFileName).fileName();
+- if (contextFileName.startsWith(projectDirectory()+ "/"))
+- contextFileName.remove(0, projectDirectory().length()+1);
++ {
++ QString canContextFileName =URLUtil::canonicalPath(fcontext->urls().first().path());
++ QString relContextFileName =URLUtil::extractPathNameRelative(URLUtil::canonicalPath(project()->projectDirectory()), canContextFileName);
++ QString popupstr =fcontext->urls().first().fileName();
++
++ bool inProject = project()->isProjectFile(canContextFileName);
+
+ popup->insertSeparator();
+ if (inProject)
+ {
+- m_contextRemoveFiles << contextFileName;
++ m_contextRemoveFiles << relContextFileName;
+ int id = popup->insertItem( i18n("Remove %1 From Project").arg(popupstr),
+ this, SLOT(slotRemoveFromProject()) );
+ popup->setWhatsThis(id, i18n("<b>Remove from project</b><p>Removes current file from the list of files in project. "
+@@ -205,7 +205,7 @@
+ }
+ else
+ {
+- m_contextAddFiles << contextFileName;
++ m_contextAddFiles << relContextFileName;
+ int id = popup->insertItem( i18n("Add %1 to Project").arg(popupstr),
+ this, SLOT(slotAddToProject()) );
+ popup->setWhatsThis(id, i18n("<b>Add to project</b><p>Adds current file to the list of files in project. "
+@@ -219,14 +219,12 @@
+ {
+ if ((*it).isLocalFile())
+ {
+- QString path(URLUtil::canonicalPath((*it).path()));
+- QString relPath( path );
+- if (relPath.startsWith(projectDirectory()+ "/"))
+- relPath.remove(0, projectDirectory().length()+1);
+- if (project()->isProjectFile(path))
+- m_contextRemoveFiles << relPath;
+- else
+- m_contextAddFiles << relPath;
++ QString canPath(URLUtil::canonicalPath((*it).path()));
++ QString relPath =URLUtil::extractPathNameRelative(URLUtil::canonicalPath(project()->projectDirectory()), canPath);
++ if (project()->isProjectFile(canPath))
++ m_contextRemoveFiles << relPath;
++ else
++ m_contextAddFiles << relPath;
+ }
+ }
+
+@@ -505,8 +503,8 @@
+ QStringList::ConstIterator it;
+
+ for ( it = fileList.begin(); it != fileList.end(); ++it )
+- {
+- m_sourceFiles.append ( *it );
++ {
++ m_sourceFiles.append (*it);
+ }
+
+ saveProject();
diff --git a/dev-util/kdevelop/kdevelop-3.3.0.ebuild b/dev-util/kdevelop/kdevelop-3.3.0.ebuild
index 90ef27d4e2e0..1670bfce0299 100644
--- a/dev-util/kdevelop/kdevelop-3.3.0.ebuild
+++ b/dev-util/kdevelop/kdevelop-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/kdevelop-3.3.0.ebuild,v 1.1 2005/11/23 11:31:36 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/kdevelop/kdevelop-3.3.0.ebuild,v 1.2 2005/11/25 09:01:56 greg_g Exp $
inherit kde eutils
@@ -28,8 +28,8 @@ src_unpack() {
kde_src_unpack
cd ${S}
- # See bug #86780 and kde bug 98852.
- epatch "${FILESDIR}/kdevelop-3.2.1-makefiles.patch"
+ # Fix for kde bug 98852. Applied for 3.4.0.
+ epatch "${FILESDIR}/kdevelop-3.3.0-makefiles.patch"
# Update the admin dir used in KDE template projects.
# See also kde bug 104386.