summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/xwelltris/xwelltris-1.0.1.ebuild')
-rw-r--r--games-puzzle/xwelltris/xwelltris-1.0.1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
index 12c1acf3236b..de3d7cce0a4c 100644
--- a/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
+++ b/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.1 2003/09/10 06:36:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xwelltris/xwelltris-1.0.1.ebuild,v 1.2 2003/11/12 21:19:21 mr_bones_ Exp $
inherit games
@@ -13,16 +13,21 @@ SLOT="0"
KEYWORDS="x86"
IUSE="sdl"
-DEPEND="|| (
- sdl? ( media-libs/libsdl )
+RDEPEND="|| (
+ sdl? ( media-libs/libsdl media-libs/sdl-image )
virtual/x11
)"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
src_compile() {
# configure/build process is pretty messed up
egamesconf `use_with sdl` || die
- sed -i "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" src/include/globals.h
- emake || die
+ sed -i \
+ -e "/GLOBAL_SEARCH/s:\".*\":\"${GAMES_DATADIR}/${PN}\":" \
+ src/include/globals.h || \
+ die "sed src/include/globals.h failed"
+ emake || die "emake failed"
}
src_install() {
@@ -31,7 +36,7 @@ src_install() {
INSTDIR=${D}/${GAMES_BINDIR} \
INSTLIB=${D}/${GAMES_DATADIR}/${PN} \
INSTMAN=/usr/share/man \
- || die
- dodoc AUTHORS Changelog README*
+ || die "make install failed"
+ dodoc AUTHORS Changelog README* || die "dodoc failed"
prepgamesdirs
}