summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog10
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-XI-2.2.patch44
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-double-unref.patch33
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild126
4 files changed, 212 insertions, 1 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index 3678950d01cc..a0c76d2c2624 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.104 2012/05/13 23:35:19 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.105 2012/05/20 10:43:38 tetromino Exp $
+
+*gnome-settings-daemon-3.4.2 (20 May 2012)
+
+ 20 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-settings-daemon-3.4.2.ebuild,
+ +files/gnome-settings-daemon-3.4.2-XI-2.2.patch,
+ +files/gnome-settings-daemon-3.4.2-double-unref.patch:
+ Version bump, fixes various bugs and plugs memory leaks.
*gnome-settings-daemon-3.4.1 (13 May 2012)
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-XI-2.2.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-XI-2.2.patch
new file mode 100644
index 000000000000..f2079dd81b88
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-XI-2.2.patch
@@ -0,0 +1,44 @@
+From 9d23fac4ce927cd27964323aa4cf8138e5128ba0 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Thu, 12 Apr 2012 13:51:09 +1000
+Subject: [PATCH] common: Try XI 2.2 if XI 2.0 fails
+
+The media-keys plugin calls supports_xinput2_devices(). That again calls
+XIQueryDevice with a major/minor of 2.0. The upstream server has a check
+for this in place and responds BadValue if a client initiates XI2 twice
+with two different versions (such both us and GTK+ checking for
+different versions). This happens here, and thus the plugin fails
+to load.
+
+The X server was fixed, but this is still required for older versions
+of the Xi code:
+http://cgit.freedesktop.org/xorg/xserver/commit/?id=ea51e9b2877df60135edaf2a8f88d0f2a2b41060
+
+https://bugzilla.gnome.org/show_bug.cgi?id=673964
+---
+ plugins/common/gsd-input-helper.c | 9 ++++++++-
+ 1 files changed, 8 insertions(+), 1 deletions(-)
+
+diff --git a/plugins/common/gsd-input-helper.c b/plugins/common/gsd-input-helper.c
+index cf9e83d..f06b507 100644
+--- a/plugins/common/gsd-input-helper.c
++++ b/plugins/common/gsd-input-helper.c
+@@ -129,7 +129,14 @@ supports_xinput2_devices (int *opcode)
+
+ if (XIQueryVersion (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), &major, &minor) != Success) {
+ gdk_error_trap_pop_ignored ();
+- return FALSE;
++ /* try for 2.2, maybe gtk has already announced 2.2 support */
++ gdk_error_trap_push ();
++ major = 2;
++ minor = 2;
++ if (XIQueryVersion (GDK_DISPLAY_XDISPLAY (gdk_display_get_default ()), &major, &minor) != Success) {
++ gdk_error_trap_pop_ignored ();
++ return FALSE;
++ }
+ }
+ gdk_error_trap_pop_ignored ();
+
+--
+1.7.8.6
+
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-double-unref.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-double-unref.patch
new file mode 100644
index 000000000000..8ae42e1b2393
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-3.4.2-double-unref.patch
@@ -0,0 +1,33 @@
+From f3e5a738c7d663adedb98829fb69bb389a10e775 Mon Sep 17 00:00:00 2001
+From: Daiki Ueno <ueno@unixuser.org>
+Date: Thu, 5 Apr 2012 16:41:12 +0900
+Subject: [PATCH] daemon: don't unref member objects twice on dispose
+
+https://bugzilla.gnome.org/show_bug.cgi?id=673555
+---
+ gnome-settings-daemon/gnome-settings-manager.c | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/gnome-settings-daemon/gnome-settings-manager.c b/gnome-settings-daemon/gnome-settings-manager.c
+index 13faeba..672c53f 100644
+--- a/gnome-settings-daemon/gnome-settings-manager.c
++++ b/gnome-settings-daemon/gnome-settings-manager.c
+@@ -461,11 +461,11 @@ gnome_settings_manager_stop (GnomeSettingsManager *manager)
+ manager->priv->owner_id = 0;
+ }
+
+- g_object_unref (manager->priv->settings);
+- manager->priv->settings = NULL;
++ if (manager->priv->settings)
++ g_clear_object (&manager->priv->settings);
+
+- g_object_unref (manager->priv->pnp_ids);
+- manager->priv->pnp_ids = NULL;
++ if (manager->priv->pnp_ids)
++ g_clear_object (&manager->priv->pnp_ids);
+ }
+
+ static void
+--
+1.7.8.6
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild
new file mode 100644
index 000000000000..760afcca7267
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.4.2.ebuild,v 1.1 2012/05/20 10:43:38 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+colord +cups debug packagekit policykit +short-touchpad-timeout smartcard systemd +udev wacom"
+
+# colord-0.1.13 needed to avoid polkit errors in CreateProfile and CreateDevice
+COMMON_DEPEND="
+ >=dev-libs/glib-2.31.0:2
+ >=x11-libs/gtk+-3.3.4:3
+ >=gnome-base/libgnomekbd-2.91.1
+ >=gnome-base/gnome-desktop-3.3.92:3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-0.9.16
+ >=sys-power/upower-0.9.11
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7.3
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.0
+ >=media-sound/pulseaudio-0.9.16
+
+ colord? ( >=x11-misc/colord-0.1.13 )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ packagekit? (
+ sys-fs/udev[gudev]
+ >=app-admin/packagekit-base-0.6.12 )
+ smartcard? (
+ sys-fs/udev[gudev]
+ >=dev-libs/nss-3.11.2 )
+ systemd? ( >=sys-apps/systemd-31 )
+ udev? ( sys-fs/udev[gudev] )
+ wacom? ( >=dev-libs/libwacom-0.3
+ x11-drivers/xf86-input-wacom )"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+ !systemd? ( sys-auth/consolekit )"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15"
+
+pkg_setup() {
+ # README is empty
+ DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable colord color)
+ $(use_enable cups)
+ $(use_enable debug)
+ $(use_enable debug more-warnings)
+ $(use_enable packagekit)
+ $(use_enable smartcard smartcard-support)
+ $(use_enable systemd)
+ $(use_enable udev gudev)
+ $(use_enable wacom)"
+}
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=621836
+ # Apparently this change severely affects touchpad usability for some
+ # people, so revert it if USE=short-touchpad-timeout.
+ # Revisit if/when upstream adds a setting for customizing the timeout.
+ use short-touchpad-timeout &&
+ epatch "${FILESDIR}/${PN}-3.0.2-short-touchpad-timeout.patch"
+
+ # Make colord and wacom optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.4.0-optional-color-wacom.patch"
+
+ # Useful patches in next release
+ epatch "${FILESDIR}/${P}-double-unref.patch"
+ epatch "${FILESDIR}/${P}-XI-2.2.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51gsettings-dconf
+ doenvd 51gsettings-dconf
+}