summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-libs/pantomime')
-rw-r--r--gnustep-libs/pantomime/ChangeLog10
-rw-r--r--gnustep-libs/pantomime/pantomime-1.2.0_pre3-r1.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/gnustep-libs/pantomime/ChangeLog b/gnustep-libs/pantomime/ChangeLog
index 1fdffabc9fa8..b032eb6fe3a4 100644
--- a/gnustep-libs/pantomime/ChangeLog
+++ b/gnustep-libs/pantomime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-libs/pantomime
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/ChangeLog,v 1.22 2008/03/08 13:15:12 coldwind Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/ChangeLog,v 1.23 2009/07/07 15:53:18 voyageur Exp $
+
+*pantomime-1.2.0_pre3-r1 (07 Jul 2009)
+
+ 07 Jul 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +pantomime-1.2.0_pre3-r1.ebuild:
+ Fix compilation with forced --as-needed, bug #276885
08 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
pantomime-1.2.0_pre3.ebuild:
diff --git a/gnustep-libs/pantomime/pantomime-1.2.0_pre3-r1.ebuild b/gnustep-libs/pantomime/pantomime-1.2.0_pre3-r1.ebuild
new file mode 100644
index 000000000000..93bce84e3c6b
--- /dev/null
+++ b/gnustep-libs/pantomime/pantomime-1.2.0_pre3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/pantomime/pantomime-1.2.0_pre3-r1.ebuild,v 1.1 2009/07/07 15:53:18 voyageur Exp $
+
+EAPI=2
+inherit gnustep-2
+
+MY_PN=${PN/p/P}
+
+S=${WORKDIR}/${MY_PN}
+
+DESCRIPTION="A set of Objective-C classes that model a mail system."
+HOMEPAGE="http://www.collaboration-world.com/pantomime/"
+SRC_URI="http://www.collaboration-world.com/pantomime.data/releases/Stable/${MY_PN}-${PV/_/}.tar.gz"
+
+LICENSE="LGPL-2.1 Elm"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s|ADDITIONAL_LDFLAGS|LIBRARIES_DEPEND_UPON|" \
+ Framework/Pantomime/GNUmakefile || die "as-needed sed failed"
+}
+
+src_install() {
+ gnustep-base_src_install
+
+ cd "${S}"/Documentation
+ dodoc AUTHORS README TODO
+ docinto rfc
+ dodoc RFC/*
+}