summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog7
-rw-r--r--kde-base/kpilot/kpilot-4.3.0.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index 479285818f83..8cad7f7dd053 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.89 2009/07/12 13:36:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.90 2009/08/04 00:55:20 wired Exp $
+
+*kpilot-4.3.0 (04 Aug 2009)
+
+ 04 Aug 2009; Alex Alexander <wired@gentoo.org> +kpilot-4.3.0.ebuild:
+ Version bump
12 Jul 2009; Raúl Porcel <armin76@gentoo.org> kpilot-3.5.10.ebuild:
alpha/ia64/sparc stable wrt #271889
diff --git a/kde-base/kpilot/kpilot-4.3.0.ebuild b/kde-base/kpilot/kpilot-4.3.0.ebuild
new file mode 100644
index 000000000000..ac7844c4838d
--- /dev/null
+++ b/kde-base/kpilot/kpilot-4.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-4.3.0.ebuild,v 1.1 2009/08/04 00:55:20 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KPilot is software for syncing PalmOS based handhelds."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="avantgo crypt debug +handbook"
+
+DEPEND="
+ >=app-pda/pilot-link-0.12
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+ avantgo? ( >=dev-libs/libmal-0.40 )
+ crypt? ( app-crypt/qca:2 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with avantgo Mal)
+ $(cmake-utils_use_with crypt QCA2)"
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test (as of 4.2.87)
+ sed -i -e '/keyringcategorysynctest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/conduits/keyringconduit/tests/CMakeLists.txt || \
+ die "sed to disable keyringcategorysynctest failed."
+
+ kde4-meta_src_test
+}