summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxlauncher/ChangeLog8
-rw-r--r--lxde-base/lxlauncher/files/lxlauncher-0.2.1-fix-segfault.patch124
-rw-r--r--lxde-base/lxlauncher/files/lxlauncher-0.2.1-intltool.patch15
-rw-r--r--lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild44
-rw-r--r--lxde-base/lxlauncher/lxlauncher-0.2.1.ebuild43
5 files changed, 7 insertions, 227 deletions
diff --git a/lxde-base/lxlauncher/ChangeLog b/lxde-base/lxlauncher/ChangeLog
index 5731e3f85518..fea6b20dafaa 100644
--- a/lxde-base/lxlauncher/ChangeLog
+++ b/lxde-base/lxlauncher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxde-base/lxlauncher
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/ChangeLog,v 1.17 2014/05/14 18:16:24 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/ChangeLog,v 1.18 2014/07/26 13:11:16 ssuominen Exp $
+
+ 26 Jul 2014; Samuli Suominen <ssuominen@gentoo.org>
+ -files/lxlauncher-0.2.1-fix-segfault.patch,
+ -files/lxlauncher-0.2.1-intltool.patch, -lxlauncher-0.2.1-r1.ebuild,
+ -lxlauncher-0.2.1.ebuild:
+ old
14 May 2014; Tom Wijsman <TomWij@gentoo.org> lxlauncher-0.2.1-r1.ebuild:
[QA] EAPI 1 -> 5. Added missing dependencies using ELF's NEEDED entries.
diff --git a/lxde-base/lxlauncher/files/lxlauncher-0.2.1-fix-segfault.patch b/lxde-base/lxlauncher/files/lxlauncher-0.2.1-fix-segfault.patch
deleted file mode 100644
index 473b516b8a60..000000000000
--- a/lxde-base/lxlauncher/files/lxlauncher-0.2.1-fix-segfault.patch
+++ /dev/null
@@ -1,124 +0,0 @@
---- src/lxlauncher.c 2009-07-07 15:48:19.000000000 +0300
-+++ src/lxlauncher.c.new 2010-06-09 21:09:24.000000000 +0300
-@@ -311,6 +311,7 @@
- {
- // Dirty hacks used to force pseudo-transparent background
- gtk_widget_queue_draw( data->table );
-+ return TRUE;
- }
-
- // Dirty hacks used to reduce unnecessary redrew during scroll
-@@ -662,18 +663,38 @@
- gchar *file;
-
- file = g_build_filename(user_dir, name, NULL);
-- if (g_file_test(file, G_FILE_TEST_EXISTS) == TRUE) {
-- return file;
-- }
-+ if (g_file_test(file, G_FILE_TEST_EXISTS) == TRUE)
-+ return file;
- free(file);
-
- for (dir = system_dirs; *dir; ++dir ) {
-- file = g_build_filename(*dir, name, NULL);
-- if (g_file_test(file, G_FILE_TEST_EXISTS) == TRUE) {
-- return file;
-- }
-- free(file);
-+ file = g_build_filename(*dir, name, NULL);
-+ if (g_file_test(file, G_FILE_TEST_EXISTS) == TRUE)
-+ return file;
-+ free(file);
-+ }
-+ return NULL;
-+}
-+
-+static void on_menu_cache_reload(MenuCache* mc, gpointer user_data)
-+{
-+ GMainLoop* mainloop = (GMainLoop*)user_data;
-+ g_main_loop_quit(mainloop);
-+}
-+
-+MenuCache* _menu_cache_lookup_sync( const char* menu_name )
-+{
-+ MenuCache* mc = menu_cache_lookup(menu_name);
-+ /* ensure that the menu cache is loaded */
-+ if(! menu_cache_get_root_dir(mc)) /* if it's not yet loaded */
-+ {
-+ GMainLoop* mainloop = g_main_loop_new(NULL, FALSE);
-+ gpointer notify_id = menu_cache_add_reload_notify(mc, on_menu_cache_reload, mainloop);
-+ g_main_loop_run(mainloop);
-+ g_main_loop_unref(mainloop);
-+ menu_cache_remove_reload_notify(mc, notify_id);
- }
-+ return mc;
- }
-
- int main(int argc, char** argv)
-@@ -695,13 +716,14 @@
- GError *error = NULL;
- gchar *config_file = get_xdg_config_file(CONFIG_FILE);
- if (config_file &&
-- g_key_file_load_from_file(key_file,
-- config_file,
-- G_KEY_FILE_NONE,
-- &error)) {
-- printf("Loaded %s\n", config_file);
-- } else {
-- perror("Error loading " CONFIG_FILE);
-+ g_key_file_load_from_file(key_file,
-+ config_file,
-+ G_KEY_FILE_NONE,
-+ &error)) {
-+ printf("Loaded %s\n", config_file);
-+ }
-+ else {
-+ perror("Error loading " CONFIG_FILE);
- }
- if (config_file)
- free(config_file);
-@@ -711,21 +733,23 @@
- // Add application specific properties
- gtk_settings_install_property(g_param_spec_boolean("lxlauncher-enable-key",
- _("Enable key navigation"),
-- _("Allow users to use up/down/left/right/tab/enter keys to operate the lxlaucher"),
-+ _("Allow users to use up/down/left/right/tab/enter keys to operate the lxlauncher"),
- FALSE,GTK_ARG_READWRITE));
- // set up themes for notebook
- gchar* gtkrc_file = get_xdg_config_file("lxlauncher/gtkrc");
- gtk_rc_parse(gtkrc_file);
- if (gtkrc_file) {
-- free(gtkrc_file);
-+ free(gtkrc_file);
- }
-
- button_size = g_key_file_get_integer(key_file, "Main", "BUTTON_SIZE", NULL);
- img_size = g_key_file_get_integer(key_file, "Main", "IMG_SIZE", NULL);
-
- // to prevent from going without configure file
-- if(!button_size) button_size = BUTTON_SIZE_FALLBACK;
-- if(!img_size) img_size = IMG_SIZE_FALLBACK;
-+ if(!button_size)
-+ button_size = BUTTON_SIZE_FALLBACK;
-+ if(!img_size)
-+ img_size = IMG_SIZE_FALLBACK;
-
- icon_size = gtk_icon_size_register( "ALIcon", img_size, img_size );
-
-@@ -756,9 +780,14 @@
- gtk_container_add( (GtkContainer*)main_window, notebook );
-
- g_setenv("XDG_MENU_PREFIX", "lxlauncher-", TRUE);
-- menu_tree = menu_cache_lookup( "applications.menu" );
-+ menu_tree = _menu_cache_lookup_sync( "applications.menu" );
-+ if(!menu_tree)
-+ {
-+ g_print("Unable to load application menu\n");
-+ return 1;
-+ }
-+ root_dir = menu_cache_item_ref(menu_cache_get_root_dir( menu_tree ));
- reload_notify_id = menu_cache_add_reload_notify( menu_tree, on_menu_tree_changed, NULL );
-- root_dir = menu_cache_ref(menu_cache_get_root_dir( menu_tree ));
-
- create_notebook_pages();
-
diff --git a/lxde-base/lxlauncher/files/lxlauncher-0.2.1-intltool.patch b/lxde-base/lxlauncher/files/lxlauncher-0.2.1-intltool.patch
deleted file mode 100644
index adbce4979986..000000000000
--- a/lxde-base/lxlauncher/files/lxlauncher-0.2.1-intltool.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -NrU5 lxlauncher-0.2.1.original/configure.in lxlauncher-0.2.1/configure.in
---- lxlauncher-0.2.1.original/configure.in 2009-07-18 21:49:07.000000000 -0600
-+++ lxlauncher-0.2.1/configure.in 2009-07-18 21:49:50.000000000 -0600
-@@ -2,10 +2,11 @@
-
- AC_INIT(configure.in)
- AM_INIT_AUTOMAKE(lxlauncher, 0.2.1)
- AM_CONFIG_HEADER(config.h)
- AM_MAINTAINER_MODE
-+IT_PROG_INTLTOOL
-
- AC_ISC_POSIX
- AC_PROG_CC
- AM_PROG_CC_STDC
- AC_HEADER_STDC
diff --git a/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild b/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild
deleted file mode 100644
index 53b30c7d65cb..000000000000
--- a/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/lxlauncher-0.2.1-r1.ebuild,v 1.4 2014/05/14 18:16:24 tomwij Exp $
-
-EAPI="5"
-
-inherit autotools eutils
-
-DESCRIPTION="An open source clone of the Asus launcher for EeePC"
-HOMEPAGE="http://lxde.sf.net/"
-SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- gnome-base/gnome-menus
- x11-libs/cairo
- x11-libs/libX11
- x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:2
- x11-libs/startup-notification"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/intltool
- sys-devel/gettext
- lxde-base/menu-cache
- !lxde-base/lxlauncher-gmenu"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-intltool.patch
- epatch "${FILESDIR}"/${P}-fix-segfault.patch
-
- # Rerun autotools
- einfo "Regenerating autotools files..."
- eautoreconf
-
- # Support as-needed and add missing libraries.
- sed -e 's/^\(LINK = .*\) -o $@$/\1/' \
- -e 's/$(lxlauncher_OBJECTS) $(lxlauncher_LDADD) $(LIBS)/\0 -lX11 -o $@/' \
- -i src/Makefile.in || die
-}
diff --git a/lxde-base/lxlauncher/lxlauncher-0.2.1.ebuild b/lxde-base/lxlauncher/lxlauncher-0.2.1.ebuild
deleted file mode 100644
index a94ceb23602c..000000000000
--- a/lxde-base/lxlauncher/lxlauncher-0.2.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxlauncher/lxlauncher-0.2.1.ebuild,v 1.8 2012/05/04 05:50:39 jdhore Exp $
-
-EAPI="1"
-
-inherit autotools eutils
-
-DESCRIPTION="An open source clone of the Asus launcher for EeePC"
-HOMEPAGE="http://lxde.sf.net/"
-SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2
- x11-libs/gtk+:2
- gnome-base/gnome-menus
- x11-libs/startup-notification"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/intltool
- sys-devel/gettext
- lxde-base/menu-cache
- !lxde-base/lxlauncher-gmenu"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-intltool.patch
-
- # Rerun autotools
- einfo "Regenerating autotools files..."
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README
-}