summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog8
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12.3-lastfm.patch20
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild161
3 files changed, 188 insertions, 1 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 93236037c68b..8d103f2253ca 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.153 2009/07/06 21:55:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.154 2009/08/09 21:52:08 eva Exp $
+
+*rhythmbox-0.12.3-r1 (09 Aug 2009)
+
+ 09 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +rhythmbox-0.12.3-r1.ebuild, +files/rhythmbox-0.12.3-lastfm.patch:
+ Fix last.fm plugin linking, bug #276972.
*rhythmbox-0.12.3 (06 Jul 2009)
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12.3-lastfm.patch b/media-sound/rhythmbox/files/rhythmbox-0.12.3-lastfm.patch
new file mode 100644
index 000000000000..5a883459648d
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.12.3-lastfm.patch
@@ -0,0 +1,20 @@
+commit df34ae56b0d8e57f2415264c168f8021c656c17d
+Author: Götz Waschk <waschk@mandriva.org>
+Date: Sat Jul 11 12:39:46 2009 +1000
+
+ last.fm: link the plugin with libsoup-gnome (bug #588248)
+
+diff --git a/plugins/audioscrobbler/Makefile.am b/plugins/audioscrobbler/Makefile.am
+index 558f509..ef063d9 100644
+--- a/plugins/audioscrobbler/Makefile.am
++++ b/plugins/audioscrobbler/Makefile.am
+@@ -18,7 +18,8 @@ libaudioscrobbler_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+ libaudioscrobbler_la_LIBTOOLFLAGS = --tag=disable-static
+ libaudioscrobbler_la_LIBADD = \
+ $(top_builddir)/corelib/librhythmbox-core.la \
+- $(TOTEM_PLPARSER_LIBS)
++ $(TOTEM_PLPARSER_LIBS) \
++ $(RHYTHMBOX_LIBS)
+
+ INCLUDES = \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
diff --git a/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild
new file mode 100644
index 000000000000..787a109e645f
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.3-r1.ebuild,v 1.1 2009/08/09 21:52:08 eva Exp $
+
+EAPI="2"
+WANT_AUTOMAKE="1.10"
+
+inherit eutils gnome2 python multilib virtualx
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+brasero cdr daap doc hal ipod gnome-keyring libnotify lirc musicbrainz mtp nsplugin python test"
+
+# FIXME: double check what to do with fm-radio plugin
+
+SLOT="0"
+
+COMMON_DEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.16
+ >=dev-libs/dbus-glib-0.71
+ >=dev-libs/totem-pl-parser-2.26.0
+ >=gnome-base/gconf-2
+ >=gnome-extra/gnome-media-2.14.0
+ >=net-libs/libsoup-2.26:2.4[gnome]
+
+ >=media-libs/gst-plugins-base-0.10.20
+
+ cdr? (
+ brasero? ( >=app-cdr/brasero-0.9.1 )
+ !brasero? ( >=gnome-extra/nautilus-cd-burner-2.21.6 ) )
+ daap? ( >=net-dns/avahi-0.6 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ hal? (
+ ipod? ( >=media-libs/libgpod-0.6 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ >=sys-apps/hal-0.5 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ lirc? ( app-misc/lirc )
+ musicbrainz? ( media-libs/musicbrainz:3 )
+ python? (
+ >=dev-lang/python-2.4.2
+ || (
+ >=dev-lang/python-2.5
+ dev-python/celementtree )
+ >=dev-python/pygtk-2.8
+ >=dev-python/gnome-vfs-python-2.22.0
+ >=dev-python/gconf-python-2.22.0
+ >=dev-python/libgnome-python-2.22.0
+ >=dev-python/gst-python-0.10.8 )"
+
+RDEPEND="${COMMON_DEPEND}
+ >=media-plugins/gst-plugins-soup-0.10
+ >=media-plugins/gst-plugins-libmms-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10 )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-taglib-0.10.6
+ nsplugin? ( || (
+ net-libs/xulrunner
+ www-client/seamonkey
+ www-client/mozilla-firefox ) )"
+
+# gtk-doc-am needed for eautoreconf
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1.4 )
+ test? ( dev-libs/check )"
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS MAINTAINERS.old NEWS README THANKS"
+
+pkg_setup() {
+ if ! use hal && use ipod; then
+ ewarn "ipod support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable ipod support"
+ fi
+
+ if ! use hal && use mtp; then
+ ewarn "MTP support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable MTP support"
+ fi
+
+ if ! use cdr ; then
+ ewarn "You have cdr USE flag disabled."
+ ewarn "You will not be able to play audio CDs."
+ fi
+
+ if use brasero; then
+ G2CONF="${G2CONF} $(use_with cdr libbrasero-media) --without-libnautilus-burn"
+ else
+ G2CONF="${G2CONF} $(use_with cdr libnautilus-burn) --without-libbrasero-media"
+ fi
+
+ G2CONF="${G2CONF}
+ MOZILLA_PLUGINDIR=/usr/$(get_libdir)/nsbrowser/plugins
+ $(use_with gnome-keyring)
+ $(use_with ipod)
+ $(use_enable libnotify)
+ $(use_enable lirc)
+ $(use_enable musicbrainz)
+ $(use_with mtp)
+ $(use_enable nsplugin browser-plugin)
+ $(use_enable python)
+ $(use_enable daap)
+ $(use_with daap mdns avahi)
+ --enable-mmkeys
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-static
+ --disable-vala"
+
+ export GST_INSPECT=/bin/true
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Fix last.fm plugin linking, bug #276972
+ epatch "${FILESDIR}/${P}-lastfm.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautomake
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "test failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
+
+ ewarn
+ ewarn "If ${PN} doesn't play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
+}