summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/snd/ChangeLog8
-rw-r--r--media-sound/snd/files/snd-12.6-as-needed.patch37
-rw-r--r--media-sound/snd/snd-12.1.ebuild101
-rw-r--r--media-sound/snd/snd-12.2.ebuild101
-rw-r--r--media-sound/snd/snd-12.3.ebuild106
-rw-r--r--media-sound/snd/snd-12.6.ebuild (renamed from media-sound/snd/snd-12.4.ebuild)9
6 files changed, 49 insertions, 313 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index 97fd4859e075..adcce54fae55 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/snd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.57 2011/10/01 07:22:27 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.58 2011/11/11 07:00:38 radhermit Exp $
+
+*snd-12.6 (11 Nov 2011)
+
+ 11 Nov 2011; Tim Harder <radhermit@gentoo.org> -snd-12.1.ebuild,
+ -snd-12.2.ebuild, -snd-12.3.ebuild, -snd-12.4.ebuild, +snd-12.6.ebuild:
+ Version bump and remove old.
*snd-12.5 (01 Oct 2011)
diff --git a/media-sound/snd/files/snd-12.6-as-needed.patch b/media-sound/snd/files/snd-12.6-as-needed.patch
new file mode 100644
index 000000000000..d2f0bcbe9d8b
--- /dev/null
+++ b/media-sound/snd/files/snd-12.6-as-needed.patch
@@ -0,0 +1,37 @@
+--- snd-12.6/configure.ac.orig
++++ snd-12.6/configure.ac
+@@ -1468,7 +1468,7 @@
+ LDSO_FLAGS="-shared"
+ LIBS="$LIBS -lm"
+ if test "$ac_cv_header_dlfcn_h" = yes ; then
+- LDFLAGS="$LDFLAGS -ldl"
++ LIBS="$LIBS -ldl"
+ fi
+ if test "$GCC" = yes ; then
+ SO_FLAGS="-fPIC $SO_FLAGS"
+@@ -1979,7 +1979,7 @@
+ if test "$ac_snd_have_extension_language" = yes ; then
+ if test "$ac_snd_have_gui" = yes ; then
+ if test "$ac_cv_header_pthread_h" = yes ; then
+- LDFLAGS="$LDFLAGS -lpthread"
++ LIBS="$LIBS -lpthread"
+ fi
+ fi
+ fi
+@@ -1987,14 +1987,14 @@
+ if test "$ac_snd_have_extension_language" = no ; then
+ if test "$ac_snd_have_gui" = no ; then
+ if test "$ac_cv_header_dlfcn_h" = yes ; then
+- LDFLAGS="$LDFLAGS -ldl"
++ LIBS="$LIBS -ldl"
+ fi
+ AC_MSG_WARN([Snd needs either an extension language (s7, Fth, or Ruby), or a graphics toolkit (Gtk or Motif), or preferably both. As currently configured, this version of Snd is useless.])
+ fi
+ fi
+
+ if test "$ac_snd_have_extension_language" = yes && test "$with_audio" = no && test "$ac_cv_header_dlfcn_h" = yes ; then
+- LDFLAGS="$LDFLAGS -ldl"
++ LIBS="$LIBS -ldl"
+ fi
+
+
diff --git a/media-sound/snd/snd-12.1.ebuild b/media-sound/snd/snd-12.1.ebuild
deleted file mode 100644
index 59ebac4e580e..000000000000
--- a/media-sound/snd/snd-12.1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.1.ebuild,v 1.3 2011/05/03 08:35:11 radhermit Exp $
-
-EAPI=4
-
-inherit multilib flag-o-matic
-
-DESCRIPTION="Snd is a sound editor"
-HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
-SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="alsa esd fam fftw gmp gsl gtk jack ladspa motif opengl oss portaudio pulseaudio ruby"
-
-RDEPEND="media-libs/audiofile
- sys-libs/readline
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- fam? ( virtual/fam )
- fftw? ( sci-libs/fftw )
- gmp? ( dev-libs/gmp
- dev-libs/mpc
- dev-libs/mpfr )
- gsl? ( >=sci-libs/gsl-0.8 )
- gtk? ( x11-libs/gtk+:3
- x11-libs/pango
- x11-libs/cairo
- opengl? ( x11-libs/gtkglext ) )
- jack? ( media-sound/jack-audio-connection-kit )
- ladspa? ( media-libs/ladspa-sdk )
- motif? ( >=x11-libs/openmotif-2.3:0 )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- ruby? ( dev-lang/ruby )"
-
-pkg_setup() {
- if ! use gtk && ! use motif; then
- ewarn "Warning: no graphic toolkit selected (gtk or motif)."
- ewarn "Upstream suggests to enable one of the toolkits (or both)"
- ewarn "or only the command line utilities will be helpful."
- fi
-}
-
-src_configure() {
- # Workaround executable sections QA warning (bug #348754)
- append-ldflags -Wl,-z,noexecstack
-
- local myconf
- if use opengl; then
- myconf="${myconf} --with-just-gl"
- else
- myconf="${myconf} --without-gl"
- fi
-
- econf \
- $(use_with alsa) \
- $(use_with esd) \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gmp) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_with oss) \
- $(use_with portaudio) \
- $(use_with pulseaudio) \
- $(use_with ruby) \
- --with-float-samples \
- ${myconf}
-
-}
-
-src_compile() {
- emake snd
-
- # Do not compile ruby extensions for command line programs since they fail
- sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h
-
- for i in sndinfo audinfo sndplay; do
- emake ${i}
- done
-}
-
-src_install () {
- dobin snd
- dobin sndplay
- dobin sndinfo
- dobin audinfo
-
- insinto /usr/$(get_libdir)/snd/scheme
- doins *.scm
-
- dodoc README.Snd HISTORY.Snd NEWS
- dohtml -r *.html pix/*.png tutorial
-}
diff --git a/media-sound/snd/snd-12.2.ebuild b/media-sound/snd/snd-12.2.ebuild
deleted file mode 100644
index 02e3232ab69c..000000000000
--- a/media-sound/snd/snd-12.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.2.ebuild,v 1.1 2011/06/09 08:52:57 radhermit Exp $
-
-EAPI=4
-
-inherit multilib flag-o-matic
-
-DESCRIPTION="Snd is a sound editor"
-HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
-SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="alsa esd fam fftw gmp gsl gtk jack ladspa motif opengl oss portaudio pulseaudio ruby"
-
-RDEPEND="media-libs/audiofile
- sys-libs/readline
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- fam? ( virtual/fam )
- fftw? ( sci-libs/fftw )
- gmp? ( dev-libs/gmp
- dev-libs/mpc
- dev-libs/mpfr )
- gsl? ( >=sci-libs/gsl-0.8 )
- gtk? ( x11-libs/gtk+:3
- x11-libs/pango
- x11-libs/cairo
- opengl? ( x11-libs/gtkglext ) )
- jack? ( media-sound/jack-audio-connection-kit )
- ladspa? ( media-libs/ladspa-sdk )
- motif? ( >=x11-libs/openmotif-2.3:0 )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- ruby? ( dev-lang/ruby )"
-
-pkg_setup() {
- if ! use gtk && ! use motif; then
- ewarn "Warning: no graphic toolkit selected (gtk or motif)."
- ewarn "Upstream suggests to enable one of the toolkits (or both)"
- ewarn "or only the command line utilities will be helpful."
- fi
-}
-
-src_configure() {
- # Workaround executable sections QA warning (bug #348754)
- append-ldflags -Wl,-z,noexecstack
-
- local myconf
- if use opengl; then
- myconf="${myconf} --with-just-gl"
- else
- myconf="${myconf} --without-gl"
- fi
-
- econf \
- $(use_with alsa) \
- $(use_with esd) \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gmp) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_with oss) \
- $(use_with portaudio) \
- $(use_with pulseaudio) \
- $(use_with ruby) \
- --with-float-samples \
- ${myconf}
-
-}
-
-src_compile() {
- emake snd
-
- # Do not compile ruby extensions for command line programs since they fail
- sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h
-
- for i in sndinfo audinfo sndplay; do
- emake ${i}
- done
-}
-
-src_install () {
- dobin snd
- dobin sndplay
- dobin sndinfo
- dobin audinfo
-
- insinto /usr/$(get_libdir)/snd/scheme
- doins *.scm
-
- dodoc README.Snd HISTORY.Snd NEWS
- dohtml -r *.html pix/*.png tutorial
-}
diff --git a/media-sound/snd/snd-12.3.ebuild b/media-sound/snd/snd-12.3.ebuild
deleted file mode 100644
index 12f0b4f58217..000000000000
--- a/media-sound/snd/snd-12.3.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.3.ebuild,v 1.1 2011/08/22 08:45:53 radhermit Exp $
-
-EAPI=4
-
-inherit multilib flag-o-matic autotools
-
-DESCRIPTION="Snd is a sound editor"
-HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
-SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE="alsa esd fam fftw gmp gsl gtk jack ladspa motif opengl oss portaudio pulseaudio ruby"
-
-RDEPEND="media-libs/audiofile
- sys-libs/readline
- alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- fam? ( virtual/fam )
- fftw? ( sci-libs/fftw )
- gmp? ( dev-libs/gmp
- dev-libs/mpc
- dev-libs/mpfr )
- gsl? ( >=sci-libs/gsl-0.8 )
- gtk? ( x11-libs/gtk+:3
- x11-libs/pango
- x11-libs/cairo
- opengl? ( x11-libs/gtkglext ) )
- jack? ( media-sound/jack-audio-connection-kit )
- ladspa? ( media-libs/ladspa-sdk )
- motif? ( >=x11-libs/openmotif-2.3:0 )
- opengl? ( virtual/opengl )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- ruby? ( dev-lang/ruby )"
-
-pkg_setup() {
- if ! use gtk && ! use motif; then
- ewarn "Warning: no graphic toolkit selected (gtk or motif)."
- ewarn "Upstream suggests to enable one of the toolkits (or both)"
- ewarn "or only the command line utilities will be helpful."
- fi
-}
-
-src_prepare() {
- sed -i -e "s:-O2 ::" configure.ac || die
- eautoreconf
-}
-
-src_configure() {
- # Workaround executable sections QA warning (bug #348754)
- append-ldflags -Wl,-z,noexecstack
-
- local myconf
- if use opengl; then
- myconf="${myconf} --with-just-gl"
- else
- myconf="${myconf} --without-gl"
- fi
-
- econf \
- $(use_with alsa) \
- $(use_with esd) \
- $(use_with fam) \
- $(use_with fftw) \
- $(use_with gmp) \
- $(use_with gsl) \
- $(use_with gtk) \
- $(use_with jack) \
- $(use_with ladspa) \
- $(use_with motif) \
- $(use_with oss) \
- $(use_with portaudio) \
- $(use_with pulseaudio) \
- $(use_with ruby) \
- --with-float-samples \
- ${myconf}
-
-}
-
-src_compile() {
- emake snd
-
- # Do not compile ruby extensions for command line programs since they fail
- sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h
-
- for i in sndinfo audinfo sndplay; do
- emake ${i}
- done
-}
-
-src_install () {
- dobin snd
- dobin sndplay
- dobin sndinfo
- dobin audinfo
-
- insinto /usr/$(get_libdir)/snd/scheme
- doins *.scm
-
- dodoc README.Snd HISTORY.Snd NEWS
- dohtml -r *.html pix/*.png tutorial
-}
diff --git a/media-sound/snd/snd-12.4.ebuild b/media-sound/snd/snd-12.6.ebuild
index bfd484b31094..58a5ed267324 100644
--- a/media-sound/snd/snd-12.4.ebuild
+++ b/media-sound/snd/snd-12.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.4.ebuild,v 1.1 2011/08/30 08:23:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-12.6.ebuild,v 1.1 2011/11/11 07:00:38 radhermit Exp $
EAPI=4
@@ -44,7 +44,7 @@ REQUIRED_USE="^^ (
)"
pkg_setup() {
- if ! use gtk && ! use motif; then
+ if ! use gtk && ! use motif ; then
ewarn "Warning: no graphic toolkit selected (gtk or motif)."
ewarn "Upstream suggests to enable one of the toolkits (or both)"
ewarn "or only the command line utilities will be helpful."
@@ -52,6 +52,7 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
sed -i -e "s:-O2 ::" configure.ac || die
eautoreconf
}
@@ -61,7 +62,7 @@ src_configure() {
append-ldflags -Wl,-z,noexecstack
local myconf
- if use opengl; then
+ if use opengl ; then
myconf+=" --with-just-gl"
else
myconf+=" --without-gl"
@@ -99,7 +100,7 @@ src_compile() {
# Do not compile ruby extensions for command line programs since they fail
sed -i -e "s:HAVE_RUBY 1:HAVE_RUBY 0:" mus-config.h
- for i in sndinfo audinfo sndplay; do
+ for i in sndinfo audinfo sndplay ; do
emake ${i}
done
}