summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lve/lve-040322.ebuild')
-rw-r--r--media-video/lve/lve-040322.ebuild22
1 files changed, 19 insertions, 3 deletions
diff --git a/media-video/lve/lve-040322.ebuild b/media-video/lve/lve-040322.ebuild
index 51c7007ac114..d1ca5b191b64 100644
--- a/media-video/lve/lve-040322.ebuild
+++ b/media-video/lve/lve-040322.ebuild
@@ -1,19 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.5 2004/06/25 00:44:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/lve/lve-040322.ebuild,v 1.6 2004/07/11 07:33:28 morfic Exp $
-inherit eutils
+inherit eutils gcc
# This is the version of ffmpeg lve must currently be compiled against
FFMPEG="ffmpeg-0.4.8"
+PDATE=20${PV##*.}
DESCRIPTION="Linux Video Editor"
HOMEPAGE="http://lvempeg.sourceforge.net"
SRC_URI="http://heanet.dl.sourceforge.net/sourceforge/lvempeg/lve-040322.src.tar.bz2
-http://heanet.dl.sourceforge.net/sourceforge/ffmpeg/ffmpeg-0.4.8.tar.gz"
+http://download.videolan.org/pub/videolan/vlc/0.7.1/contrib/ffmpeg-${PDATE}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
KEYWORDS="~x86 ~ppc"
DEPEND="virtual/x11
>=media-libs/libsdl-1.2.6-r3
@@ -28,6 +30,20 @@ src_unpack() {
# Patch to change LIB and BIN paths
epatch ${FILESDIR}/${PV}-lve.patch
+
+ cd ${WORKDIR}/lve
+
+ rm ffmpeg
+ ln -s ../ffmpeg-20040322 ffmpeg
+
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ einfo "Compiler used: gcc-3.4.x Applying patch conditionally."
+ sed -i "s:(T_REGION \*):T_REGION \*:" src/region.c || die "Source couldnt be fixed"
+ cd ffmpeg
+ epatch ${FILESDIR}/0.4.8-gcc3.4-magicF2W.patch
+ cd ${WORKDIR}/lve
+ fi
}
src_compile() {