summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ethereal')
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.5-r1.ebuild62
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild6
-rw-r--r--net-analyzer/ethereal/ethereal-0.9.5.ebuild55
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.51
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.9.5-r11
5 files changed, 4 insertions, 121 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.9.5-r1.ebuild b/net-analyzer/ethereal/ethereal-0.9.5-r1.ebuild
deleted file mode 100644
index fea64e5d7da4..000000000000
--- a/net-analyzer/ethereal/ethereal-0.9.5-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.5-r1.ebuild,v 1.1 2002/06/29 19:30:01 blocke Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A commercial-quality network protocol analyzer"
-SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
-HOMEPAGE="http://www.ethereal.com/"
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="virtual/glibc
- >=sys-libs/zlib-1.1.4
- =dev-libs/glib-1.2*
- snmp? ( >=net-analyzer/ucd-snmp-4.2.5 )
- X? ( virtual/x11 =x11-libs/gtk+-1.2* )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-DEPEND="${RDEPEND}
- sys-devel/perl
- sys-devel/bison
- sys-devel/flex
- >=net-libs/libpcap-0.7.1"
-
-src_compile() {
- local myconf
- use X || myconf="${myconf} --disable-ethereal"
- use ssl || myconf="${myconf} --without-ssl"
- use snmp || myconf="${myconf} --without-ucdsnmp"
-
- ./configure \
- --prefix=/usr \
- --enable-pcap \
- --enable-zlib \
- --enable-ipv6 \
- --enable-tethereal \
- --enable-editcap \
- --enable-mergecap \
- --enable-text2cap \
- --enable-idl2eth \
- --enable-dftest \
- --enable-randpkt \
- --includedir="" \
- --mandir=/usr/share/man \
- --sysconfdir=/etc/ethereal \
- --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
- --host=${CHOST} ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
- dodir /usr/lib/ethereal/plugins/${PV}
-
- make install \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- sysconfdir=${D}/etc/ethereal \
- plugindir=${D}/usr/lib/ethereal/plugins/${PV} || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
-}
diff --git a/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild b/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild
index 7b99714030de..410fea6e84ac 100644
--- a/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild,v 1.1 2002/06/30 03:06:55 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.5-r2.ebuild,v 1.2 2002/07/18 23:22:43 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A commercial-quality network protocol analyzer"
SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
HOMEPAGE="http://www.ethereal.com/"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
RDEPEND="virtual/glibc
>=sys-libs/zlib-1.1.4
diff --git a/net-analyzer/ethereal/ethereal-0.9.5.ebuild b/net-analyzer/ethereal/ethereal-0.9.5.ebuild
deleted file mode 100644
index ca8464444aaa..000000000000
--- a/net-analyzer/ethereal/ethereal-0.9.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.9.3-r1.ebuild,v 1.2 2002/05/23 06:50:15 seemant Exp
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A commercial-quality network protocol analyzer"
-SRC_URI="http://www.ethereal.com/distribution/${P}.tar.gz"
-HOMEPAGE="http://www.ethereal.com/"
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="virtual/glibc
- >=sys-libs/zlib-1.1.3
- =dev-libs/glib-1.2*
- snmp? ( >=net-analyzer/ucd-snmp-4.1.2 )
- X? ( virtual/x11 =x11-libs/gtk+-1.2* )
- ssl? ( >=dev-libs/openssl-0.9.6b )"
-
-DEPEND="${RDEPEND}
- sys-devel/perl
- sys-devel/bison
- sys-devel/flex
- >=net-libs/libpcap-0.5.2"
-
-src_compile() {
- local myconf
- use X || myconf="${myconf} --disable-ethereal"
- use ssl || myconf="${myconf} --without-ssl"
- use snmp || myconf="${myconf} --disable-snmp"
-
- ./configure \
- --prefix=/usr \
- --enable-pcap \
- --enable-zlib \
- --enable-ipv6 \
- --includedir="" \
- --mandir=/usr/share/man \
- --sysconfdir=/etc/ethereal \
- --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
- --host=${CHOST} ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
- dodir /usr/lib/ethereal/plugins/${PV}
-
- make install \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- sysconfdir=${D}/etc/ethereal \
- plugindir=${D}/usr/lib/ethereal/plugins/${PV} || die
-
- dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
-}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.5 b/net-analyzer/ethereal/files/digest-ethereal-0.9.5
deleted file mode 100644
index 08d48ba93256..000000000000
--- a/net-analyzer/ethereal/files/digest-ethereal-0.9.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7a02706c0f22e56a45bd8999dbb35e3 ethereal-0.9.5.tar.gz 3384282
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r1 b/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r1
deleted file mode 100644
index 08d48ba93256..000000000000
--- a/net-analyzer/ethereal/files/digest-ethereal-0.9.5-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a7a02706c0f22e56a45bd8999dbb35e3 ethereal-0.9.5.tar.gz 3384282