summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/libnasl/libnasl-2.2.5.ebuild')
-rw-r--r--net-analyzer/libnasl/libnasl-2.2.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/libnasl-2.2.5.ebuild b/net-analyzer/libnasl/libnasl-2.2.5.ebuild
new file mode 100644
index 000000000000..c7f0bcbbc176
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-2.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.2.5.ebuild,v 1.1 2005/07/24 03:31:15 vanquirius Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="=net-analyzer/nessus-libraries-${PV}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ export CC=$(tc-getCC)
+ econf || die "configuration failed"
+ # emake fails for >= -j2. bug #16471.
+ emake -C nasl cflags
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed libnasl"
+ dodoc COPYING
+}