summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/openafs/openafs-1.2.8.ebuild')
-rw-r--r--net-fs/openafs/openafs-1.2.8.ebuild110
1 files changed, 0 insertions, 110 deletions
diff --git a/net-fs/openafs/openafs-1.2.8.ebuild b/net-fs/openafs/openafs-1.2.8.ebuild
deleted file mode 100644
index e49e89a863a9..000000000000
--- a/net-fs/openafs/openafs-1.2.8.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.8.ebuild,v 1.11 2003/11/21 18:16:46 rphillips Exp $
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
-distributed computing environments. AFS performs exceptionally well,
-both within small, local work groups of machines and across wide-area
-configurations in support of large, collaborative efforts. AFS provides
-an architecture geared towards system management, along with the tools
-to perform important management tasks. For a user, AFS is a familiar yet
-extensive UNIX environment for accessing files easily and quickly."
-
-SRC_URI="http://openafs.org/dl/openafs/${PV}/${P}-src.tar.bz2"
-HOMEPAGE="http://www.openafs.org/"
-
-SLOT="0"
-LICENSE="IPL-1"
-KEYWORDS="x86 -ppc -sparc "
-SANDBOX_DISABLED="1"
-
-DEPEND=">=sys-apps/portage-2.0.47-r10
- >=sys-libs/ncurses-5.2
- >=sys-libs/pam-0.75"
-
-SYS_NAME=i386_linux24
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}/src/config
- cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
- sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
- Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
- rm Makefile.i386_linux24.in.old
- epatch ${FILESDIR}/openafs-pinstall-execve.patch
-}
-
-src_compile() {
- epatch ${FILESDIR}/openafs-1.2.8.patch
-
- ./configure \
- --with-afs-sysname=i386_linux24 \
- --enable-transarc-paths || die
- cp src/pam/Makefile src/pam/Makefile.old
- sed -e "s|-I/usr/include/sys| |g" \
- src/pam/Makefile.old > src/pam/Makefile
- rm src/pam/Makefile.old
-
- make || die
- make dest || die
-}
-
-src_install () {
-
-
-# Client
-
- cd ${S}/${SYS_NAME}/dest/root.client/usr/vice
-
- insinto /etc/afs/modload
- doins etc/modload/*
- insinto /etc/afs/C
- doins etc/C/*
-
- insinto /etc/afs
- doins ${FILESDIR}/{ThisCell,CellServDB}
- doins etc/afs.conf
-
- dodir /afs
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/afs.rc.rc6 afs
-
- dosbin etc/afsd
-
- # Client Bin
- cd ${S}/${SYS_NAME}/dest
- exeinto /usr/afsws/bin
- doexe bin/*
-
- exeinto /etc/afs/afsws
- doexe etc/*
-
- cp -a include lib ${D}/usr/afsws
- dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
-
- # Server
- cd ${S}/${SYS_NAME}/dest/root.server/usr/afs
- exeinto /usr/afs/bin
- doexe bin/*
-
- dodir /usr/vice
- dosym /etc/afs /usr/vice/etc
- dosym /etc/afs/afsws /usr/afsws/etc
-
- dodoc ${FILESDIR}/README
-
- dodir /etc/env.d
- echo 'CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws"' >> ${D}/etc/env.d/01${PN}
- echo 'PATH=/usr/afsws/bin:/etc/afs/afsws' >> ${D}/etc/env.d/01${PN}
- echo 'ROOTPATH=/usr/afsws/bin:/etc/afs/afsws:/usr/afs/bin' >> ${D}/etc/env.d/01${PN}
-}
-
-pkg_postinst () {
- echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
- echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
- echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
-}