summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/ChangeLog9
-rw-r--r--net-im/qutim/files/fix_insecure_rpath.patch14
-rw-r--r--net-im/qutim/qutim-0.2.0-r1.ebuild118
3 files changed, 140 insertions, 1 deletions
diff --git a/net-im/qutim/ChangeLog b/net-im/qutim/ChangeLog
index 774a4c98645d..e66e2cf029ec 100644
--- a/net-im/qutim/ChangeLog
+++ b/net-im/qutim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/qutim
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.2 2009/11/29 09:39:13 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/ChangeLog,v 1.3 2009/11/29 12:42:19 hwoarang Exp $
+
+*qutim-0.2.0-r1 (29 Nov 2009)
+
+ 29 Nov 2009; Markos Chandras <hwoarang@gentoo.org> +qutim-0.2.0-r1.ebuild,
+ +files/fix_insecure_rpath.patch:
+ Fix insecure_rpath issue. Fix LINGUAS installation. Fix plugins
+ installation
29 Nov 2009; Markos Chandras <hwoarang@gentoo.org> qutim-0.2.0.ebuild:
Fix phonon dependencies
diff --git a/net-im/qutim/files/fix_insecure_rpath.patch b/net-im/qutim/files/fix_insecure_rpath.patch
new file mode 100644
index 000000000000..36f062980a2d
--- /dev/null
+++ b/net-im/qutim/files/fix_insecure_rpath.patch
@@ -0,0 +1,14 @@
+Index: qutim-0.2.0/CMakeLists.txt
+===================================================================
+--- qutim-0.2.0.orig/CMakeLists.txt
++++ qutim-0.2.0/CMakeLists.txt
+@@ -46,6 +46,9 @@ ADD_DEFINITIONS( -DQUTIM_SVN_REVISION=${
+ SET (CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ SET (CMAKE_BUILD_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+ SET (CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
++SET (CMAKE_SKIP_BUILD_RPATH TRUE)
++SET (CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
++
+ LIST (APPEND CMAKE_MODULE_PATH "cmake")
+ LIST (APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+ SET (QT_USE_QTNETWORK true)
diff --git a/net-im/qutim/qutim-0.2.0-r1.ebuild b/net-im/qutim/qutim-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..6a18f68833a1
--- /dev/null
+++ b/net-im/qutim/qutim-0.2.0-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/qutim/qutim-0.2.0-r1.ebuild,v 1.1 2009/11/29 12:42:19 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils qt4 cmake-utils
+MY_PN="${PN/im/IM}"
+
+DESCRIPTION="New Qt4-based Instant Messenger (ICQ)."
+HOMEPAGE="http://www.qutim.org"
+LICENSE="GPL-2"
+SRC_URI="http://qutim.org/uploads/src/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug histman icq irc jabber gnutls mrim ssl vkontakte yandexnarod"
+
+DEPEND="x11-libs/qt-gui:4[debug?]
+ x11-libs/qt-webkit:4
+ || ( media-sound/phonon x11-libs/qt-phonon )
+ jabber? ( ssl? ( dev-libs/openssl )
+ gnutls? ( net-libs/gnutls ) )"
+RDEPEND="${DEPEND}"
+
+LANGSLONG="bg_BG cs_CZ de_DE uk_UA"
+LANGS="ru"
+
+for X in ${LANGSLONG}; do
+ IUSE="${IUSE} linguas_${X%_*}"
+done
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+PATCHES=(
+ "${FILESDIR}"/fix_insecure_rpath.patch
+)
+
+src_prepare() {
+ qt4_src_prepare
+ # fix translations directory
+ einfo "Fixing LINGUAS path"
+ sed -i "s/languages/\/usr\/share\/${PN}\/languages/" src/${PN}.cpp
+}
+
+src_compile() {
+ # build main executable
+ cmake-utils_src_compile
+ local found=0
+ # build protocol support
+ if use jabber; then
+ found=1
+ cd "${S}"/plugins/jabber || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake \
+ $(cmake-utils_use ssl OpenSSL) \
+ $(cmake-utils_use gnutls GNUTLS) ../ || die
+ emake || die
+ fi
+ # build mrim
+ if use mrim; then
+ found=1
+ cd "${S}"/plugins/mrim || die
+ mkdir build
+ cd build
+ cmake -C "${TMPDIR}"/gentoo_common_config.cmake ../ || die
+ emake || die "failed to compile mrim plugin"
+ fi
+ # Qt4 based projects so I shall use eqmake4
+ cd "${S}"/plugins || die
+ for i in histman yandexnarod icq irc vkontakte;do
+ if use ${i}; then
+ found=1
+ cd "${i}"
+ einfo "now building ${i}-plugin"
+ eqmake4 ${i}.pro
+ emake || die "failed to compile ${i} plugin"
+ cd ..
+ fi
+ done
+
+}
+
+src_install(){
+ # not recommended by upstream and probably broken
+ #cmake-utils_src_install
+ dobin "${WORKDIR}/${P}_build/${PN}" || die
+
+ cd "${S}"/plugins || die
+ insinto "/usr/$(get_libdir)/qutim"
+ [[ $found -eq 1 ]] && doins $(find . -type f -executable -iname "*.so")
+ doicon "${S}"/icons/${PN}_64.png || die "Failed to install icon"
+ make_desktop_entry ${PN} ${MY_PN} ${PN}_64.png \
+ "Network;InstantMessaging;Qt" || die "make_desktop_entry failed"
+
+ #install linguas
+ for X in ${LANGSLONG}; do
+ for Z in ${LINGUAS}; do
+ if [[ ${X%_*} == ${Z} ]]; then
+ einfo "Installing ${Z} translation files"
+ insinto /usr/share/${PN}/languages/${X}/
+ doins -r "${S}"/languages/${X}/binaries/* || die "failed to install ${X} translation"
+ fi
+ done
+ done
+ for X in ${LANGS}; do
+ for Z in ${LINGUAS}; do
+ if [[ ${X} == ${Z} ]]; then
+ einfo "Installing ${Z} translation files"
+ insinto /usr/share/${PN}/languages/${X}/
+ doins -r "${S}"/languages/${X}/binaries/* || die "failed to install ${X} translation"
+ fi
+ done
+ done
+
+}